LuckyDeuce Jul 25, 2013 @ 12:24pm
Jake's Barrens mission???
Hate to post what seems like should be a simple question, but I'm stuck.
[VERY SLIGHT SPOILER]

EARLY in the game, I've got Jake and we're going to get back at the Halloweeners that jumped him. I go on South, find and wipe 3 enemy Halloweeners. Then I stroll on to the little yellow diamond icon on the screen and nothing happens. Can't interact with it or the flashing bones (looks like a pile of bones on the ground). Walked around the whole map 3 times. Can't go into Seamstress Union as it says to complete investigation...

Soooooooooo, am I missing something or is this a bug?
Showing 1-11 of 11 comments
< >
LuckyDeuce Jul 25, 2013 @ 12:34pm 
Actually, it's not a pile of bones, but a flashing lamp... couldn't tell. Still though, nothing happens when standing in, on, around the icon... frustrating.
Rhenthyl Jul 25, 2013 @ 12:36pm 
Jake should have left you, saying his bounty is to high for Lone star to ignore, he'll give you 1000 and disappeare. Talk to the old tramp, and then the cop and decide how to handle him (i bribed him) that should open it up. also you have to follow the path around to the point, you cant just walk right to it
LuckyDeuce Jul 25, 2013 @ 12:45pm 
Thanks for the help, but it was a bug. Restarted the level and this time after killing the 'weeners a Troll showed up to the fight. Had to reboot the game though to get it. Makes the lack of a save out of combat particularly annoying though.
BillyRayOsiris Jul 25, 2013 @ 1:27pm 
I've tried rebooting the game and restarting the level twice now, still the same issue. Any ideas?
LuckyDeuce Jul 25, 2013 @ 1:34pm 
Yeah, the first time when it failed to progress I had done the optional mission to help the vendors with their gang problem first. The second time, when it was succesful, I did Jake's mission first. Don't know if that's related or not, but something to try.
BillyRayOsiris Jul 25, 2013 @ 1:41pm 
Ok, I think I understand your comment now, LuckyDeuce. For anyone else that happens to run into this bug, you need to close out of the game and restart it completely, then once you've loaded your save you need to restart the level (it seems redundant but it works). Thanks for the help!
BillyRayOsiris Jul 25, 2013 @ 1:42pm 
Just saw your reply, I thought that might have been an issue too, but I was able to do the optional mission before the fight and it still worked.
sciencedude Jul 25, 2013 @ 2:51pm 
I have a same bug. And yes, I've finished optional objective before main (deal with Halloweeners). Trying to restart from checkpoint.
BillyRayOsiris Jul 25, 2013 @ 4:14pm 
Yeah, just restart the game then restart the level and the troll should appear at the end of the fight with the three Halloweeners. Good luck!
BlackVoid Aug 25 @ 12:01am 
So nice, that this is still bugged after more than a year.
BlackVoid Aug 25 @ 12:05am 
I have tried to restart level and the game restarts the whole adventure and goes to character creation. What a bugged mess. Uninstalled and will never buy anything from this developer again.
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: Jul 25, 2013 @ 12:24pm
Posts: 11