yoshi314 Feb 12 @ 10:37am
Fix for linux version not starting from steam client
I could not get linux version to start from steam client. It expects libSDL2 to be in the system. Which wasn't there in my case.

I had to modify "runme" script, adding two lines there :

TOP="${HOME}/.local/share/Steam/ubuntu12_32/steam-runtime"

#lines broken for clarity
export LD_LIBRARY_PATH="${TOP}/..:\
${TOP}/i386/lib/i386-linux-gnu:${TOP}/i386/lib:\
${TOP}/i386/usr/lib/i386-linux-gnu:${TOP}/i386/usr/lib:\
${LD_LIBRARY_PATH}"

./teleglitch32


This makes the game work using libraries provided with steam. Tested on 64bit gentoo.
Date Posted: Feb 12 @ 10:37am
Posts: 0