Europa Universalis: Rome - Gold Edition

Europa Universalis: Rome - Gold Edition

Borock Obomo Mar 1, 2013 @ 8:41pm
"Fails To Start Game" as it says
Whenever I try to start playing Europa Universalis Rome, it says that there is an unknown error, and it won't start. I recently bought this game today, and it's expansion, both for $10.00 in a Gold Edition. Please Help. The website for support does nothing at all.
< >
Showing 1-15 of 15 comments
SilentN4saken Mar 2, 2013 @ 7:21am 
samething here tried everything i can think of still cant get it to run :(
Borock Obomo Mar 3, 2013 @ 2:41pm 
Hey Silent, I found out. In another discussion, there are 2 links to a microsoft enhancerm helping you run the game. Go downlaod them.
Borock Obomo Mar 3, 2013 @ 2:42pm 
Enhancer*. Go to the "Don't start the game" discussion, and there will be 2 links to downloadable content to run the game. Go download them.
Doktor Dirch Mar 10, 2013 @ 12:30pm 
Same problem here. Purchased EU Rome and Vae Victis start of march 2013 and it worked once. Now I get the "Steam error" box with the nonsence message "Failed to start game (unknown error)"
Last edited by Doktor Dirch; Jun 6, 2013 @ 1:16pm
SilentN4saken Apr 29, 2013 @ 2:45pm 
i dont know if anyone is still following this but i found a werid work around i installed eu rome from steam then closed steam and installed the eu rome demo from a different website into the eu rome steam folder reopened(signed into) steam, installed eu rome vae victis then restarted steam one more time just to make sure. not sure if that last part (restarting steam) is nessisary and then i was able to play it no problem
Doktor Dirch Jun 6, 2013 @ 1:17pm 
Thanks for the tip - will try when I have time. I must admit that I gave up on steam and got the game from other "channels" - a true local installation - that worked, just like ye olde days :)
SilentN4saken Jun 23, 2013 @ 5:17pm 
? just uninstall and re install didnt work for me
SilentN4saken Jun 23, 2013 @ 9:53pm 
nice nice
intspod Jul 4, 2013 @ 1:35am 
I too have been blighted by this error. I tried installing the Ms C++ packs recommended. I tried reinstalling. I tried verifying the cache. Nothing works. I will try the demo jink as a last resort. Why don't Steam/Paradox fix this?
rlnormanjr Sep 17, 2014 @ 7:22am 
There has been some glitches with Windows 7. The game kept on giving me "Failed to Start" until I downloaded the Microsoft Visual C++ 2008 Redistributable Package (x86) from http://www.microsoft.com/en-us/download/details.aspx?id=29
Ibux Oct 3, 2015 @ 4:42am 
nothing helps ffs
vc 2005 did it for me. (2008, 2012, and 2015 did not work)
Last edited by ♥Automne & Vyllis♥; Dec 17, 2015 @ 2:00pm
Metamucil Monk Mar 26, 2016 @ 10:12am 
It took the vc 2005 that came with Fallout Tactics to fix it for me. The one I downloaded from Microsoft seemed borked in some way. (Windows 10 Pro)
LordOfPants Jul 11, 2016 @ 5:22pm 
I had this problem with Windows 10 64 bit Home, I was able to fix it by installing the Microsoft Visual C++ 2005 SP1 Redistributable Package (x86) . Yes, it apparently needs the x86 version even on 64 bit windows. Here's a direct link to MS's download for it: https://www.microsoft.com/en-us/download/confirmation.aspx?id=5638
Don Feloni Sep 4, 2016 @ 3:33am 
Originally posted by LordOfPants:
I had this problem with Windows 10 64 bit Home, I was able to fix it by installing the Microsoft Visual C++ 2005 SP1 Redistributable Package (x86) . Yes, it apparently needs the x86 version even on 64 bit windows. Here's a direct link to MS's download for it: https://www.microsoft.com/en-us/download/confirmation.aspx?id=5638

Thanks Lord! You just saved me this game and Paradox a few bucks! (Y)
< >
Showing 1-15 of 15 comments
Per page: 15 30 50