Europa Universalis: Rome - Gold Edition
NinjaBerry3 Mar 1, 2013 @ 8:41pm
"Fails To Start Game" as it says
Whenever I try to start playing Europa Universalis Rome, it says that there is an unknown error, and it won't start. I recently bought this game today, and it's expansion, both for $10.00 in a Gold Edition. Please Help. The website for support does nothing at all.
Showing 1-13 of 13 comments
< >
SilentN4saken Mar 2, 2013 @ 7:21am 
samething here tried everything i can think of still cant get it to run :(
NinjaBerry3 Mar 3, 2013 @ 2:41pm 
Hey Silent, I found out. In another discussion, there are 2 links to a microsoft enhancerm helping you run the game. Go downlaod them.
NinjaBerry3 Mar 3, 2013 @ 2:42pm 
Enhancer*. Go to the "Don't start the game" discussion, and there will be 2 links to downloadable content to run the game. Go download them.
larsdirchsorensen Mar 10, 2013 @ 12:30pm 
Same problem here. Purchased EU Rome and Vae Victis start of march 2013 and it worked once. Now I get the "Steam error" box with the nonsence message "Failed to start game (unknown error)"
Last edited by larsdirchsorensen; Jun 6, 2013 @ 1:16pm
SilentN4saken Apr 29, 2013 @ 2:45pm 
i dont know if anyone is still following this but i found a werid work around i installed eu rome from steam then closed steam and installed the eu rome demo from a different website into the eu rome steam folder reopened(signed into) steam, installed eu rome vae victis then restarted steam one more time just to make sure. not sure if that last part (restarting steam) is nessisary and then i was able to play it no problem
larsdirchsorensen Jun 6, 2013 @ 1:17pm 
Thanks for the tip - will try when I have time. I must admit that I gave up on steam and got the game from other "channels" - a true local installation - that worked, just like ye olde days :)
mattlemus03 Jun 22, 2013 @ 11:51pm 
just uninstall and re install it
SilentN4saken Jun 23, 2013 @ 5:17pm 
? just uninstall and re install didnt work for me
mattlemus03 Jun 23, 2013 @ 8:39pm 
rlly it worked for me
SilentN4saken Jun 23, 2013 @ 9:53pm 
nice nice
intspod Jul 4, 2013 @ 1:35am 
I too have been blighted by this error. I tried installing the Ms C++ packs recommended. I tried reinstalling. I tried verifying the cache. Nothing works. I will try the demo jink as a last resort. Why don't Steam/Paradox fix this?
mattlemus03 Jul 4, 2013 @ 10:02am 
these error are made by more than one party paradox and sich made mount and blade and its very slow at high quality thats why in order to fix this problem try to find the other web designner
rlnormanjr Sep 17 @ 7:22am 
There has been some glitches with Windows 7. The game kept on giving me "Failed to Start" until I downloaded the Microsoft Visual C++ 2008 Redistributable Package (x86) from http://www.microsoft.com/en-us/download/details.aspx?id=29
Showing 1-13 of 13 comments
< >
Per page: 15 30 50