[Banner Pilot] Feb 9, 2013 @ 4:39am
♥♥♥♥ing crap
lost my playonline id and password so i cant transfer it and square enix wont contact me. ♥♥♥♥♥♥ service. no chat support or phone support no contact at all. but hey! they are active on facebook and filling my mailbox with adds all the time! but no ♥♥♥♥ing help!!
Last edited by [Banner Pilot]; Feb 9, 2013 @ 4:40am
Showing 1-12 of 12 comments
< >
Maodox Mar 26, 2013 @ 6:04pm 
So their service is ♥♥♥♥ because you can't keep track of your own information. Nice.
Dartanian Apr 7, 2013 @ 9:17pm 
^

You know there is this thing called "AUTOMATICLY GET YOUR ♥♥♥♥ING ID EMAILED TO YOU" You know just click the button
[Banner Pilot] Apr 8, 2013 @ 1:55am 
♥♥♥♥ING ♥♥♥♥ THANK ♥♥♥♥ING YOU
Fox702 Apr 19, 2013 @ 4:26pm 
Similar problem here
When Steam had its first Publsher sale years ago it was for SquareEnix I mostly bought it for this game which I cannot even play
Worthless game, yet they keep trying to hype it by making "Ultimate Editions"
Theresa Barkskin Apr 20, 2013 @ 3:15pm 
Originally posted by Matthewlh:
Similar problem here
When Steam had its first Publsher sale years ago it was for SquareEnix I mostly bought it for this game which I cannot even play
Worthless game, yet they keep trying to hype it by making "Ultimate Editions"

It would help if you explained your problem.
Fox702 Apr 20, 2013 @ 3:29pm 
I can't quite remember it was over a year ago before the Community forums
I installed the game. It wouldn't let me log in. I required some form of ID player ID or something of that sort
It was right after the Ultimate Edition came out. I checked my emails. I tried contacting them. They said they didn't understand my issue. It was nonsense.
I'm guessing it had to do with the new edition coming out, but I really don't know.
After spending so many hours on it I gave up. I can't explain the issue too well as it happened over a year ago.
Even before that I did successfully log in. And I figured somewhere in my emails I'd find something related to the game, but found nothing. I wanted to give it a 2nd chance with the release of the Ultimate Ed
jciii Jul 12, 2013 @ 2:08am 
i am also having a problem. i reactivated from their web page, but when entering password after playonline screen it just goes back to login screen. i liked it when they had a voice phone support
☆Crysumpom☆ Sep 26, 2013 @ 2:06am 
Using hearts to blurb out profanity made me lol. Good sport. :p
Also when it comes to Squeenix service and support i have my issues too. They're rather unsupportive in my experience. But i hope that "AUTOMATICLY GET YOUR ♥♥♥♥ING ID EMAILED TO YOU" suggestion by Dartan work out.
.:FairlyKeefin|SweedishChef:. Oct 31, 2013 @ 8:49pm 
Having a similar problem with XIV, I have a 1.0 account that I even have my code for and haven't been able to get it back. Pretty ♥♥♥♥in mad about it.
Sogame Jan 17, 2014 @ 3:21pm 
Your PLAYONLINE ID was emailed to you when you first created the account.
Search the emai lassociated with your account for SquareEnix and you should be able to find it.

If not, try calling them. Their phone support is bad compared to Blizzard's, but they'll eventually help you out.
Just think about it: Either the account stays dead; or they help you out and they get your $9.99/month. It's not in their best interests to deny you help.
[Banner Pilot] Jan 20, 2014 @ 8:02am 
playing ff14 a realm reborn. no worries im over it
CoryJXX Apr 14, 2014 @ 11:30pm 
every problem stated was bs, they have online and phone support, recovered my account info in 15 minutes, not sure if bad customer service or just bad customer..
Showing 1-12 of 12 comments
< >
Per page: 15 30 50