LOLLERCOASTER Jul 18, 2013 @ 11:44am
Achievements do not work!!!
The achievements I have unlocked are remembered in the game but Steam does not recognize. Help!
Showing 1-15 of 48 comments
< >
[NCE]Splattercat Jul 18, 2013 @ 2:24pm 
Same problem **Update** Mine finally updated, must have been lag related to servers or something of that nature. After resetting steam everything is squared away.
Last edited by [NCE]Splattercat; Jul 18, 2013 @ 3:13pm
LOLLERCOASTER Jul 18, 2013 @ 4:33pm 
Really? I still have no sign of them. What did you do?
Oddbrother Jul 18, 2013 @ 4:40pm 
You're not playing on a Linux system, are you?
LOLLERCOASTER Jul 18, 2013 @ 4:43pm 
I am on Mac. :/
hippiehater805 Jul 18, 2013 @ 8:45pm 
same problem, also on a mac.
stephen51 Jul 19, 2013 @ 6:23am 
Happening to me too, on Windows. The first time I played the game it worked fine, since then it hasn't tracked any of my achievments on steam. Hopefully it'll get resolved.
Repth Jul 19, 2013 @ 7:17am 
If I'm not mistaken, Take No Prisoners and The Loner have been bugged for quite some time and will not register. I'm having problems with Sleuth, Grave Robber, and Marathon registering. No matter how many graves or points of interests I visit or times I beat the game, the bar never moves. Meh...
Last edited by Repth; Jul 19, 2013 @ 12:26pm
mira810303 Jul 19, 2013 @ 12:01pm 
Repth - When you complete the game, do you skip the credits sequence, or play through it to completion? I don't know if this is anything, but, when I was working on those achievements (Sleuth, Grave Robber and Marathon, that is), once I stopped skipping the credits, things started to register again.
Repth Jul 19, 2013 @ 12:24pm 
Oh wow, interesting point. For my first playthrough I let the credits play for a good 3 minutes or so before I skipped and everything registered. For my other playthroughs I skipped it as soon as the credits let me and nothing registered.

It seems silly that skipping part of the credits would block achievements. Should be fixed. Thanks for the insight, mira810303.
Last edited by Repth; Jul 19, 2013 @ 12:25pm
0gb.us Jul 19, 2013 @ 4:00pm 
I'm not sure server lag is to blame for the achievements failing to register. Achievements in other games still work as they should. Then again, I'm also not sure that server lag isn't the issue. It could be, or it could not be.
thedudenfresh Jul 19, 2013 @ 8:28pm 
I've been getting several achievements for this game, and I've loaded up the game many times, but Steam STILL doesn't recognise my unlocked achievements. I'm NOT earning them again, I got my achievements fair and square and I'm not reinstalling the game again to make Steam recognise my achievements. Steam better make an update patch for these buggy achievements because I'm ♥♥♥♥ed off right now!
digitalsiren Jul 19, 2013 @ 8:30pm 
I, too, have the same issue. Started playing on the 15th and Steam hasn't recognized a single achievement. Is re-installing the game even a potential solution?
skru_loose Jul 20, 2013 @ 12:54am 
The first and second times I played (when I got it a few months ago, and then again last night), I played and the game recognized achievements. My first play was the Campaign Mode, which I played through to the very end (credits included). My second play, last night, was the Endless Mode. On both plays, I was able to be credited with Steam Achievements. I know that the achievements I got in Endless popped immediately, without having to end the playthrough; I, unfortunately, don't recall if the first playthrough on Campaign popped before or after (or both) the ending.

I just finished a second playthrough on the Campaign, and I'm pretty sure (though not 100% positive) that I should've gotten the Romero achievement (survive with George Romero in your party) though I'm unclear if that's just that he has to be in the party or YOU (the "leader" character; he was just a group member) actually needs to be named as such so I admit freely I may not have correctly satisfied the requirement.

I didn't watch the credits to completion, instead skipping them, and no ding. It's possible I didn't correctly fulfill the requirement for that to complete, or it could be that I didn't watch the credits through all the way so the game didn't report to Steam correctly. I'll playthrough again sometime soon and try to remember to come back to the thread and update this if it's still a going concern. It did appear, though, that a few of the incremental achievements have updated tonight on this playthrough (specifically, my "visit gravesites" one incremented for the two gravestones I visited on my last Campaign playthrough).

It may also be important to note that the game does have achievements, of a sort, that are completely separate from the Steam ones -- the Endless Mode does have Skulls awarded for achievements within the Endless Mode play that open up differing loadouts, etc.. Some of them are related to Steam, but not all of them. It's not completely clear to me if that might be a point of confusion for us.

Also: anyone who's having troubles around the point where I posted this, it does appear to me that Steam is lagging rather heavily during the last day or so. A purchase I made hours ago should've awarded a Summer Trading Card that didn't appear til an hour ago or so where a purchase a few days ago that should've resulted in a card did so immediately. I also noticed that the servers are having lagging severly right now in loading up the Store or any of my Inventory or Badge pages.
skru_loose Jul 20, 2013 @ 3:31am 
Ok, so I just completed another playthrough - Campaign Mode on Easy (foolishly, I expected it to be faster, but the RNG hated my guts thoroughly). In the playthrough, I managed to get the following Steam Achievements:

-- Make the Call (Put down an infected party member who has passed out.)
-- I Know a Guy... (Make it to Safe Haven with George Romero in the party.)
-- Trader Jose's (Beat the game without trading anything on the road.)
-- Penniless (Make it to Safe Haven without starting with any money or selling anything.)


And, although this would be my third complete and successful playthrough, the following Achievement finally incremented to 1/5:

-- Marathon (Beat the game five times.)


Each of the four did credit to me as soon as I'd fulfilled the requirements: Make the Call dinged as soon as my shot landed on the incapacitated infected party member, and the other three dinged as soon as I finished fueling up the generator to end the "Enter Safe Haven" sequence of the game.

When setting up this playthrough, I realized that the issue that *I* had with the "I Know a Guy..." Achievement was purely my fault: I put in "George Romer" into the name field, not realizing that "George Romero" would not fit -- in order to get that to work, for me, I had to put "GeorgeRomero" into the name field. There's another thread on the forums talking about it -- apparently some people didn't have an issue and either option would work for them; for me it only worked without a space. Also, my George got bit about halfway through but it appears that the Achievement should ding provided he's alive. He didn't have to be uninfected.


I believe that I should have received the following Steam Achievement:

-- Take No Prisoners (Always choose to shoot your way through zombie hoards.)

Each time I had the option to shoot my way through, I did so. I was not always successful, and the last two times I did have the Chainsaw Windows Upgrade, but nothing in the description indicates that I must be successfull every time or forgo this Upgrade, so I believe that I should have gotten it.

Providing that there's not something I did wrong, or my understanding of that one is incorrect, I can confirm that Organ Trail isn't always correctly awarding Steam Achievements.
mindoug Jul 20, 2013 @ 6:04am 
Sleuth, Marathon, Grave Robber no longer updated in the last two passes.
Take No Prisoners (game with Chainsaw Window) - not counted.
Showing 1-15 of 48 comments
< >
Per page: 15 30 50