Mr Nice Guy Apr 27, 2013 @ 10:21am
Can't play / install: msiexec, .NET framework, XNA Framework and / or error code 2908
Bought the game and installed it, but it tries to install msiexec then just closes out without starting or displaying anything game related, which appears to be the error at https://support.steampowered.com/kb_article.php?ref=6218-USFX-5568. Yes, I've restarted my computer.

The first time I tried this, the steam popup also said it was installing .NET framework 4.0, but it only says it's installing msiexec for subsequent attempts.

I already tried directly installing from the dependency folder, in this case _CommonRedist. The .net Framework in the DotNet folder was apparently already installed, so I just repaired it. When trying to install the XNA framework, the installation process stops halfway through with error code 2908. I didn't see any installer for msiexec.

I had similar (possibly the exact same) problems installing Gnomoria and Wizorb, which also uses XNA / .net Framework:
http://steamcommunity.com/app/224500/discussions/0/810920513828877441/

I've also asked Microsoft support about the problem in 2 separate threads, but they apparently gave up after "turn it off and on again" didn't work:
http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/net-framework-initialization-error/21d069d4-44b7-403a-9e1f-de6d75ffdc36
http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/problems-installing-xna-framework-error-code-2908/af80e635-b2fa-477f-ac49-e6781d699f54

It's not directly game related, but I'd really like this problem fixed. I love indie games like this, but I'm not going to keep buying them if every single one won't start because they depend on XNA framework.
Showing 1-6 of 6 comments
< >
ZeggyZon Apr 28, 2013 @ 1:33am 
"msiexec" is a program microsoft uses to "Provides the means to install, modify, and perform operations on Windows Installer from the command line. To install or configure a product"

So either msiexec is failing or isn't even installed correctly. You could also try this:

I too managed to corrupt my .net framework and thought I'd have to re-install windows but I manages to fix it by doing the following.

I used a tool called dotnetfx_cleanup_tool and removed all traces of .net framework from my computer. Even then .net framework refused to install. I downloaded .net framework 4.5 from http://www.microsoft.com/en-us/download/confirmation.aspx?id=30653 and that successfully installed even though 4.0 didn't.

This fixed my issues but it may vary for you

You can open up windows "add/remove programs" utility and see if XNA or .net framework 4.0 or 4.5 is listed and if it is its probably correctly installed.
Mr Nice Guy Apr 28, 2013 @ 1:03pm 
I've completely removed / re-installed the .NET framework multiple times from version 2.0 to 4.5, all of which said it installed successfully, but nothing removed the 2908 error code when trying to install the XNA framework. Someone in a Terraria thread had the same problem as me, and apparently the cause is mscoree.dll in system32 not updating when the .NET framework gets installed / updated:
http://www.terrariaonline.com/threads/microsoft-xna-framework-4-0-problem.5540/
Their answers all go out to broken / old links, and I can't figure out what to do.
silvaril May 3, 2013 @ 1:39am 
Heya

Please check to see if the following helps:
http://petermarcu.blogspot.ca/2011/07/net-net-framework-4-setup-reports.html

Alternatively, you may find that the following helps:
http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

Please let us know how things work out.
Mr Nice Guy May 3, 2013 @ 2:09pm 
Originally posted by silvaril:
Heya

Please check to see if the following helps:
http://petermarcu.blogspot.ca/2011/07/net-net-framework-4-setup-reports.html

Alternatively, you may find that the following helps:
http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

Please let us know how things work out.

I have TrustedInstaller on my system, but its version
v6.1.7600.16384 when the author suggests the version be at least
v6.1.7600.16385. I'm trying to reinstall windows 7, but I bought this computer pre-made from Ebay and I'm not sure how / where he downloaded Windows 7 from. Is this installer somewhere on my system, or can I check somehow?
silvaril May 4, 2013 @ 3:06am 
Heya

I would check to see what Windows 7 key sticker, if any, is on your machine before reinstalling.

You may have trouble finding a version of Windows 7 that uses the key attached, if any, as OEM install software does not accept the same license keys as Retail install software.

Hopefully the install media would have been delivered with the machine.
Alternatively, there may be an OEM partition on the hard drive with a reinstallation image on it.

Check for keys, software or partition before proceeding...
Nertonius Maximus Jul 17, 2013 @ 7:33am 
So I know this thing can look kinda sketchy but it's the easiest way I found to update the mscoree.dll problem you get when Framework 4.0 doesn't update the extension properly. I was having trouble playing Terraria, Rogue Legacy and Precipice of Darkness 3 but this quickly updated the mscoree.dll and I was fine to play right away.

http://www.dll-files.com/dllindex/dll-files.shtml?mscoree
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Apr 27, 2013 @ 10:21am
Posts: 6