sacredcat Oct 24, 2013 @ 5:54am
Can't patch to v1.02
I can't figure out how to patch the game to v1.02

Do I have to download a patch? Does Uplay or Steam patch the game? I tried installing the game using both Win 7 x32 and x64 and it is always v1.00 when I start.

When I try to patch the game using this file - FC3_Blood_Dragon_update_1.01.exe or FC3_Blood_Dragon_update_1.02_WW.exe (both of which I downloaded from other sites) it says "could not retrieve version number".

Any help would be greatly appreciated.
Showing 1-13 of 13 comments
< >
sacredcat Oct 24, 2013 @ 6:00am 
Over here it says "If you have purchased the game directly through Steam, the latest patch will automatically install when you launch the game."
https://support.ubi.com/en-gb/FAQ.aspx?platformid=9&productid=4567&faqid=kA030000000eY0tCAE

The latest patch isn't being installed through steam.
[RC]***Sgt.D_Nukem*** Oct 24, 2013 @ 11:40am 
I tried to download both patches, and got the same error message the OP just mentioned.

oh, and by the way, what do these patches do for the game??
Release notes – PC patch 1.01
----------------------------------------------

----------------------------------------------
Fixes for the patch:
----------------------------------------------

General:
- Improved overall stability.
- Fixed the sound turning off after dying under some circumstances
- Fixed Spider’s navigation from getting stuck in certain situations
- Fixed UI for both HDAO and HBAO options which were being reset to default values after a change was applied

Release notes – PC patch 1.02
----------------------------------------------

----------------------------------------------
Fixes for the patch:
----------------------------------------------

General:
- Fixed desynchronized video and audio in cinematics

Gameplay:
- Reset Garrisons Option: Resets garrisons to their hostile state. You must liberate all Garrisons to unlock this feature. All incomplete side missions and quests will become hidden.


WTF Steam & Uplay it won't upgrade to v1.02


A symptom is the following error: There was a problem starting your game. Make sure you have no other games running that use the Ubisoft Game Launcher

Navigate to the [Game] folder: C:Program Files (x86)Steamsteamappscommon[Game]
Locate [Game].exe
Right Click and select properties
In the compatibility tab select the option to run as admin
Follow steps a & b for [Game]_d3d11.exe (if applicable)
Create a shortcut on your desktop for the game’s .exe file.
Right click on the shortcut and select Properties.
Set the Target to: “C:Program Files (x86)Steamsteamappscommon[Game][Game].exe” “-uplay_steam_mode” (Remember to include the quotation marks and change “C:” to which ever drive the game is installed to.)
Apply changes and launch the game from the icon.

Cloud saving from Uplay always broken & patchfinding too! Gonna report this to steam/ubi support !
MutoidMan May 29 @ 7:28am 
I too am experiencing the updating problem. Also, I am having a problem with the game defaulting to windowed mode when starting from Steam.
Wolf May 29 @ 11:35pm 
And no one of you experiencing Uplay being broken from 3 days now ? Looking for updates up to 3 minutes , after logging telling you you have internet problems , not sinking your save games ?
I m sure Uplay server are satured with watch_dogs problably they can't be reliable
MutoidMan May 30 @ 10:31pm 
Fixed problem of defaulting to windowed mode and extremely slow start-up times for Uplay and FC3BD by uninstalling Uplay and reinstalling it in a directory other than Program Files (x86). Startup is of both Uplay and FC3BD takes only a scant few seconds now.

However FC3DB is still not updating through Steam.
Last edited by MutoidMan; May 30 @ 10:31pm
i ve sent question request to both Uplay & steam i will copy paste their answere here stay tuned
Hello,

A staff member has replied to your question:

Hello,

Thank you for contacting Steam Support.

Patches for third party games can only be distributed through Steam once the following two actions have occurred:

(1) The Publisher has provided us with the necessary files
(2) The Publisher has given us permission to release the update

The latest patches will be released as soon as possible, and will be downloaded automatically when available.

If you have questions about the availability of a specific patch, please contact the support department for the game in question.

Your patience is appreciated, please let us know if you have any other questions.

Ubisoft | Uplay support answer coming next week
Last edited by SHOUBI (paweknized connection); May 31 @ 12:26pm
MutoidMan Jun 2 @ 7:07am 
Thanks for the update. Curious as to what Ubisoft's response will be.
Epic Communication History with Ubi support !!!

Product
PC
FAR CRY
Far Cry 3: Blood Dragon
Created Date 5/30/2014 9:18:16 AM

Description According to Ubisoft|Uplay it says:
"If you have purchased the game directly through Steam, the latest patch will automatically install when you launch the game."
https://support.ubi.com/en-gb/FAQ.aspx?platformid=9&productid=4567&faqid=kA030000000eY0tCAE
The latest patch isn't being installed through steam!

So far i've already run in admin mode both game .exe & add "-uplay_steam_mode" in set launch options (Steam game properties)

But it seems Steam Client can't grab v 1.02 package (chglog here: http://steamcommunity.com/app/233270/discussions/0/792924952385258734/#c522728730194538557 )

I'm currently also sending a similar request to the Steam support as well!

NB: i m resigned to always force fullscreen mode once in game because always reset to windowed!

...................................................................................................................................
Thank you for contacting Customer Service Ubisoft! We confirm that we have received your message. We do our best to meet you in the next two days (Monday - Friday).
...................................................................................................................................

Immanuel 6/2/2014 2:04:34 PM

Wilt u zo vriendelijk zijn om een screenshot te maken van het probleem of de foutmelding zodra deze zichtbaar is?

U doet dit als volgt:

Zodra het probleem of foutmelding zichtbaar is op uw beeldschermscherm, drukt u de toesten “Ctrl” en “PrintScreen” tegelijkertijd in alsof u een foto maakt.
Deze handeling slaat het huidige scherm op in het geheugen.

Indien u een screenshot uit het spel heeft gemaakt (b.v een in game screenshot van een foutmelding), ♥♥♥♥ u vervolgens het spel afsluiten.

Gaat u dan naar “Start” > “Alle Programma’s” > “Bureau Accessoires” > gaat, klik dan op het programma “Paint”.

Wanneer het programma “Paint ” is opgeladen, drukt u gelijktijdig op de toets “Ctrl” en de toets “V”.

Als alles goed is gegaan ziet u nu een schermafdruk van het moment dat u op de printscreen toets gedrukt heeft. Mocht dit niet het geval zijn, dan is het niet goed gegaan met de 'printscreen toets'.
U ♥♥♥♥ dan ook het beste vanaf stap 1 opnieuw proberen om de printscreen correct te maken.
Als u wel een schermafdruk ziet staat, dan ♥♥♥♥ u naar 'Bestand' gaan en op 'Opslaan' klikken (of u klikt op de toetsencombinatie 'ctrl+v')

In het menu dat u nu te zien krijgt ♥♥♥♥ u bepalen waar u de zojuist gemaakte screenshot wilt opslaan, dit kan in principe overal zijn maar het makkelijkst is wanneer u links op 'bureaublad' klikt en de afbeelding opslaat als een *.jpg bestand.
Dit kun u doen door onder het veld waar u de bestandsnaam invoert te klikken en voor JPG(*.JPG) te kiezen. Uw schermafdruk zal dan worden opgeslagen op uw bureaublad zodra u op de opslaan knop heeft gedrukt.

De volgende stap is uw opgeslagen .jpg file als bijlage toevoegen aan dit incident.




SHOU8ISHOCK 6/3/2014 3:13:39 PM

Why do you answer with such a language?
Pourquoi vous répondez en néerlandais je suis liégeois bon sang!!?

Votre réponse ne m'est pas utile je n'ai aucun message d'erreur, je vous demande pourquoi n'ai je pas accès au patch 1.02 sur la version que j'ai via Steam?!
Vous le faites exprès non?! Je ne parle pas de captures d'écran il me semble..

"Why Steam Client can't grab v 1.02 package (chglog here: http://steamcommunity.com/app/233270/discussions/0/792924952385258734/#c522728730194538557 )"

Damn it!


Originally posted by MutoidMan:
Thanks for the update. Curious as to what Ubisoft's response will be.
still curious ?! ^^
Last edited by SHOUBI (paweknized connection); Jun 3 @ 8:31am
MutoidMan Jun 3 @ 1:59pm 
What, Huh?!?
MutoidMan Jun 5 @ 9:57am 
I checked the readme file and it lists the game as being V1.02 so maybe the game just doesn't report it. Would be nice to have confirmation.
sacredcat Jun 7 @ 7:57am 
When I played the game several months ago, the 'reset garrison' feature was available (which is a feature of the patched version). So I guess this means that the Steam version is patched even though it still shows as v1.00
Showing 1-13 of 13 comments
< >
Per page: 15 30 50