legend_forge Jun 2 @ 6:25pm
Irritating Graphics Glitch
Whenever I play the game looks great except for these huge blue squares layered over everything. They seem to be tied to bases somehow, but I can't get rid of them. I updated my drivers, played with the settings, even uninstalled and reinstalled Uplay. Nothing seems to help. Any fixes?
Showing 1-8 of 8 comments
< >
Sh@rktejo Jun 20 @ 2:50pm 
Sorry mate, there isn't a fix for this issue, this only occurs on laptop GPU's, i have a Geforce GTX 770m and i'm affected.
I searched all over the web for a fix, but there is none that works, ubisoft oficial forum as an oficial awnser, basically their saying that mobile GPU's are not supported, so they will not fix it.
But if you have a Desktop computer the game will play just fine.
Ubisoft at it's best :(
legend_forge Jun 20 @ 7:16pm 
This is the only game I have had an issue with from Ubisoft. I'm not too upset overall, just annoying.
Afrobear345 Jun 20 @ 8:39pm 
Im having the same issue with a 660m, glad im not the only one.
dfromdub Jun 21 @ 6:53am 
HI guys, I bought the game yesterday and had the same problem. Somehow it seems to be fixed now even though I don't know what did it.
I am on a laptop as well, I have a GTX 765m and an Intel card.

Here is what I did in order: [These are all "possible fixes" I read around on the internet]
- I verified the cache here on steam. That results in steam saying that 50 files are missing and in a 2GB download (the whole game). Also, I uninstalled and reinstalled Uplay.
(It did not work)
- I tried to manually disable SSAO in the configuration xml file (Documents/my games/Far cry blood dragon/GamerProfile.xml). I just edited the SSAO from =6 to =0.
(It did not work)
- I read the issue disappear using DirectX 9 instead of 11. Changed that, and reloaded the game.
(it did not work)
- As suggested by somebody I went in the game folder (/steamapps/common/Far cry blood dragon/). There is a folder called "support, entered that and then "directX" folder. I found DXSETUP.exe and executed it.
I reloaded the game and... It did not work

I shut down my laptop and went doing something else. Today I switched the machine on, loaded the game and no more blue squares!!! Well go figure that...
I don't know if it is because I never rebooted the machine after the steps I described above, but it might have something to do with it.

I did not go back to DX 11 because I feel it might re-break the game so I'll stick to DX 9. This means no AA etc. The game is not as pretty as it could be but it's better that the blue squares.
Unfortunately it seems this issue was present at day 1, but Ubi never bothered fixing it and just blamed laptops, thus they will never fix it.

I hope this might be useful to you
Last edited by dfromdub; Jun 21 @ 6:55am
legend_forge Jun 21 @ 9:48am 
I hadn't tried messing with DX, I'll give that a shot and report back.
wade Aug 4 @ 6:01pm 
Originally posted by dfromdub:
- As suggested by somebody I went in the game folder (/steamapps/common/Far cry blood dragon/). There is a folder called "support, entered that and then "directX" folder. I found DXSETUP.exe and executed it.


This fixed it for me and I love you and want to have your babies.
Zulu Aug 12 @ 9:06pm 
By executed you mean delete right?
Originally posted by Captain Wade:
Originally posted by dfromdub:
- As suggested by somebody I went in the game folder (/steamapps/common/Far cry blood dragon/). There is a folder called "support, entered that and then "directX" folder. I found DXSETUP.exe and executed it.


This fixed it for me and I love you and want to have your babies.
dfromdub Aug 13 @ 2:44am 
Originally posted by Zulu:
By executed you mean delete right?

No man, I meant double-click on it. ;)
Last edited by dfromdub; Aug 13 @ 2:44am
Showing 1-8 of 8 comments
< >
Per page: 15 30 50