Blue-Phoenix V™ Sep 3, 2013 @ 6:24pm
planetary annihilation black screen on startup
whenever i try to play planetary annihilation, the screen shows up as a completely black screen with faded stuff that pops up on screen, does anyone know how to fix this?
Last edited by Blue-Phoenix V™; Sep 3, 2013 @ 6:24pm
Showing 1-6 of 6 comments
< >
Blue-Phoenix V™ Sep 3, 2013 @ 6:25pm 
i am also linked to UberNet but i only got the game on steam
SXX Sep 3, 2013 @ 6:31pm 
Please upload your DxDiag.txt somewhere (e.g http://sendspace.com/ ) and link it here.
Run DxDiag tool (Start > Run > type "dxdiag" without quotes), press "Save All Information" button and upload your DxDiag.txt.
Blue-Phoenix V™ Sep 3, 2013 @ 7:20pm 
SXX Sep 3, 2013 @ 7:25pm 
Originally posted by God Phoenix:
you mean like this?
Yeah, thanks.
You problem appear because you run game on integrated Intel card.

You have discrete GPU (NVIDIA GeForce GT 650M) so you need to run game on it:
http://www.youtube.com/watch?v=DzGugS05wo0
Check this wow-to.
SXX Sep 3, 2013 @ 7:28pm 
Also anyway I'm recommend you update both drivers. Intel:
https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=22842
And Nvidia too:
http://www.nvidia.com/object/notebook-win8-win7-64bit-320.49-whql-driver.html

It's will give you better average performance for all your apps.
Last edited by SXX; Sep 3, 2013 @ 7:29pm
Blue-Phoenix V™ Sep 3, 2013 @ 8:00pm 
THX SO MUCH!!!
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Sep 3, 2013 @ 6:24pm
Posts: 6