hexaae Jan 25, 2013 @ 12:47am
Flickering shadows with AMD cards?
I have 7970M (Catalyst 13.1, 1080p) in my MSI GX660 and shadows for player and NPCs flicker/tremble like hell when I move the camera around under some specific angles....
Is there a way to fix this?
This bug seems to affect all AMD cards.
Last edited by hexaae; Feb 3, 2013 @ 5:30am
Showing 1-10 of 10 comments
< >
hexaae Feb 3, 2013 @ 5:30am 
I've contacted SE support... I really have no concrete hope for a fix, but who knows... ;)
HeBr | Mahogany Feb 3, 2013 @ 10:04am 
Hey, I have a AMD card, and I have flickering shadows too.
You're not alone in this.
Zloth Feb 3, 2013 @ 1:02pm 
Contact AMD/ATI and report it as a bug. SqEx has probably got the code mothballed somewhere but I would be really shocked if they would actually dust it off and give it an update at this point. Plus I think it's more likely to be AMD/ATI's changes that caused the problem.
GeNolWeNol Feb 4, 2013 @ 3:59am 
The shadow/texture flickering (most noticeable when you're in Athlum; just lower the viewpoint so you're a bit above Rush's shoulders, rotate the camera, and you'll eventually see both shadow & texture flickering) has been there ever since 5770 era, and has never been fixed.

Also, the only way to force VSync with TLR is to either use D3DOverrider or RadeonPro with AMD cards; CCC is useless.
With Nvidia cards, you can just force it via NV Control Panel with profiles.
Last edited by GeNolWeNol; Feb 4, 2013 @ 4:00am
hexaae Feb 4, 2013 @ 2:40pm 
Just for my info... are you sure the problem persists with Windows Vista and Windows 8 with an AMD gfx card?
Last edited by hexaae; Feb 4, 2013 @ 2:41pm
Pip-boy Mar 7, 2013 @ 3:32pm 
Download D3DOverrider
Cavalorn Aug 14, 2013 @ 2:11pm 
I found a fix for the flickering shadows in Last Remnant on Ati/AMD. :D All you have to do is go to:
Documents\My Games\The last remnant\RushGame\Config and open the file RushEngine and there look for a line saying: AllowShadowVolumes=TRUE
Now there change it from TRUE to FALSE and close the file and when asked to save click yes. Now all the flickering problems are gone. :D But before doing this you have to make sure you have set in game options your shadow settings to whatever setting you would like your shadow quality to be, cuz if you do it after the fix, the game will crash, so once you have used the fix DO NOT change the shadow settings in game, otherwise your game will start crashing. =) So if you want to change in future the shadow quality after the fix is used, all you have to do is go back in this file RushEngine and set the AllowShadowVolumes=FALSE to true and save, this way you can change shadow quality to other setting and then put the AllowShadowVolumes=TRUE to false again, and you won't get any crash. xD
Last edited by Cavalorn; Aug 14, 2013 @ 2:31pm
hexaae Aug 15, 2013 @ 5:39am 
Originally posted by cavalorn:
I found a fix for the flickering shadows in Last Remnant on Ati/AMD. :D All you have to do is go to:
Documents\My Games\The last remnant\RushGame\Config and open the file RushEngine and there look for a line saying: AllowShadowVolumes=TRUE
Now there change it from TRUE to FALSE and close the file and when asked to save click yes. Now all the flickering problems are gone. :D But before doing this you have to make sure you have set in game options your shadow settings to whatever setting you would like your shadow quality to be, cuz if you do it after the fix, the game will crash, so once you have used the fix DO NOT change the shadow settings in game, otherwise your game will start crashing. =) So if you want to change in future the shadow quality after the fix is used, all you have to do is go back in this file RushEngine and set the AllowShadowVolumes=FALSE to true and save, this way you can change shadow quality to other setting and then put the AllowShadowVolumes=TRUE to false again, and you won't get any crash. xD
WELL DONE! :)
It works, though with some view angles they still tremble a lot... at least won't flicker as hell anymore! Thank you for the hint!

Now what I miss is a way to force vsync (without extenral tools) and get rid of that horrible tearing effect!
Last edited by hexaae; Aug 15, 2013 @ 6:18am
Cavalorn Aug 15, 2013 @ 6:49am 
No problem :)
And about the view angle what do you mean? Cuz I am using an ATI x1650, it's very old GPU but it plays just fine on high settings and medium shadows the game, and the only issue with flickering shadow I had was on the characters and nowhere else. Also the d3doverrider works perfectly fine for vertical sync ingame. xD

And there is no way to have vsync forced without external tools, though Radeonpro I think is not an external tool since is made from AMD for their catalyst drivers, so you could try this instead of D3DOverrider. =)

Also try if you haven't in audio options to set it to hardware, it did a lot better the sound quality for me and sounds really impressive now, like it add an extra reverb sound effect. :D
Last edited by Cavalorn; Aug 15, 2013 @ 9:05am
GeNolWeNol Aug 18, 2013 @ 7:57pm 
RadeonPro is not an official tool from AMD.
It's a fan-made tool by japamd over at Guru3D forum.

Sound quality on hardware mode depends largely on your sound card.
Hardware mode may cause static noises on ASUS audio cards, especially with GX mode turned on.
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Jan 25, 2013 @ 12:47am
Posts: 10