Deadfall Adventures

Deadfall Adventures

View Stats:
Nefentari Jul 31, 2014 @ 2:00pm
Terrible lag
I'm experiencing terrible lag in this game, even in the main menu and the cutscenes are also lagging quite bad - even on very low settings and a resolution of 1280x720, so it's very hard to find the motivation to play it. :/
I'm playing on an Asus notebook with an i7-4700HQ (quad, 2.4GHz, hyperthreading), the GTX 850M and 8gb of RAM and I can run "Dead Island: Riptide" on high settings/with 1920x1080 without lag (and that game isn't exactly optimized well) and "Minecraft" on the highest settings with around 60fps, so I should also be able to play "Deadfall Adventures" on at least medium settings, right?
Any tips on how to fix it?
< >
Showing 1-5 of 5 comments
Méléas Nov 10, 2015 @ 11:27pm 
Having the same problem, did you find a solution ?
SPG Nov 11, 2015 @ 2:50pm 
The game uses Unreal Engine 3, which is known for lag issues. Since there seems to be little help for this game specifically, you could try searching for answers by googling the Engine and/or other games that use it.

Here is a list of games that use that Engine. You might find a solution in those game hubs

http://pcgamingwiki.com/wiki/Engine:Unreal_Engine_3
Méléas Nov 11, 2015 @ 9:14pm 
Originally posted by SPG:
The game uses Unreal Engine 3, which is known for lag issues. Since there seems to be little help for this game specifically, you could try searching for answers by googling the Engine and/or other games that use it.

Here is a list of games that use that Engine. You might find a solution in those game hubs

http://pcgamingwiki.com/wiki/Engine:Unreal_Engine_3
Thank you, I will look into it
Try switch ON Vertical Synchronisation. It help for me (on Geforce 9600GT with High settings: no lags, FPS 30+).

У кого лагает - попробуйте включить Вертикальную синхронизацию. Мне это помогло. На моей Geforce 9600GT на высоких настройках без сглаживания не лагает и дает более 30 FPS (часто 40-50), при включении сглаживания 2x FPS ~30 (25-35).
Turns out I was running on the integrated chipset... I managed to switch on the dedicated graphic cards, it runs perfectly on high specs. Thanks for the answers !
< >
Showing 1-5 of 5 comments
Per page: 15 30 50