Ricky Spanish Sep 23, 2013 @ 9:35am
game randomly crashes after 30+ mins of play
anyone expirence something similar? or a fix to it?
Showing 1-6 of 6 comments
< >
Ryan Fraoch Sep 26, 2013 @ 7:25am 
Hello,

Please give us more details about those crash and about your computer specifications.

Fraoch
NutsMammoth  [developer] Oct 1, 2013 @ 12:52am 
Please modify the graphics configuration file in order to improve the game perfomances:

1. Open the folder Cities XL Platinum located on the hard disk.
2. By default the game is installed in the Local Disk (C:), Program Files or Program Files (x86) and Focus Home Interactive.
3. For the Steam version, the path is the Local Disk (C:), Program Files or Program Files (x86), Steam, SteamApps then Common.
4. Open the folder Data then the folder Config.
5. Right click the file GlobalSettings.cfg and click Edit or open the file using the Notepad.
6. Go to the line Live and set PoolSize to 4096 => <PoolSize>4096</PoolSize>
7. Go to the line Layout and set ProcessEnabled to 0 => <ProcessEnabled>0</ProcessEnabled>
8. Go to the line Visibility Manager and set VisibilityEnabled to 1 => <VisibilityEnabled>1</VisibilityEnabled>
9. Save the file GlobalSettings.cfg and run the game.

As soon as you experience major slowdowns with your city, please save your city then quit the game (go back to the main menu) and reload your city.
LindaJeanne Oct 2, 2013 @ 11:51am 
I have this same problem, and the above didn't fix it.

Samsung RF711 laptop

NVDIAGeForce GT 540M video card (and YES, I went to the NVDIA site and updated all the drivers. Still doesn't work.)

quad core, four gigs of ram.

All I've had time to do so far is try to go through the tutorials -- but the game crashes after about 10 minutes of play.

It doesn't seem to matter what I'm doing (once I was left-clicking to begin a road, another time I was scrolling to zoom, a third time I was clicking the "next" button on the tutorial... you know, really computationally expensive stuff like that.)

I've uploaded the most recent crash log to pastebin:

http://pastebin.com/FMn31BCH

This is driving me batty -- I REALLY want to play this game!

Edited to add: forgot the OS: I'm running Windows 7.

Also, I don't have any mods installed. Just the raw download of Platinum from Steam (which began yesterday afternoon & finished up in the wee hours of the morning).
Last edited by LindaJeanne; Oct 2, 2013 @ 11:53am
LindaJeanne Oct 3, 2013 @ 5:30am 
UPDATE:

I followed the instructions in this post:
http://steamcommunity.com/app/231140/discussions/0/810921273966169356/

Originally posted by NutsMammoth:
Please uninstall all libraries Microsoft Visual C++ 2005 and restart the computer.
Run Steam and click Library.
Right click Cities XL Platinum and click Properties.
Click Local Files tab then Verify Integrity of Game Cache button.
Run the game.

And then I started getting "Failed to start game (unknown error)" whenever I tried to start the game.

So I followed the instructions on this page:

https://support.steampowered.com/kb_article.php?ref=8676-EFLX-7453&l=english

None of it worked. So I uninstalled the game completely, re-downloaded it (another 12 hours. Gah!) and tried again. I still get the "Failed to start game (unknown error)".

(and yes, I verified that it wasn't the firewall or anti-virus software blocking it)

This is my first experience with Steam, and it's not exactly filling me with confidence =^/
LindaJeanne Oct 3, 2013 @ 5:57am 
I think it works now!! (fingers crossed), Information for others having the same problems:

After all the above, I found https://support.steampowered.com/kb_article.php?ref=2919-UALV-8437 (yes, after hours of trying to get things configured, I finally found the official support page. Like I said, I'm new to steam.)

Exit Steam entirely.
Browse to your Cities XL Platinum installation folder (Usually C:\Program files\Steam\Steamapps\common\Cities XL Platinum\)
Run the following installers:
...\Steamapps\common\Cities XL Platinum\DotNetFx35.exe
...\Steamapps\common\Cities XL Platinum\vcredist_x86.exe
Reboot your computer and test any issues again.

The firist app exited, saying it couldn't run on a 64 bit system.

The second app re-installed a clean copy of the libraries that I deleted in the above step.

After re-booting, the game started, and I made it through the second tutorial without crashing!!! Woot!

I'll come back and let y'all know if I make it through a gaming session without a crash =^)


[CENSORED]!!! Still crashing after 10 minutes or so =^(
Last edited by LindaJeanne; Oct 3, 2013 @ 6:08am
LindaJeanne Oct 3, 2013 @ 8:28am 
WOOT! Fixed!!

I finally contacted Focus Home support, and they were very helpful. After a couple of e-mails back and forth, this fixed it.

While the problem was specific to my configuration, I'll post the solution that worked for me here, in case someone else has a problem with a similar cause.

Hello,

Your laptop computer has two graphics controllers: INTEL HD and NVIDIA GEFORCE.
The high-performance graphics controller for games is the NVIDIA GEFORCE.

Please select the NVIDIA GEFORCE graphics controller to play Cities XL Platinum:

1. Right click on the background of the Windows Desktop and click NVIDIA Control Panel.
2. Click Manage 3D settings under 3D Settings in 'Select a Task...'.
3. Click Program Settings tab under 'I would like to use the following 3D settings:'.
4. Click the Add button under '1. Select a program to customize:'.
5. Open the folder Cities XL Platinum.
6. The default path is Local Disk (C:), Program Files or Program Files (x86), Steam, SteamApps and Common.
7. Select the application CitiesXL_Platinum.exe and click the Open button.
8. Select 'High-performance NVIDIA processor' under '2. Select the preferred graphics processor for this program:'.
9. Click the Apply button then close the NVIDIA Control Panel window and run the game.

Best Regards,

Technical Support
Focus Home Interactive
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Sep 23, 2013 @ 9:35am
Posts: 6