Toretto May 28, 2013 @ 6:31am
Why won't this s**t work!!!!!
Ive tried everything in all the forums but nobody, from what i can tell, is having the same error code as me?

mcCrypto: ERROR in CryptAcquireContext() with CRYPT_NEWKEYSET() msg:<Access is denied. (Error code = 5)>
Showing 1-4 of 4 comments
< >
The doctor is in May 28, 2013 @ 6:57am 
try googling the above error you will find the game is not the problem. its your installation of windows and your certificate keystore missing/inaccessible keys!

basically a call to crypto api is failing because it cannot found / access the key it needs from the keystore

if you open the windows keystore you will be able to see your keys, if they are not there or inaccessible then something is wrong.

here is how to view and edit your windows keystore (they certainly dont make it easy)
http://swimmingpooldotnet.wordpress.com/2009/12/15/how-to-view-local-machine-keystore-windows-xp/

ignore its says xp, will work with vista/7/9

what exact hardware and os do you have?

open the windows application/system/security event logs and look for related warnings/errors and post them. it will give greater details as to the crypto api that failed that you can use to go to microsoft support and help you resolve the issue you have with your keystore


try these things

http://citiesxl.wikia.com/wiki/Technical_FAQ

if that dont work try this

verify game cache

update your .net/c/c++ runtime

login as a user with admin rights

open

C:\Program Files (x86)\Steam\steamapps\common\Cities XL Platinum

run

vcredist_x86.exe
dotnetfx.exe
DirectX9\DXSETUP.exe

if that does not work

run a command prompt as admin and enter

sfc /scannow

try downloading, uninstalling reinstalling 32bit (and 64 bit if 64 bit windows) version of c/c++ runtime and updates

try downloading, uninstalling, reinstalling 32-bit (and 64 bit if 64 bit windows)version of .net runtime

i always found it best to make sure that i have all versions of c/c++/.net runtime

make sure you have latest and updated directx

also make sure windows and all your drivers are up to date

but it looks like you dont have admin priviledges or your keystore is damaged or inaccessible

if that does not work try this

also are you using oem version of windows, like a dell version, cause they dont normally give you full/complete/retail version. its slightly different/tweaked and the way they create accounts the first time that you run them is not microsoft way like when you do a full install of windows and unfortunately they cause problems like this.

so uninstall the game/delete local files.
so create another account with admin rights. not using oem create account tool. use the windows one it does things right. then download and install the game it should run

if that does not work try this

mcCrypto: ERROR in CryptAcquireContext() with CRYPT_NEWKEYSET() msg:Edit
{C} This error occurs when the encryption key is not present on the host computer.
Reinstalling Windows did not work.

However, I tried a final idea and I copied the encryption key from my laptop to a shared drive between my computers and moved it to my pc. It worked!!!!! CXL loaded up and plays wonderfully.

I wish I knew how to actually fix this problem though for people who don't have the option of installing the game on another pc and moving the key over.

basically yoou have to go to another computer and grabs the keys from the keystore and then put them in your bad machines keystore, sucks but it should work.
Last edited by The doctor is in; May 28, 2013 @ 7:04am
Toretto May 28, 2013 @ 1:18pm 
i run windows 8 and i updated everything and i read about installing it on another comp then put the keys on to mine but i don't have another comp to use! I've tried everything else.
Toretto May 28, 2013 @ 2:09pm 
Annnnnnndddddddd the Doctor has fixed it, thanks again for all your help!
The doctor is in May 28, 2013 @ 2:17pm 
np so the solution was to create another account and then run steam as admin and then run the games

oem copies of windows normally dont give you 100% the same windows and accounts as the real version.

also w windows 8 the online account is not the same as a local account and u need a local account


so you will have the correct keys

well once u created the local account it created the keys you needed and it worked

nice. so others with this problem can now have hope

and its not the game, its those oem preinstalled copies....

if u google that exact error without cities xl u see other get it and u see the solution is to create another account with admin rights....
Last edited by The doctor is in; May 28, 2013 @ 2:17pm
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: May 28, 2013 @ 6:31am
Posts: 4