baki Nov 29, 2013 @ 1:19pm
[SOLVED] Game crash within 2 seconds of starting it
I am still unable to launch the game. I've tried almost all the methods, except the changing the name of folder "Video" to "Videos" (doesn't exist) and running dotnetfx.exe (doesn't work on 64 bit).

DXDIAG - System Tab
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601)
Processor: Intel(R) Core(TM) i5-3570K CPU @ 3.40 GHz (4 CPUs), ~3.4GHz
Memory: 8192MB RAM

DXDIAG - Display Tab
Name: NVIDIA GeForce GTX 660 Ti
Display Memory: 4038 MB
Dedicated Memory: 1989 MB
Shared Memory: 2048 MB
Current Mode: 1680 x 1050 (32 bit) (59Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: Cinema
Monitor Id: APP921B
Native Mode: 1680 x 1050(p) (59.883Hz)
Output Type: DVI
Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver File Version: 9.18.0013.3182 (English)
Driver Version: 9.18.13.3182
DDI Version: 11
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
Driver Date/Size: 11/14/2013 05:55:24, 18208624 bytes
WHQL Logo'd: Yes
WHQL Date Stamp:
Device Identifier: {D7B71E3E-52C3-11CF-BC7B-4E081CC2C435}
Vendor ID: 0x10DE
Device ID: 0x1183
SubSys ID: 0x28431462
Revision ID: 0x00A1
Driver Strong Name: oem33.inf:NVIDIA_SetA_Devices.NTamd64.6.1:Section090:9.18.13.3182:pci\ven_10de&dev_1183
Rank Of Driver: 00E02001
Video Accel: ModeMPEG2_A ModeMPEG2_C ModeVC1_C ModeWMV9_C

DXDIAG - Sound Tab
Description: Headset Microphone (Microsoft LifeChat LX-3000 )
Default Sound Capture: Yes
Default Voice Capture: Yes
Hardware ID: USB\VID_045E&PID_070F&REV_0100&MI_00
Manufacturer ID: 65535
Product ID: 65535
Type: WDM
Driver Name: USBAUDIO.sys
Driver Version: 6.01.7601.18208 (English)
Driver Attributes: Final Retail
WHQL Logo'd: Yes
Date and Size: 7/12/2013 04:40:58, 109824 bytes
Cap Flags: 0x1
Format Flags: 0xFFFFF
Description: Stereo Mix (Realtek High Definition Audio)
Last edited by NutsMammoth; Dec 13, 2013 @ 2:08am
Showing 1-7 of 7 comments
< >
baki Nov 29, 2013 @ 7:53pm 
I believe there is some sort of permissioning issue, but the fix that the developer offers doesn't seem to work for Steam games.

I would not recommend buying this game at this time. Wait for them to fix these issues first.
The doctor is in Dec 1, 2013 @ 2:48pm 
look in game log file

post last error, that is the problem...
baki Dec 1, 2013 @ 4:17pm 
[01:38:28] CORE mcCrypto.cpp ( 127) ErrorBuild mcCrypto: ERROR in CryptAcquireContext() with CRYPT_NEWKEYSET() msg:<Access is denied. (Error code = 5)>
baki Dec 1, 2013 @ 4:23pm 
Also, I've checked various fan/official forums for this and what I've found is that while the official forums don't answer this question, the fan one specifies that there is no fix. Without being able to return the game, the only option is to wait.

However, with previous reviews of the company behind the game, that isn't likely to happen. In other words, ♥♥♥♥ out of luck.
NutsMammoth  [developer] Dec 2, 2013 @ 2:10am 
A. Please configure the game in order to run it in administrator mode:

1. Open the Local Disk (C:) then the folder Program Files or Program Files (x86).
2. Open the folder Steam then the folder Steamapps.
3. Open the folder Common then the folder Cities XL Platinum.
4. Right click on the application CitiesXL_Platinum.exe and click Properties.
5. Click the tab Compatibility and check 'Run this program as an administrator' under Privilege Level.
6. Click the button OK and run the game.

B. Otherwise, please modify the graphics configuration file in order to run Cities XL in windowed mode:

1. Open the folder Cities XL Platinum located on the hard disk.
2. The default path is the Local Disk (C:), Program Files or Program Files (x86), Steam, SteamApps then Common.
3. Open the folder Data then the folder Config.
4. Right click the file GlobalSettings.cfg and click Edit or open the file using the Notepad.
5. Go to <Application>.
6. Set Win32FullScreen to 0:

<Win32FullScreen>0</Win32FullScreen>

7. Save the file GlobalSettings.cfg and run the game.

As soon as you experience major slowdowns with your city, please save your city then quit the game (go back to the main menu) and reload your city.
Last edited by NutsMammoth; Dec 2, 2013 @ 2:12am
eobet Dec 2, 2013 @ 2:17am 
Originally posted by NutsMammoth:
As soon as you experience major slowdowns with your city, please save your city then quit the game (go back to the main menu) and reload your city.

Unless I'm mistaken, you posted in another thread that there wasn't a memory leak in this game. However, isn't this an implicit confirmation that there actually IS one?
baki Dec 4, 2013 @ 8:01pm 
Everything below I have already tried and it did not work. This is the solution that finally worked (there is some difference between running as admin and actually being logged in as admin):

1. Press Start and search for 'cmd'
2. Right-click on cmd and 'Run as administrator'
3. Type: net user administrator /active:yes
4. Press Start and Switch User (under the shut down menu)
5. Log onto Administrator and run game

Originally posted by NutsMammoth:
A. Please configure the game in order to run it in administrator mode:

1. Open the Local Disk (C:) then the folder Program Files or Program Files (x86).
2. Open the folder Steam then the folder Steamapps.
3. Open the folder Common then the folder Cities XL Platinum.
4. Right click on the application CitiesXL_Platinum.exe and click Properties.
5. Click the tab Compatibility and check 'Run this program as an administrator' under Privilege Level.
6. Click the button OK and run the game.

B. Otherwise, please modify the graphics configuration file in order to run Cities XL in windowed mode:

1. Open the folder Cities XL Platinum located on the hard disk.
2. The default path is the Local Disk (C:), Program Files or Program Files (x86), Steam, SteamApps then Common.
3. Open the folder Data then the folder Config.
4. Right click the file GlobalSettings.cfg and click Edit or open the file using the Notepad.
5. Go to <Application>.
6. Set Win32FullScreen to 0:

<Win32FullScreen>0</Win32FullScreen>

7. Save the file GlobalSettings.cfg and run the game.

As soon as you experience major slowdowns with your city, please save your city then quit the game (go back to the main menu) and reload your city.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50