Cities XL Platinum

Cities XL Platinum

View Stats:
Frost Jul 14, 2014 @ 8:09pm
Crashes after I hit play
Hi I just downloaded Cities XL Platinum and whenever i get to the main menu and then press play my game stops working and says its not responding. Does anyone have any suggestions or is having the same problem that I'm having.

Thanks.
< >
Showing 1-15 of 47 comments
The doctor is in Jul 14, 2014 @ 10:03pm 
open latest login log file in

C:\Users\<username>\AppData\Local\Focus Home Interactive\Cities XL 2012\log

and post what u see at the end


also does not hurt to verify game cache just in case
BOT RoflKartoffel Jul 15, 2014 @ 1:55am 
I have got the same problem and I have never been able to fix it. Yes i verified the game's cache.

[10:54:15] LUA csScriptManager.cpp ( 522) Error validations fileacc_id.dat does not exist
[10:54:15] LUA csScriptManager.cpp ( 522) Error validations file
[10:54:15] LUA csScriptManager.cpp ( 522) Error Loading live/Offline/ppath.cxl
[10:54:15] LUA csScriptManager.cpp ( 522) Error Loading live/Offline/player1.cxl
[10:54:15] LUA csScriptManager.cpp ( 522) Error BatchData is nil !
[10:54:15] LUA csScriptManager.cpp ( 522) Error Default GFX values detected correctly, setting gfx quality to Custom
[10:54:15] LUA csScriptManager.cpp ( 522) Error Set Quality : Custom _bDisplayMsgBox = false
[10:54:15] LUA csScriptManager.cpp ( 522) Error resolution set
[10:54:15] LUA csScriptManager.cpp ( 522) Error Changing scale
[10:54:15] LUA csScriptManager.cpp ( 522) Error InterfaceMgr:ChangeScale 70
[10:54:15] LUA csScriptManager.cpp ( 522) Error Apply options done
[10:54:22] LUA csScriptManager.cpp ( 522) Error validations fileacc_id.dat does not exist
[10:54:22] LUA csScriptManager.cpp ( 522) Error validations file
[10:54:22] LUA csScriptManager.cpp ( 522) Error Loading live/offline/ppath.cxl
[10:54:22] LUA csScriptManager.cpp ( 522) Error Loading live/offline/player1.cxl
[10:54:22] LUA csScriptManager.cpp ( 522) Error BatchData is nil !
[10:54:22] LUA csScriptManager.cpp ( 522) Error Default GFX values detected correctly, setting gfx quality to Custom
[10:54:22] LUA csScriptManager.cpp ( 522) Error Set Quality : Custom _bDisplayMsgBox = false
[10:54:22] LUA csScriptManager.cpp ( 522) Error resolution set
[10:54:22] LUA csScriptManager.cpp ( 522) Error Changing scale
[10:54:22] LUA csScriptManager.cpp ( 522) Error InterfaceMgr:ChangeScale 70
[10:54:22] LUA csScriptManager.cpp ( 522) Error Apply options done
[10:54:22] CORE mcFile.cpp ( 198) Error can't open file download/data/design/actor/avatar/default.actor
[10:54:22] LIVE lavAvatarManager.cpp ( 591) Error [lavAvatarManager] AvatarSetDescription : unknown avatar "offline"
[10:54:24] LUA csScriptManager.cpp ( 522) Error Loading data/test/FakeRights.cxl
[10:54:37] LUA csScriptManager.cpp ( 522) Error Doing new init slots
[10:54:37] LUA csScriptManager.cpp ( 522) Error Loading data/test/SlotMap.cxl
[10:54:38] LUA csScriptManager.cpp ( 522) Error nb of maps = 62 max nb = 70
[10:54:38] LUA csScriptManager.cpp ( 522) Error nb of maps = 62 max nb = 70
[10:54:38] LUA csScriptManager.cpp ( 522) Error nb of maps = 62 max nb = 70
[10:54:38] LUA csScriptManager.cpp ( 522) Error nb of maps = 62 max nb = 70
[10:54:38] LUA csScriptManager.cpp ( 522) Error Could not find file live/offline/solo/SoloCfg.cxl to load
[10:54:38] LUA csScriptManager.cpp ( 522) Error Loading data/test/SoloMapDesc.cxl
[10:54:38] LUA csScriptManager.cpp ( 522) Error Loading live/offline/solo/TradeMatrix.cxl
[10:54:38] CORE mcFile.cpp ( 198) Error can't open file live/offline/solo/TradeMatrix.cxl
The doctor is in Jul 15, 2014 @ 10:40am 
sounds like you have bad files

remove any mods that you may have installed

verify game cache just in case

post details about your hardware (cpu, gpu, memory) and os (windows version n if 32/64 bits)

make sure windows, drivers, c/c++ runtime, .net runtime, directx runtime, etc are all updated


if you do not have any maps that you would like to preserve

try renaming

C:\Users\<username>\AppData\Local\Focus Home Interactive\Cities XL 2012

to something else like


C:\Users\<username>\AppData\Local\Focus Home Interactive\Cities XL 2012.org

run again and see if problem got solved
Last edited by The doctor is in; Jul 15, 2014 @ 10:42am
Frost Jul 16, 2014 @ 1:46am 
Problem signature:
Problem Event Name: APPCRASH
Application Name: CitiesXL_Platinum.exe
Application Version: 1.0.5.725
Application Timestamp: 4e55dec6
Fault Module Name: CitiesXL_Platinum.exe
Fault Module Version: 1.0.5.725
Fault Module Timestamp: 4e55dec6
Exception Code: c0000005
Exception Offset: 0022961e
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

This is what comes up for the info for the crash.
StevieWonder Jul 16, 2014 @ 2:35am 
I am running windows 7 and everything I have is updated with current divers. I have tried running as admin. I have tried disabling firewall. I have tried all these delete file in the user/yourname/app yadda but all I have there is logs of failed game start attempts that read..

[02:34:11] CORE mcCrypto.cpp ( 127) ErrorBuild mcCrypto: ERROR in CryptAcquireContext() with CRYPT_NEWKEYSET() msg:<Object already exists. (Error code = 2148073487)>

Anyone know how I can get this new game I just bought working?
The doctor is in Jul 16, 2014 @ 4:32am 
rename
C:\Users\<username>\AppData\Local\Focus Home Interactive\Cities XL 2012
to
C:\Users\<username>\AppData\Local\Focus Home Interactive\Cities XL 2012.org

verify game cache (just in case)

manually run
C:\Program Files (x86)\Steam\SteamApps\common\Cities XL Platinum\vcredist_x86.exe
C:\Program Files (x86)\Steam\SteamApps\common\Cities XL Platinum\dotnetfx.exe
C:\Program Files (x86)\Steam\SteamApps\common\Cities XL Platinum\DirectX9\DXSETUP.exe


if that does not work

get and run http://www.microsoft.com/en-gb/download/confirmation.aspx?id=26


if that does not work who created the the windows login account that you are using, did u creted it or do you have eom windows and oem installer / first time setup created it

if oem windows and oem installer / first time setup creted it then i have some bad news for you

that account is not proper windows account and it does not have proper privilidges

you will need to create an account from window users control panel and give it admin rights

i know they look the same, but they are not
The doctor is in Jul 16, 2014 @ 4:35am 
Originally posted by Frost:
Hi I just downloaded Cities XL Platinum and whenever i get to the main menu and then press play my game stops working and says its not responding. Does anyone have any suggestions or is having the same problem that I'm having.

Thanks.

rename
C:\Users\<username>\AppData\Local\Focus Home Interactive\Cities XL 2012
to
C:\Users\<username>\AppData\Local\Focus Home Interactive\Cities XL 2012.org

verify game cache (just in case)

manually run
C:\Program Files (x86)\Steam\SteamApps\common\Cities XL Platinum\vcredist_x86.exe
C:\Program Files (x86)\Steam\SteamApps\common\Cities XL Platinum\dotnetfx.exe
C:\Program Files (x86)\Steam\SteamApps\common\Cities XL Platinum\DirectX9\DXSETUP.exe
StevieWonder Jul 16, 2014 @ 11:54am 
@The Doctor is in

When i change the name of Cities XL 2012 to cities 2012.org it just makes another directory without the ORG and crashes same as ussual. The only directory in the cities XL 2012 directory is a folder called LOG which is full of error messages saying

[02:34:11] CORE mcCrypto.cpp ( 127) ErrorBuild mcCrypto: ERROR in CryptAcquireContext() with CRYPT_NEWKEYSET() msg:<Object already exists. (Error code = 2148073487)>

Everything is up to date -- video/audio/windows

This crappy game is the problem not my computer.

Renaming files does not work!

Manually running VCREDIST_x86.exe installs but does not fix problem.
Manually running dotnetfx.exe Is not supported by 64bit OS <-------WTF?
Manually running DXSETUP.exe installed but does not fix problem.

Game cache verifies to be good.
The doctor is in Jul 16, 2014 @ 6:18pm 
check that windows cryptographic service provider is properly running if it is

so do u have oem version of windows?

if so how did u create the windows account that your using to install and run the game?

if the account was created using oem first setup / install that account most likely does not have proper access rights as i posted

you need to try creating an account with windows users control panel

and give that account admin rights

its just how it is the oem programs dont have proper rights so they cant create proper account

so the keystore is not setup properly for thos account

and u get errors like that

if u search web for error 2148073487 u will see it happens to alot of programs that need to access the keystore...
Last edited by The doctor is in; Jul 16, 2014 @ 6:19pm
StevieWonder Jul 16, 2014 @ 6:36pm 
cryptographic services are running.

CryptSvc pid 1124 Cryptographic Services Status:running Group:networkservice


Also, the UAC is off and does not pop up when i run as admin or when i run admin on any other program.

control panel - User accounts: shows my name and says Administrator
Last edited by StevieWonder; Jul 16, 2014 @ 6:54pm
The doctor is in Jul 16, 2014 @ 7:01pm 
ok but u still not answering my question, and this is not about uac.

this is what u have to do. it dont matter that u have admin. the keystore / keys are toast or u dont have proper access its not about being admin or not. they keystore is special storage for crypto keys... oem windows first time setup which create user account cant create them properly... so do u have oem windows is the question. did u get window preinstalled on some machine or did u get oem version of windows (oem windows that u get from manufacturers is the problem and their non compliant installers that they all use) only account created by microsoft windows installer (non oem) and by windows usrs control panel are valid. just go create another account in user give it admin right using windows users control panel and try running steam with that new account and installing / running game... the error means NTE_EXISTS which means the above call fails because CRYPT_NEWKEYSET is being used and the keys exists... so u need to use another account where the keys dont exist...

http://steamcommunity.com/app/231140/discussions/0/45350791849228045/#c41973820564399790

the other way to fix it is to blow the keystore but u dont want to do that caue it could have valid keys that u need for other applications and encrypted stuff. so u must not do that... so if u search web and they suggest u delete the keystore dont think about it u may need those keys
Last edited by The doctor is in; Jul 16, 2014 @ 7:10pm
StevieWonder Jul 16, 2014 @ 7:10pm 
My windows is an ISO downloaded from microsoft that contains every version of windows and you pick the one who have for the key you have and install.
Later it asks to verify your copy of windows and it verifies as a good copy.
Originally this ran a copy of DELLs version of windows 7 but my HD crapped out and had to buy another. Since dell does not give you a CD anymore and puts the operating system in a secret partition, I had to find windows 7 online and use my key.

I dont know what questions im not answering and i really dont understand what you want me to do to fix this. I have 3 accounts 1. guest pass-disabled 2. ASP.NET Machine account - standard user password protected 3. Nuada -admin

I am using #3 Nuada which is set to admin.

The doctor is in Jul 16, 2014 @ 7:14pm 
ok but who created that account did it come from dell or microsoft windows

i am asking u to go to windows users control panel and create a new account that has admin rights. log in using that new account, then run steam using that new account, then install and run the game using that new account

caus current one dont work... cause it looks like there is problem in keystore


basically its all about did u do clean install or u using the dell one cause if ur using the dell one (old dell account) u cant

the error message says it all

"[02:34:11] CORE mcCrypto.cpp ( 127) ErrorBuild mcCrypto: ERROR in CryptAcquireContext() with CRYPT_NEWKEYSET() msg:<Object already exists. (Error code = 2148073487)>
"

i also using iso from microsoft msdn... microsoft one should work the dell one wont, but had to do a complete wipe and create account using iso one not bring stuff from dell or keep stuff from dell. the dell is toast they and others created their stuff long ago micrsoft made changes and they have not kept up so their account they create using their funky first time installers dont actually create 100 compliant microsoft accounts..

so just try creating another account using windows users control panel and try to see if that resolves it. we wasting lots of time going in circles just to run a test. the error message says it all...

also there is chance key is their cause of some other reason. so dont just delete the current account/keystore. the point is there is key or perhaps keystore is toast. but regardles u cant delete ur keystore cause some of the keys maybe needed by u to decrypt stuff that is encrypted if u blow them u never will decrypt the stuff. or perhaps some keys being use to encode/decrypt so u dont want to blow a keystore. at leat make a back up of it on like thumb drive but then u must know what u doing with backup and perhaps later restore of keystore. also u can open the keystore using microsoft tool and edit out keys but i dont know the name of the key that is problem and i dont know the passwords it may have on key / keystore and its like me giving u lots of hours of support for u not doing what u should be doing which is create another acount. this one toast. not by game. but by windows...
Last edited by The doctor is in; Jul 16, 2014 @ 7:30pm
StevieWonder Jul 16, 2014 @ 7:29pm 
Ok, I created a new user account and gave it admin also. Logged out and then logged in with new account. Started Steam and tried to start the game. Same exact error. Any other ideas?
The doctor is in Jul 16, 2014 @ 7:36pm 
run steam as admin.... so u right mouse on the icon and click on run as administrator to start steam

this is what symantec suggests for that error (which should have been solved by u creating a new account)

well that should be the solution cause it creates a new keystore for u that is what microsoft says to do...

i mean u could try renaming the keysotre intead of deleting it nd then logging out and logging back in

rename

C:\Users\<username>\AppData\Roaming\Microsoft\Crypto\RSA

to

C:/Users/<username>/AppData/Roaming/Microsoft/Crypto/RSA.org

log completely out

log back out in

that should recreate it

remember if u need them u will need to rename that directory back
Last edited by The doctor is in; Jul 16, 2014 @ 7:38pm
< >
Showing 1-15 of 47 comments
Per page: 15 30 50