Zmarksthespot Jul 16, 2014 @ 7:35am
How to limit this game to 60fps?
Showing 1-4 of 4 comments
< >
KWAiRT Jul 16, 2014 @ 9:41am 
Turn ON your VSYNC if your using a 60Hz display
Zmarksthespot Jul 16, 2014 @ 10:02am 
Vsync doesn't work in game and in nvidia control panel, 2000+ fps in menu and 120+ fps in game.
Kill Master Aug 4, 2014 @ 10:25pm 
Both AMD, and NVidia should be able to force V-Sync on any program; for NVidia go to your control panel under "3D Settings" -> "Manage 3D Settings" -> click on the "Program Settings" tab, then use the drop-down menu to select "Cities XL Platinum" from the list then in the window below at the very bottom there should be a "Vertical sync" option (select either "On" or "Adaptive")

Note: the program selected must be "Cities XL Platinum" otherwise it won’t work.
(For me only "Cities XL 2012" showed up in the list and I had to add "Cities XL Platium.exe" myself)
Last edited by Kill Master; Aug 4, 2014 @ 10:26pm
☪☆ HunWolf ☪☆ Aug 12, 2014 @ 10:03am 
There is just no vsync ! If it would be, it would be awesome. Im tired of those headaches I get !
Showing 1-4 of 4 comments
< >
Per page: 15 30 50