Quake > General Discussions > Topic Details
Major MipplAsh Hoss May 1, 2013 @ 4:47am
"Unkown command -width"
I just switched over to GLQuake and I'm having a bit of an issue. Whenever I try to change resolution (-width 1440 -height 900 -bpp 16) it says "unkown command '-width" If anyone knows how to fix this, or if I'm entering the command wrong please help. Thanks in advance!
Showing 1-6 of 6 comments
< >
Johnny Law May 1, 2013 @ 7:37am 
You may need to provide more details about what you're doing and where/how you are seeing that message.

For starters though... are you specifying those as command-line options when you launch the game? They're not console commands. If you're starting GLQuake through Steam then you can put them in the "launch options" for Quake in your Steam library. More about that, and about command-line options in general, in the "Command Line" section of this guide:
http://steamcommunity.com/sharedfiles/filedetails/?id=120426294
Major MipplAsh Hoss May 1, 2013 @ 10:28am 
Originally posted by Johnny Law:
You may need to provide more details about what you're doing and where/how you are seeing that message.

For starters though... are you specifying those as command-line options when you launch the game? They're not console commands. If you're starting GLQuake through Steam then you can put them in the "launch options" for Quake in your Steam library. More about that, and about command-line options in general, in the "Command Line" section of this guide:
http://steamcommunity.com/sharedfiles/filedetails/?id=120426294
There you go. That's my problem. I was entering them in the console, in-game. I'll try setting them as launch commands and see what happens. Thanks!
Last edited by Major MipplAsh Hoss; May 1, 2013 @ 10:35am
Johnny Law May 1, 2013 @ 9:32pm 
All righty. Keep us posted if you still have any issues. :-)
Major MipplAsh Hoss May 2, 2013 @ 4:06am 
Originally posted by Johnny Law:
All righty. Keep us posted if you still have any issues. :-)
I do. I tried the command and it crashed glquake as soon as I opened it.
Johnny Law May 2, 2013 @ 1:01pm 
Is that the exact command line you're using? What are the native dimensions of your monitor/desktop?

If you're not specifying your native resolution, then try that. Otherwise here are some suggestions off the top of my head:

First thing to try is omitting the -bpp option. You probably don't need it. Just specify width and height.

If that doesn't help, then try replacing your GLQuake.exe (which is version 0.95) with version 0.98. You can find 0.98 in various places including at http://www.quaketerminus.com/nqexes/glquake098alpha.zip

You don't need any of the files in that zip archive except for the new glquake.exe. One way to try it out would be:

- copy or move Steam's glquake.exe to a safe place
- move the version 0.98 glquake.exe to the place where the Steam exe used to be
- launch Quake as before, see if it works this time


Now if THAT doesn't help, you can try using a modern Quake engine instead of the original GLQuake. This is the "best" thing to do in any case (for most situations), but it does involve a little more learning/effort. This guide describes many of the available engines:
http://steamcommunity.com/sharedfiles/filedetails/?id=118401000

And the "Owner's Manual" guide linked above would help in configuring the engine of your choice. The "Quick Start" section of the Owner's Manual is a good place to start.
jasper.mills May 20, 2013 @ 7:38am 
using that new glquake exe worked for me so thanks for the info :)
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: May 1, 2013 @ 4:47am
Posts: 6