salad_phd Feb 28, 2013 @ 3:47pm
Application won't start... (sorta?)
I've already gone through the (entirely useless) Steam troubleshooting. It doesn't change anything.

After installing the application (through steam) double clicking the shortcut on the desktop launches the Steam window that displays the license key. The application splash comes up and then crashes when it gets to the "core components" loading screen.

Navigating directly to the application folder within the steamapps directory, and starting the x64 version of ArticyDraft.exe launches the application, and after the splash takes me to what I'm assuming is the multi-user interface (asks for a server and port).

There is no option to launch the SE version.

Clicking the menu button and choosing About says that there is no valid license key.

After reading the getting started information at the main articy site, there should be a place to enter a key on the About menu. There is no such option.

So far this is a useless $90 tool that I really need. Some help would be appreciated.
Showing 1-15 of 42 comments
< >
Skipper Feb 28, 2013 @ 8:39pm 
whats your specs for the machine you are using it on
salad_phd Feb 28, 2013 @ 9:17pm 
i7 at 3.3Ghz, 16GB RAM, GTX670, Win7, fully updated.

It's not system specs. (And if it is then the developers of this application need to rethink their concept of minimum system requirements...)
Kwaung Feb 28, 2013 @ 9:42pm 
I got the same problem. I was install the software on my NAS device. I reinstall it on my local HDD. And everything work fine.
salad_phd Feb 28, 2013 @ 9:44pm 
This software is installed locally on my machine.
salad_phd Feb 28, 2013 @ 9:52pm 
Attempting to circumvent Steam and launching the application directly using the -singleuser command line option allows me to get into the application, but when I attempt to enter the key provided by Steam it complains that the license is invalid.
salad_phd Feb 28, 2013 @ 9:54pm 
Uninstalling the application and attempting to install on another local drive has no effect.
|-DMD-| Rusty Mar 1, 2013 @ 12:17am 
Put in a ticket - I'm curious to see how long it takes to get a reply.
Kwaung Mar 1, 2013 @ 1:24am 
Well for that I have no idea. All I can suggest that you take a look at the Crash info on
C:\Users\[username]\AppData\Roaming\Nevigo\articy\Logs

It suppose to have a crash report there. Unzip the lastest one and open "ExceptionDump.txt". And see what the problem is.

[Edit] Did you try the Steam support page for the software?

https://support.steampowered.com/kb_article.php?ref=3847-DGJB-2609
Last edited by Kwaung; Mar 1, 2013 @ 1:30am
Nevigo  [developer] Mar 1, 2013 @ 1:30am 
Hi. We're working on hunting this bug right now, and I'll keep you posted on this. Sorry for the inconvenience.

-Kai
Last edited by Nevigo | Kai Rosenkranz; Mar 4, 2013 @ 4:21pm
salad_phd Mar 1, 2013 @ 10:21pm 
Putting in a ticket with Steam is one of the more futile exercises I've ever done. Last time I waited more than a week before getting a "look in the kb" message from a support guy who obviously hadn't read the numerous emails or crash dumps I sent.

Additionally, the support page for the software was the first thing I tried. Like I said above, it had no effect.

Fortunately the Nevigo folks are considerably more responsive than Steam, and they're working to rectify the situation.
Vendrium Mar 1, 2013 @ 10:59pm 
same problem here - actually if you guys have a workaround - that would already help as well - for the time being.

The trial version from your website works perfectly.
The full version from Steam crashes on "Core components"

Edit: I found a workaround...of sorts.

1) \Steam\steamapps\common\articydraft
2) Right-Click and go to properties of "SteamStarter.exe"
3) Set the "Run as administrator" flag
4) Run the program straight from the folder

This seemed to work for me - but I'm still getting the 'Core Components' crash when running through Steam.

The problem however is that I'm greeted with a "Host address: [blank]" (Port: 16707) screen and cannot navigate away from it and do not have a server set up with Nevigo.

On the note of crashing: Is anyone else running Razor Game Booster?
I thought that it might be causing the issue.
Last edited by Vendrium; Mar 1, 2013 @ 11:19pm
jayGuard Mar 2, 2013 @ 3:40pm 
Having the same problem as well. Hopefully it gets fixed soon
Nevigo  [developer] Mar 2, 2013 @ 4:30pm 
Hi guys,

I am sorry to see more people getting nagged by this bug.
The current situation is, that we know this crash takes place deep inside a Steam DLL (therefore the trial works fine). As you already said, you need patience if you need an answer from Valve (we send an inquiry as well).

But I would be pleased if those of you encountering the problem send us the crashdumps to support (at) nevigo (dot) com. So we hopefully find a way to work around this. I have seen that the offending DLL is the same version as the one I use without any problems, so there must be anything special we are missing.

As I offered Vendrium in another thread, you can mail us an support inquiry to support (at) nevigo (dot) com including :

- your steam assigned CD-Key (starting with the letter 'C')
- your steam names (as shown here in the forum)
- and if you already downloaded a trial that license key code (staring with the letter 'A')

With those information we can extend or create a temporary license you can use until the issue is solved.

-Peter
Last edited by Nevigo | Kai Rosenkranz; Mar 3, 2013 @ 12:42am
Nevigo  [developer] Mar 4, 2013 @ 12:22pm 
Hi,

I just got word from Valve, that they have disabled the overlay for the application and that this should solve the problem.

I hope that helps, and I would be pleased if you report back (either to close the case or to make a follow-up with Valve)

-Peter
Last edited by Nevigo | Kai Rosenkranz; Mar 4, 2013 @ 4:22pm
Vendrium Mar 4, 2013 @ 11:15pm 
Hi - it doesn't seem to work here, but then my Artisy didn't update either (which I would think would be necessary if Valve changes settings).

I then also tried to disable the application overlay manually - but this didn't fix the issue either.
Showing 1-15 of 42 comments
< >
Per page: 15 30 50