Noontide  [developer] Feb 10, 2014 @ 11:23am
Reporting Bugs
Hey folks,

First of all, let me say just how much we appreciate everyone who is taking the time to report bugs here. We can't understate just how important it is that we receive these reports when you find a bug, each report helps us release targeted fixes to specific problems and will result in a more polished final game. It's incredible how dedicated you are to do this and we sincerely appreciate the passion you show for the game!

To help us get the best out of each report we need you to include all the information you possibly can about your build of the game, system and the bug itself. The more information we have the easier it is for us to identify and fix. So with that in mind here's a few guidelines to help us get the information we need.

Cheers everyone!

Reporting Bugs

For each unique bug please do the following:

  • Open a new thread on our official forums[forum.subterraneangames.com]. Our forums allows us to manage bug reports more granularly. Among other things, it allows us to track each bug as an individual issue and merge similar reports so that our code team can get a better picture of the current state of each bug.
  • If you're posting a crash please post them in our crash report topic.[forum.subterraneangames.com]
  • Include the information as outlined in this thread on our forums[forum.subterraneangames.com]
  • Be sure to include any information you can about how the bug came about and if you can try to replicate it and provide us with clear steps to reproducing it ourselves.
  • For Multiplayer reports please indicate if you were the client or the host.
  • Videos, Screenshots, anything else that might help us replicate is welcome.


Last edited by Noontide; Aug 23, 2014 @ 12:45pm
Showing 1-15 of 149 comments
< >
The_Bloods Feb 10, 2014 @ 9:08pm 
I have loved dk since the first one and am liking this one so far only issues i have is it starts to slow down during game play and when i click on build or any thing at my menu it clicksd on tiles as well. I cant get updates easy either i have to mess with file verify alot to get it to update. Must beat this game have beat all the rest is only one left to terize lol.
Last edited by The_Bloods; Feb 10, 2014 @ 9:08pm
ZoneMaster May 3, 2014 @ 7:59am 
When I finished the tutorial and clicked on the 'Main Menu' to go there the game exited to the desktop. I have the Linux version.


Processor Information:
Vendor: AuthenticAMD
CPU Family: 0x15
CPU Model: 0x10
CPU Stepping: 0x1
CPU Type: 0x0
Speed: 2500 Mhz
2 logical processors
2 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 14.04 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.13.0-24-generic
X Server Vendor: The X.Org Foundation
X Server Release: 11501000
X Window Manager: Compiz
Steam Runtime Version: steam-runtime-release_2014-04-15

Video Card:
Driver: ATI Technologies Inc. AMD Radeon HD 7420G

Driver Version: 4.4.12874 Compatibility Profile Context 14.10
OpenGL Version: 4.4
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x1002
DeviceID: 0x9992
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1600 x 900
Desktop Resolution: 1600 x 900
Primary Display Size: 15.04" x 8.43" (17.20" diag)
38.2cm x 21.4cm (43.7cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: ATI R6xx HDMI

Memory:
RAM: 3347 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 465079 Mb
Largest Free Hard Disk Block: 291309 Mb

Installed software:

Recent Failure Reports:
Sat May 3 12:06:18 2014 GMT: file ''/tmp/dumps/assert_20140503080605_16.dmp'', upload yes: ''CrashID=bp-5126b17e-cd97-4624-95c2-ca08c2140503''

FlyxDK Aug 9, 2014 @ 9:18pm 
I am getting black screen, on higher resolution that 1024
Silver Spade Aug 14, 2014 @ 5:16am 
Hey guys I just purchased this as the OSX compatibility problem wasn't listed on your storefront anymore. You have it listed in this article and the game crashes within 2 min. I assume it is still a problem, do you have any ETA on a fix yet?
v0id  [developer] Aug 22, 2014 @ 11:30am 
Hey guys,
this thread is not supposed to report bugs. It is just there to explain how to properly create bug reports.

Please head over to https://forum.subterraneangames.com/forums/bedrock-beta-bug-reports.70/ and report bugs there.

If you do it here it's not very likely that they will be read, while we are eager to get all reports fixed in our bug reports forum linked above.

@OSX version: it should work for almost everyone with the current public version, but some people reported problems when playing with too high quality settings especially on low and mid range specs. In this case the game just crashes which is a problem specific to the Unity Engine version used in the current public build.

However the current public version (0.4.3) is a bit outdated and will get soon replaced by the new 0.5.0 version, which should run a lot smoother on OSX.

You can already try the current work in progress of this version if you sign in our patch testing branch (https://forum.subterraneangames.com/threads/patch-testing-bedrock-beta-v0-5-0-dungeons-for-two.6125/) which provides nightly builds of the game and many issues you have are potentially fixed there.

I hope this helps you.
Cheers
Last edited by Noontide; Aug 23, 2014 @ 12:45pm
Silver Spade Aug 22, 2014 @ 6:32pm 
Many thanks v0id, I'll be sure to report bugs there for you and sign up to the nightly builds
Dunn Aug 30, 2014 @ 4:12am 
Here are on the below link 12 crash dumps log files produced by "War for the overworld", fix this please. As it is impossible for me to play the survival map without game crash when I get to the behemot wave... It crashes on 2560x1440 resolution aswell as on 1280x720.. Makes no difference.
{LINK REMOVED}http://ge.tt/4NUNans1/v/0?c
Sir Mountebank Aug 31, 2014 @ 1:04pm 
So I put in one of those Animal Pen rooms, and as soon as the announcer said something had entered my dungeon the game froze. Are certain animals not actually in the game yet? I think he said it was a 'Skarg', if that's any help.
[LINUX]oldrocker99 Sep 10, 2014 @ 9:05pm 
Linux version:

The game has started every time I've run it, but, for the first time, after the update, the window opened and immediately closed again, after the Unity screen rez and size dialog.



From the terminal:

oldrocker99@oldrocker99-Desktop:~/.steam/steam/SteamApps/common/War For The Overworld$ ./WFTOGame.x86_64
Set current directory to /home/oldrocker99/.local/share/Steam/SteamApps/common/War For The Overworld
Found path: /home/oldrocker99/.local/share/Steam/SteamApps/common/War For The Overworld/WFTOGame.x86_64
Mono path[0] = '/home/oldrocker99/.local/share/Steam/SteamApps/common/War For The Overworld/WFTOGame_Data/Managed'
Mono path[1] = '/home/oldrocker99/.local/share/Steam/SteamApps/common/War For The Overworld/WFTOGame_Data/Mono'
Mono config path = '/home/oldrocker99/.local/share/Steam/SteamApps/common/War For The Overworld/WFTOGame_Data/Mono/etc'
PlayerConnection initialized from /home/oldrocker99/.local/share/Steam/SteamApps/common/War For The Overworld/WFTOGame_Data (debug = 0)
PlayerConnection initialized network socket : 0.0.0.0 55021
Multi-casting "[IP] 192.168.1.5 [Port] 55021 [Flags] 2 [Guid] 2153506264 [EditorId] 3962654383 [Version] 1048832 [Id] LinuxPlayer(192.168.1.5) [Debug] 0" to [225.0.0.222:54997]...
PlayerConnection already initialized - listening to [192.168.1.5:55021]
Aborted (core dumped)




Kubuntu 14.04, LXQT desktop
AMD Phenom II 965 CPU
16 GB PC1333 RAM
GeForce 650ti, nVidia 3.43.13 drivers

[EDIT] After today's upgrade, it does come up. Thanks!
Last edited by [LINUX]oldrocker99; Sep 11, 2014 @ 10:11am
buttscratcher Jan 22 @ 6:46am 
The beastmaster doesn't walk over the floor but is with his legs in the floor looks a bit like he is floating
hacks21 Jan 27 @ 11:53pm 
Sometimes when enemies are group together and dies ... there will be a shadow of unit animation repeating itself like a ghost
Et Cete Mar 7 @ 2:33am 
after quit the game a while,then came back to play, the game is freeze on first screen. i can't play it anymore.
AvatarIII Mar 7 @ 10:06am 
try verifying cache, that normally helps :)
Dorian666 (FR) Mar 8 @ 12:32am 
KERNELBASE.dll caused a Breakpoint (0x80000003)
in module KERNELBASE.dll at 0033:04dee002.

Error occurred at 2015-03-08_092442.
F:\SteamLibrary\steamapps\common\War For The Overworld\WFTOGame.exe,
56% memory in use.
8141 MB physical memory [3510 MB free].
9421 MB paging file [4059 MB free].
134217728 MB user address space [134215175 MB free].

Context:
RDI: 0x62a6f228 RSI: 0x62a6f000 RAX: 0x00000001
RBX: 0xf5827d30 RCX: 0x91aa6370 RDX: 0x00000064
RIP: 0x04dee002 RBP: 0x00ffe4f0 SegCs: 0x00000033
EFlags: 0x00000206 RSP: 0x00ffe3e8 SegSs: 0x0000002b
R8: 0x010d0fc0 R9: 0x00008000 R10: 0x00000000
R11: 0x00ffe1f0 R12: 0x00000001 R13: 0x00000003
R14: 0x00001930 R15: 0x891b4330

Bytes at CS:EIP:
cc c3 90 90 90 90 90 90 90 90 65 48 8b 04 25 30 Module 1
C:\WINDOWS\SYSTEM32\xinput1_3.dll
Image Base: 0x00400000 Image Size: 0x0001e000
File Size: 107368 File Time: 2007-04-04_185422
Version:
Company: Microsoft Corporation
Product: Microsoft® DirectX for Windows®
FileDesc: Microsoft Common Controller API
FileVer: 9.18.944.0
ProdVer: 9.18.944.0

Module 2
C:\WINDOWS\system32\SETUPAPI.dll
Image Base: 0x0af70000 Image Size: 0x001da000
File Size: 1950280 File Time: 2014-10-29_050928
Version:
Company: Microsoft Corporation
Product: Système d’exploitation Microsoft® Windows®
FileDesc: Installation de L’API Windows
FileVer: 6.3.9600.17415
ProdVer: 6.3.9600.17415

Module 3
C:\Program Files (x86)\Steam\vstdlib_s64.dll
Image Base: 0x61030000 Image Size: 0x00063000
File Size: 317352 File Time: 2015-02-19_005140
Version:
Company: Valve Corporation
Product: Steam
FileDesc: vstdlib_ s.dll
FileVer: 2.63.41.43
ProdVer: 3.0.0.1

Module 4
C:\Program Files (x86)\Steam\tier0_s64.dll
Image Base: 0x610a0000 Image Size: 0x00124000
File Size: 332200 File Time: 2015-02-19_005134
Version:
Company: Valve Corporation
Product: tier0_s Dynamic Link Library
FileDesc: tier0_s Dynamic Link Library
FileVer: 2.63.41.43
ProdVer: 1.0.0.1

Module 5
C:\Program Files (x86)\Steam\steamclient64.dll
Image Base: 0x611d0000 Image Size: 0x00bd0000
File Size: 12228944 File Time: 2015-02-19_005132
Version:
Company: Valve Corporation
Product: Steam
FileDesc: Steamclient.dll
FileVer: 2.63.41.43
ProdVer: 3.0.0.1

Module 6
F:\SteamLibrary\steamapps\common\War For The Overworld\steam_api64.dll
Image Base: 0x61da0000 Image Size: 0x0002e000
File Size: 166080 File Time: 2015-01-01_104658
Version:
Company: Valve Corporation
Product: Steam Client API
FileDesc: Steam Client API
FileVer: 2.30.48.16
ProdVer: 1.0.0.1

Module 7
C:\WINDOWS\SYSTEM32\atiumd6a.dll
Image Base: 0x61dd0000 Image Size: 0x00737000
File Size: 7520200 File Time: 2014-04-18_034230
Version:
Company: Advanced Micro Devices, Inc.
Product: Advanced Micro Devices, Inc. Radeon Video Acceleration Universal Driver
FileDesc: Radeon Video Acceleration Universal Driver
FileVer: 8.14.10.448
ProdVer: 8.14.10.448


== [end of error.log] ==
Umbreon Mar 16 @ 3:29am 
Hey, i bought this game this week and was eager to try it out, but each time i open it i just get a black background, i tried fiddeling around the and entered the campain, but it was still black..the only thing i can see is the minimap, the hand and the subtitle, But i can't see any ingame. Which is a bit annoying as i really wanted to try it. I don't know if anyone else have had the same problem, I tried to reinstal it but nothing worked...Any sugestions?
Showing 1-15 of 149 comments
< >
Per page: 15 30 50