DOOM II: Hell on Earth > Общи дискусии > Подробности за темата
VILKAS 2 януари 2013 в 5:31след.
using forward/back key and mouse
hi guys, i'm getting bit confused of controls on my mouse. I always use controls on my keybord to move and my mouse to aim and shoot. How can I disable mouse for moving in the game?


cheers
Показване на 1-11 от 11 коментара
< >
Scoops 28 януари 2013 в 1:34след. 
unplug the mouse
Melon 1 февруари 2013 в 1:45след. 
To give a more helpful response, it's not actually possible in the original game. Pretty much every source port made since wil let you do it though, including Chocolate Doom. FPS control schemes have come a long way since Doom was first made, I don't think using the mouse solely for aiming in combination with moving using the keyboard ever crossed their mind when making this game.
Последно редактиран от Melon; 1 февруари 2013 в 1:46след.
REB.- 2 февруари 2013 в 7:05след. 
[Disable vertical mouse input]

Do you just want to aim with your mouse instead of accidentally walking forward and backward whenever you move your mouse accordingly? Well here is an ancient fix that will work for all dos games: http://www.doomworld.com/idgames/index.php?id=12039
When originally typed into dos, it disabled vertical mouse movement for games. However, you can get dosbox to automatically load it into the games you want it to.

1. Download novert.exe and place it into the base folder of whatever dos game.
2. find your conf and go down to [autoexec] at the bottom of the file.
3. In between the drive letter and the .exe, type novert. It should look as so for ultimate doom:
mount c .\base
Code:

_____________________________
c: |
novert |
doomp.exe -config MOUSE.CFG |
exit |
----------------------------------------------------



Now you can aim the way you want to.
Poutine Fox 2 февруари 2013 в 8:54след. 
This is so awesome thank you for that link.
VILKAS 3 февруари 2013 в 4:15сут. 
Първоначално публикувано от .:F1X3D:.:
[Disable vertical mouse input]

Do you just want to aim with your mouse instead of accidentally walking forward and backward whenever you move your mouse accordingly? Well here is an ancient fix that will work for all dos games: http://www.doomworld.com/idgames/index.php?id=12039
When originally typed into dos, it disabled vertical mouse movement for games. However, you can get dosbox to automatically load it into the games you want it to.

1. Download novert.exe and place it into the base folder of whatever dos game.
2. find your conf and go down to [autoexec] at the bottom of the file.
3. In between the drive letter and the .exe, type novert. It should look as so for ultimate doom:
mount c .\base
Code:

_____________________________
c: |
novert |
doomp.exe -config MOUSE.CFG |
exit |
----------------------------------------------------



Now you can aim the way you want to.

Thanks a lot for your help! It works!
BETTY [R.I.P F.C.T.V] 13 април 2013 в 6:22сут. 
seroiusly, just download GZdoom
REB.- 13 април 2013 в 10:17сут. 
Първоначално публикувано от VandY:
seroiusly, just download GZdoom

Some people just want to play the original DOOM on DOSBox and not a Source Port. It's about nostalgia...
YEEZUS 4 август 2013 в 1:18сут. 
Първоначално публикувано от REB.-:
[Disable vertical mouse input]

Do you just want to aim with your mouse instead of accidentally walking forward and backward whenever you move your mouse accordingly? Well here is an ancient fix that will work for all dos games: http://www.doomworld.com/idgames/index.php?id=12039
When originally typed into dos, it disabled vertical mouse movement for games. However, you can get dosbox to automatically load it into the games you want it to.

1. Download novert.exe and place it into the base folder of whatever dos game.
2. find your conf and go down to [autoexec] at the bottom of the file.
3. In between the drive letter and the .exe, type novert. It should look as so for ultimate doom:
mount c .\base
Code:

_____________________________
c: |
novert |
doomp.exe -config MOUSE.CFG |
exit |
----------------------------------------------------



Now you can aim the way you want to.
could you help me with the second step. I am confused on what to do. I have placed the novert file into the base file of doom 2.
YEEZUS 4 август 2013 в 1:19сут. 
or can anyone in this thread explain. i think the guy hasnt been online in months. much appreciated
Tuuka 4 август 2013 в 8:19сут. 
How can I enable Y axis mouse control, in order to aim vertically? I have managed to do this with GZDoom and Ultimate Doom but not for Doom II. Please help :(
REB.- 12 август 2013 в 9:31сут. 
Първоначално публикувано от YEEZUS:
or can anyone in this thread explain. i think the guy hasnt been online in months. much appreciated

Uhm... FIRE!

Search your Doom 2 folder, it's usually installed on C:/Programfiles/Steam/Steamapps/Common/Doom 2

Then, if you are going to play DOOM 2 with Mouse open the "doom2m.conf" file

If you are gonna play DOOM 2 with the Original Controls open the "doom2.conf" file

Once you are on the damn file just go down to [autoexec] at the bottom of the file.

3. In between the drive letter and the .exe, type novert. It should look as so for DOOM II:
[autoexec]

mount c .\base
c:
novert
doom2.exe -config MOUSE.CFG
exit

That's it... Its very simple but hard to explain lol

If you don't get it watch this guide:

Последно редактиран от REB.-; 12 август 2013 в 9:33сут.
Показване на 1-11 от 11 коментара
< >
На страница: 15 30 50