Multi 10 mei om 8:09nm
DOOM 2 wont go past a picture
It shows a picture of a guy with a shotgun.
1-15 van 15 reacties weergegeven
< >
Multi 10 mei om 9:09nm 
I got it fixed with the Doom 2 fix down below, all good. On windows 8 so thats prolly why haha
Rudy432 10 mei om 11:05nm 
how do you fix it on windows 8 im having that issue
Multi 11 mei om 12:06vm 
Theres a thread on here that will do it for you you gotta change config files
pepperonipizza 11 mei om 3:40vm 
I can't find that thread. Can you copy the config-instructions for us? :)
Multi 11 mei om 3:54vm 
Yeah sure
Multi 11 mei om 3:56vm 
So, getting Doom 2 to work on Windows 8 is not a long, nor difficult task. I'd like to point out that I did actually get my help from the internet, but I did have to improvise a bit.
First, go to OS (C:) > Program Files (x86) > Steam > steamapps > common > Doom 2 > base
Right-click DOOM2 and go to 'Properties' then set compatability mode to Windows 95.
Then, go to doom2.conf and open it with Notepad.
Change 'fullscreen=true' to 'fullscreen=false' and 'waitonerror=true' to 'waitonerror=false'.
After that, go to doom2m.conf and do the same thing.
Then, open dosbox.conf and scroll down to where it says 'waitonerror=true' and change it to 'waitonerror=false'
Make sure you save these changes and close the files.
Go to your Steam Library and go to Doom 2: Hell on Earth and click 'Play'
If it still doesn't work, like it did for me, go to doom2.conf and change 'fulldouble=true' to 'fulldouble=false'
Do the same thing for doom2.conf.
After this, it should all work.
Hope this helped you! :)
Tarvis 11 mei om 8:32vm 
Simple fix:

Go to the base folder, open up doom2m.conf, find the line "cycles" under the [cpu] section and set it to "max", find the line "output" under the [sdl] section and change it to "opengl"
ricky.d.keim 11 mei om 2:07nm 
if you are uncomfortable editing files the other thing to do is look on the doom wiki for scource ports. I have doomsday scource port which makes the game look very nice and polished. if you want something closer to the game in its orginal state try Chocolate Doom. I bought these games this morning and had to tweak them to get them working on windows 8.1 the scource ports are awesome check them out.
Poptartmasta92 11 mei om 8:57nm 
Get a surce port to play online like Zandronum.

If you want it to play more like when it came out try Chocolate Doom.

PipebassGomez 14 mei om 6:09nm 
Hey thanks for solving this problem. finally is working for me.
I have a question, somebody has solved the movement with mouse control? It always walk forward or backward if I move the mouse and is kinda ♥♥♥♥ty :/
Multi 14 mei om 6:11nm 
Yeah, there is another thread on here by my friend GeeTee, who has fixd the WASD/Mouse movement in Doom 1/2 and Wolfenstein 3d/spear of destiny. Its on the front page let me link you
Marauder 19 mei om 12:53nm 
Thanks for the help guys. I got it to work.
[23] Bath Salt Zombie [q_Q] 19 mei om 11:46nm 
Origineel geplaatst door Tarvis:
Simple fix:

Go to the base folder, open up doom2m.conf, find the line "cycles" under the [cpu] section and set it to "max", find the line "output" under the [sdl] section and change it to "opengl"

Awsome ! That worked perfectly. Is there a way to enable Steam Overlay in these games ? :o
Tarvis 20 mei om 8:43vm 
Yeah, but it requires hex editing if you want to play the DOSBOX version instead of a sourceport. If all you want to do is play a sourceport, then get Notepad++, go to your Steam install folder, then its appcache folder, and open appinfo.vdf. Ctrl-F for "doom2 + mouse.bat" (without quotes) and replace it with the .exe name of your choice. I prefer to use ZDL.exe, the ZDL launcher, because you can launch any source port from it and still get overlay. Save it and restart Steam for it to take effect.
Laatst bewerkt door Tarvis; 20 mei om 8:45vm
1-15 van 15 reacties weergegeven
< >
Per pagina: 15 30 50