Dragon's Prophet

Dragon's Prophet

View Stats:
OneWayTr!P Oct 1, 2013 @ 2:14pm
**SOLUTIONS TO FIX YOUR GAME**
This is to help you get past the RENA BlackScreen. Clicking PLAY and the game not launching or opening and closing right after, and to fix windows mode start up issue.

(NOTE: Not all solutions work for everyone so dont use this discussion to complain if something did not work for you. We all use different PC's and most times the problem has nothing to do with the game. Its mainly your rig and what you install on it that ither converts files to a different type changes the way some files work. Or you just plan dont know what you are doing with your PC and screwed it up.)

Also some Widescreen Monitors dont work with the game. This is information posted on there website. (And for the record, I have a widescreen HP 24 inch Monitor. I can ALT+Enter and it works for me, I do not know if issues with monitors are related to some brand names).

Window Mode Fix: Fixing windows mode if the game runs fine:
ALT + Enter, Will Fullscreen/Windowmode ANY GAME on a Windows OS. After the game is launched and the blackscreen changes to SoE logo.

RENA BlackScreen and PLAY Button: Try one of these two methods.
1st Option: Go into your steam library, right click Dragon's Prophet click Properties and Uncheck the Enable Steam Community In-Game. That worked for me to fix my launching issue and in game crashing, game started up normally for me and has been working for me just fine.

NOTE: For the 1st Option and the one that worked for me. You will still see the RENA BlackScreen after clicking PLAY but the game will Launch in 3-10 seconds and go to fullscreen. Steam Community Overlay In-Game (Shift-Tab) is what prevented the game from launching for me. It is what also causes the game to crash if it is getting passed the launch issue.

This solution I found on discussions has to do with altering the resolution in the config file. After you preform this solution you can change your resolution in game after creating your character.

2nd Option: (Original Poster): zerg_humand
Go into your steam library, right click Dragon's Prophet click Properties. Click on the Local Files tab. From there, click "Browse Local Files..."
Find the config file and open it up. Scroll down until you see this:

[Window]
DefaultWindowWidth = 1680
DefaultWindowHeight = 1050
Windowed = 0

Change the width and height to your standard game settings (Most games defaults are 1024x768 or 1280x768 1024x720 or 1280x720 and if you really need to try 800x600) and then save the file. The next time you start the game it should display correctly.

You can try going to there website and downloading the game from there which I hear people have done that and do not have any issues with the normal installation from SoE. Alot of MMORPG games are known to have issues running on steam with the community overlay in game. (Shirt-Tab).

I hope this will help anyone who is having trouble. I am sorry if you are one of that few that cannot enjoy the game. It really is not that bad. Good luck and take care everybody.
Last edited by OneWayTr!P; Oct 2, 2013 @ 5:09pm