Soulײַ Mar 4, 2013 @ 6:21pm
Multiplayer not working *HELP*
My friend and I both bought Baldur's Gate only to get the disapointment of not being able to play together, as we both saw it being a Multiplayer game.

After countless hours of trying out both eachothers ip's, port forwarding even using Hamachi. Nothing is working, does anyone have a fix or tip? It just gets stuck in the (joining selected session... this may take a while, please wait) we both are typing in the correct IP but still failure to join, is there a certain screen we need to wait in? Do we need to include any ports in with the IP? Please help anyone, feeling like this was a waste of cash and time and a huge disapointment.
Showing 1-9 of 9 comments
< >
Bossonova911 Mar 4, 2013 @ 7:14pm 
Join the club. p.s nice username, it's one of my favourite bands.
Soulײַ Mar 4, 2013 @ 7:19pm 
Ugh I wish there wasn't a club, thank you been my alias for very long time now. ^^
[Ars]Baen Mar 4, 2013 @ 9:22pm 
are you both using the steam version?
Soulײַ Mar 5, 2013 @ 1:24am 
Yes we are.
Bossonova911 Mar 5, 2013 @ 1:55am 
correct
Hikoh Mar 5, 2013 @ 6:13pm 
try again, v1.0.2014 just happened. i was having multi-player issues, not its all fine even without hamachi
Hikoh Mar 5, 2013 @ 6:15pm 
and if you still cant i might be due to your internet, such as restrictions, or NAT type not connecting to other NAT type. look into everything, it might not be soly the games fault, but dont get me wrong, might be the game too.
Bossonova911 Mar 5, 2013 @ 7:08pm 
Soulײַ Mar 6, 2013 @ 5:55am 
Thanks for your input guys, It will be tested. :)
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Mar 4, 2013 @ 6:21pm
Posts: 9