griffer82 Oct 14, 2013 @ 7:44pm
Help! graphics corrputed - game does not display correctly
Hi, I'm running BG:EE on an ispiron 9300 with a ATI mobility radeon x300 graphics card, which (i believe) meets the system requirements, but when i run the game all i get is this:

http://steamcommunity.com/profiles/76561198084509617/screenshots/


I've tried updating my drivers, and i've been all over these forums and the foums over at beamdog but i can't seem to fix the problem. Is my system incompatible? how can i fix this? It's incredibly frustrating!

thanks to anyone who can point me in the right direction.

Last edited by griffer82; Oct 14, 2013 @ 9:10pm
Showing 1-6 of 6 comments
< >
Crazed Possum Oct 15, 2013 @ 2:30am 
try turning off any global triple buffering and antialising.
griffer82 Oct 15, 2013 @ 5:59pm 
Thanks for the response! however I'm not able to change (or find) those settings in the control panel for my video card. at the most i can decrease the antialising to 2x, but it doesn't help.
SeriousCat Oct 15, 2013 @ 11:55pm 
Originally posted by griffer82:
Thanks for the response! however I'm not able to change (or find) those settings in the control panel for my video card. at the most i can decrease the antialising to 2x, but it doesn't help.

Are you using an Nvidia or ATI graphics card? If you're using an Nvidia card, do the following:

Nvidia Global 3D Settings

1. If Nvidia, go to the following menu path:

Nvidia Control Panel > Manage 3D settings > Global Settings

2. Change the following options to the specified values:

Anisotropic Filtering: Application-controlled
Antialiasing - Mode: Application-controlled
Triple buffering: Off
Vertical sync: Use the 3D application setting
griffer82 Oct 16, 2013 @ 7:05pm 
it's an ATI card so it doesn't have those particular settings unfortuntely. torchlight runs fine, but this piece of crap - nothing but trouble. it worked once. once. i played for an hour. oh well.
Crazed Possum Oct 17, 2013 @ 1:18pm 
Originally posted by griffer82:
it's an ATI card so it doesn't have those particular settings unfortuntely. torchlight runs fine, but this piece of crap - nothing but trouble. it worked once. once. i played for an hour. oh well.

Your Ati card should have a catalyst control panel inorder to change and setup your video card. if not you may want to download the catalyst from Ati's webpage for your model of card.
griffer82 Oct 18, 2013 @ 4:43pm 
Thanks for the response - I dowloaded the catalyst control panel some time ago (before posting originally) - There isn't an option to completely turn off antialiasing, but i did leave it at application-controlled (same with the filtering setting). There also isn't a setting for tripple buffering.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Oct 14, 2013 @ 7:44pm
Posts: 6