Chatterbox0016 Nov 28, 2013 @ 1:31pm
Error upon start-up
So I just bought BG:EE on the steam sale. After installing, when I go to run the game I immediately get an error. There aren't any details when the error occurs, other than where the crash report is located.

After locating the crash file (DMP), it asks me to find a program to run it with.

I tried using the installing application located in:

C:/ProgramFiles(x86)/Steam/SteamApps/common/Baldur's Gate Enhanced Edition/_CommonRedist/OpenAL/2.0.7

This doesn't really do anything other than confirm the game is installed.

Do I reinstall? If so, how should I make sure I do it correctly. Or is there a simpler fix?

Sorry if this has been covered, I tried other solution posted for similar problems and couldn't figure it out.
Showing 1-15 of 47 comments
< >
kingragnork Nov 28, 2013 @ 4:03pm 
I have the same problems, i've done every solution i've read about on the forums and nothing.
Last edited by kingragnork; Nov 28, 2013 @ 4:57pm
Crazed Possum Nov 28, 2013 @ 8:48pm 
turn off DEP .

THIS IS FOR WINDOWS 7 AND I KNOW YOU HAVE WINDOWS 8.1 SO FOR NOW YOU'LL HAVE TO FIGURE IT OUT CAUSE IM OFF TO WORK...SORRY

1. CLICK THE START BUTTOM AT THE LOWER LEFT OF THE DESKTOP SCREEN
2. WHERE IT SAYS "SEARCH PROGRAMS AND FILES" BOX TYPE IN THERE ( SYSDM.CPL)
3.THE BOX THAT APPEARS HAS 5 TABS ACROSS THE TOP OF IT. CHOOSE (ADVANCE)
4.THE FIRST ONE LABLED (PERFORMANCE, VISUAL EFFECTS,PROCESSOR SCHEDULING,MEMORY USAGE......... CLICK THE (SETTINGS) BUTTON.
5.THERE WILL BE A LIST, BUT DON'T WORRY ABOUT THAT.....ACROSS THE TOP OF THAT WINDOW BOX ARE 3 MORE TABS. CLICK (DATA EXECUTION PREVENTION)
6.YOUR DEP SHOULD PROBABLY BE TURNED ON ALREADY.

7.Click the Data Execution Prevention tab, and then click Turn on DEP for all programs and services except those I select.


BUT NOW YOU CAN "ADD" A GAMES EXECUTION FILE (THE ONE THAT STARTS THE GAME UP) TO THE LIST SO YOU CAN THUS TURN IT OFF WHEN YOU PLAY JUST THAT GAME. YOUR GAME START FILE WILL ALMOST ALWAYS LOOK SOMETHING LIKE THIS: (RTC3.EXE) FOR RAILROAD TYCOON 3, OR ( PR2.EXE) FOR PORT ROYALE 2. IN YOUR CASE YOU WILL WANT TO ADD BALDUR'S GATE OR BGEE.EXE LOCATED IN THE BALDURS GATE DIRECTORY: C:\PROGRAM FILES (X86)\STEAM\STEAMAPPS\COMMON\BALDUR'S GATE ENHANCED EDITION\......SCROLL DOWN TO BGEE AND HIGHLIGHT IT AND ADD THE EXECUTABLE TO THE DEP LIST.....DONE.

NOTE: THIS IS IN CAPS INORDER TO SEE IT BETTER WHILE TROUBLESHOOTING YOUR COMPUTER.
kingragnork Nov 29, 2013 @ 12:02am 
Thanks for posting that all over the forums Crazed but i've tried every available solution on here and the BG:EE forums and i still get that crash dump error. I am trying to run this on a gaming laptop, i'm sure I would have zero problems if I had a desktop.
Last edited by kingragnork; Nov 29, 2013 @ 12:03am
Mercure Nov 29, 2013 @ 3:08am 
First of all, do you have 2 GPU's? If so, try to force the game to use the other GPU.

Secondly, I'm assuming this isn't the case (as it happened right after installing the game), but you haven't installed any mods, aye? Mods can occasionally cause trouble after patching.

BGEE used to have major troubles with OpenGL in the past, and I think OpenAL is similar (though don't quote me on this one). Most problems with OpenGL should have been fixed though.

Have you already tried to verify the game cache? Go to library > right-click on BGEE > properties > local files tab > Verify Game Cache buttons. That may work. May take a while.

Another horribly simple solution which works for some: restart the PC. You may have already done that, but it never hurts to mention it.

If you decide to attempt to reinstall it, try installing it outside of the program files folder. I myself avoid installing games in the ProgramFiles folder like the plague, as it can occasionally mess up some games.

If none of these (admittedly basic) ideas work, let us know what chipset/GPU you use. With a bit of luck, we can figure this out somehow.
[squirps] Nov 29, 2013 @ 7:55am 
Thank you Crazed! Went through two reinstalls and other various troubleshooting procedures, but your solution worked perfectly. To the OP, I hope you get yours working soon :)
AStainlessSteelRat Nov 29, 2013 @ 8:46pm 
Thanks for the post Crazed Possum, that fixed my problem straight away!
Chatterbox0016 Nov 29, 2013 @ 9:27pm 
Thanks Crazed Possum, I saw your solution in another post but it didn't work.

Mercure- I don't believe I have 2GPU's and I certainly haven't downloaded any mods that I am aware of. I have restarted the computer many times and verified the game cache.

How do I go about reinstalling outside of the program files folder?
Novo67 Nov 29, 2013 @ 9:31pm 
check that your desktop resolution is on 32 bit color and not 16 bit under advanced resolution settings. This worked for me and I tried all the other suggestions like you.
Mercure Nov 29, 2013 @ 9:33pm 
Originally posted by Royale:
How do I go about reinstalling outside of the program files folder?
I've never had to do it myself (I keep my Steam outside of the Program Files Folder at all times, and it is in fact on another partition (D, I reserve my C for my OS and for other software required for running the PC/software required for work/studying), but if memory servers, when you install any game, you can choose where to install it.

Just go to library > right-click BGEE > Install game... > Change the options in the dropdown box under the line "Choose location for install."
Last edited by Mercure; Nov 29, 2013 @ 9:34pm
Chatterbox0016 Nov 29, 2013 @ 9:33pm 
Also, when I try Crazed's solution, and running the file directly out of my documents instead of through Steam, I dont get the error but instead, nothing happens.

Video Card: ATI Mobility Radeon 5470
Mercure Nov 29, 2013 @ 9:37pm 
By the way, if that doesn't work, can you give us a screenshot of the error message? Just in case there's something useful there. Remember to cut&paste and/or censor stuff in the screenshot as you see fit to protect your privacy and such. :)

Another thing which works for some: try to update your graphic drivers. Preferably uninstall the old ones first (or let the driver update installers do that for you) to make sure you don't get any OTHER problems.
Chatterbox0016 Nov 29, 2013 @ 9:46pm 
When I try to install elsewhere on the C drive, it won't let me because there is already a games folder on the C:/ apparently.
Mercure Nov 29, 2013 @ 9:48pm 
I assume you have no D drive, then?

Have you already updated your graphic drivers by the way? That's worth a shot as well. It certainly has solved various problems for other people. :)
Chatterbox0016 Nov 30, 2013 @ 10:50am 
So I uploaded a screenshot of my error message to Community. Unfortunately I have it under the FF7 tab, but as it is my only uploaded content, it shouldn't be hard to find on my profile.

Also, my video drivers probably do need updating but I am having trouble doing so with detection software. A little nervous to do so manually.
Chatterbox0016 Nov 30, 2013 @ 11:20am 
UPDATE:

SO now, the error message no longer shows up, but instead the game simply doesnt open. It shows up in my task manager but then quickly closes down. I will continue to look at other posted solutions to this problem in hope of finally getting to play this game!
Showing 1-15 of 47 comments
< >
Per page: 15 30 50