Cyradis314 Nov 28, 2013 @ 12:41pm
Fails to Launch - Thanksgiving
The game launched for me fine two days ago. My dad's GF used my computer to log into Steam to check a few things, then I logged back in. I've downloaded some new games during the sale. Go to play BGEE... no launch. Briefly acts like it will, then nothing happens. Been through the guides that Steam has listed already, and it still does nothing.
The game is fun, but it has been the absolute worst on playability and support. First the Beamdog launch last year and that non-playability, then it won't play on a new graphics card, and now this. Any help would be great, I'd like to be able to go back to playing the game!
Happy Thanksgiving and gaming, everyone!
Showing 1-15 of 29 comments
< >
Mercure Nov 28, 2013 @ 12:58pm 
Well, you can try the Beamdog BGEE forums, but I'm not sure they can help you. Atari is responsible for the Steam BGEE client - Beamdog has no control over the Steam client. Technically, Atari should provide support, though I don't think their track record is very good in that regard. :/

I'm fairly sure they're try to help you on the Beamdog BGEE forums, mind you, but if it's a Steam client issue, then you may be out of luck until Atari does something about it.

First things first however. Have you tried to verify the integrity of the game cache yet? To do so, go to your Steam library and find BGEE in the list. Right-click BGEE and select properties. In the properties window, go to the Local Files tab and press "Verify Integrity of Game Cache." It needed, the game will download the required files to replace any damaged/corrupted/missing files. This tends to solve most problems such as these. If that fails, you can try to uninstall the game and then do a clean installation afterwards. Takes some time, but it might fix it.

PS: Concerning the graphic card issue - that was fortunately solved in patch 1.2 (or at least, it was solved for me). Mostly a driver issue. I think it was mostly Intel not supporting OpenGL (2) properly and refusing to fix things on their end, meaning that Beamdog had to recode parts of the engine to get things to work (which is why it took so long). It's not the only game with such issues though. I believe quite a few gamers (including me) also have trouble running Minecraft smoothly because of it. Intel & co. are aware of it, but simply refuse to fix it, despite it affecting thousands upon thousands of players. Kind of sucks, but such is the sad reality of life. :/

Here's hoping that you manage to get the game running again. Restarting the PC occasionally also fixes issues (though you have probably tried that already). If all else fails, I'd still advise you to take a look at the official BGEE forums ran be Beamdog. Good luck!
Last edited by Mercure; Nov 28, 2013 @ 1:00pm
Cyradis314 Nov 28, 2013 @ 5:02pm 
I did verify the cache, and did restart a few times. The graphics card did get resolved recently. Annoying as all hell since I got the game, and had tons of issues on launch, they failed at a refund (24hrs to DL, then fail to boot), then the graphics issue came up when it actually was playable. It worked a week ago, and now BAM it isn't up. Currently trying to reinstall the game. I wish I knew what caused the crash though, because it wasn't a BGEE patch that I know of :( We'll see!
Thanks for the reply :)
Crazed Possum Nov 28, 2013 @ 8:49pm 
turn off DEP .

THIS IS FOR WINDOWS 7 AND I KNOW YOU HAVE WINDOWS 8.1 SO FOR NOW YOU'LL HAVE TO FIGURE IT OUT CAUSE IM OFF TO WORK...SORRY

1. CLICK THE START BUTTOM AT THE LOWER LEFT OF THE DESKTOP SCREEN
2. WHERE IT SAYS "SEARCH PROGRAMS AND FILES" BOX TYPE IN THERE ( SYSDM.CPL)
3.THE BOX THAT APPEARS HAS 5 TABS ACROSS THE TOP OF IT. CHOOSE (ADVANCE)
4.THE FIRST ONE LABLED (PERFORMANCE, VISUAL EFFECTS,PROCESSOR SCHEDULING,MEMORY USAGE......... CLICK THE (SETTINGS) BUTTON.
5.THERE WILL BE A LIST, BUT DON'T WORRY ABOUT THAT.....ACROSS THE TOP OF THAT WINDOW BOX ARE 3 MORE TABS. CLICK (DATA EXECUTION PREVENTION)
6.YOUR DEP SHOULD PROBABLY BE TURNED ON ALREADY.

7.Click the Data Execution Prevention tab, and then click Turn on DEP for all programs and services except those I select.


BUT NOW YOU CAN "ADD" A GAMES EXECUTION FILE (THE ONE THAT STARTS THE GAME UP) TO THE LIST SO YOU CAN THUS TURN IT OFF WHEN YOU PLAY JUST THAT GAME. YOUR GAME START FILE WILL ALMOST ALWAYS LOOK SOMETHING LIKE THIS: (RTC3.EXE) FOR RAILROAD TYCOON 3, OR ( PR2.EXE) FOR PORT ROYALE 2. IN YOUR CASE YOU WILL WANT TO ADD BALDUR'S GATE OR BGEE.EXE LOCATED IN THE BALDURS GATE DIRECTORY: C:\PROGRAM FILES (X86)\STEAM\STEAMAPPS\COMMON\BALDUR'S GATE ENHANCED EDITION\......SCROLL DOWN TO BGEE AND HIGHLIGHT IT AND ADD THE EXECUTABLE TO THE DEP LIST.....DONE.

NOTE: THIS IS IN CAPS INORDER TO SEE IT BETTER WHILE TROUBLESHOOTING YOUR COMPUTER.
Cyradis314 Nov 28, 2013 @ 9:35pm 
I will give this a try after eating more calories than are healthy for me! I am on Windows 7, not 8, so I won't have to figure that part out, thank goodness!
Dunno if the caps will help too much; perhaps on this gray background it is true. Happy Thanksgiving good sir (or happy thursday anyway, if you aren't celebrating)!
Brother hood of nod Nov 28, 2013 @ 9:48pm 
thankswhat? ima australian is this some kind of chinese holiday?
Last edited by Brother hood of nod; Nov 28, 2013 @ 9:49pm
HaTeMe Nov 28, 2013 @ 11:54pm 
Same here, got it today and it is simply not starting.
I just get a short loading cursor for not even a single second.
Mercure Nov 29, 2013 @ 3:12am 
Can you check in Windows Task Manager if there is a BGEE.exe and/or Baldur.exe process running after attempting to start the game?

I've got the Beamdog version and not the Steam version, so I'm not sure to what extent they're different, but...
Last edited by Mercure; Nov 29, 2013 @ 3:13am
HaTeMe Nov 29, 2013 @ 12:32pm 
No there isn't, I have checked that already yesterday.
I get also the Steam window for new stuff which only happens if you're closing the game, so it is pretty much "crashing" straight at the first moment.

I've googled a few hours and tried different things like trying to update openal and stuff like this but nothing worked.

Really disappointing, I thought they got the game fixed, now that they are working on BG2EE ...
HaTeMe Nov 29, 2013 @ 4:01pm 
*push*
Zomghai Nov 29, 2013 @ 8:02pm 
I had the same problem (running Windows 7).

I just downloaded the game and tried running it for the first time today. Whenever I tried to launch the game, my name would turn green for a few seconds like I was playing, but nothing would ever show up--no error message or anything. I went straight to the game directory and tried to launch directly from there, and that time I did get an error message: OpenAL32 was missing. Checked the Windows\SysWOW64 folder and found there was no OpenAL32.dll file.

If you can install OpenAL Soft and then RENAME its DLL file (in the SysWOW64 folder) to OpenAL32.dll, it should work.

In short, it's looking for an OpenAL driver in the Windows folder and not finding it. If it sees OpenAL32.dll, it should be happy and can launch.

Good luck!
Mercure Nov 29, 2013 @ 9:25pm 
Originally posted by HaTeMe:
No there isn't, I have checked that already yesterday.
I get also the Steam window for new stuff which only happens if you're closing the game, so it is pretty much "crashing" straight at the first moment.

I've googled a few hours and tried different things like trying to update openal and stuff like this but nothing worked.

Really disappointing, I thought they got the game fixed, now that they are working on BG2EE ...
The game IS mostly fixed, but the Steam release is a little different from the Beamdog release (is (or was?) provided by Atari and not directly by Beamdog), and there are so many different PC setups that there will always be somebody experiencing trouble.

To be honest, it sounds like the OpenGL problem which I had, just with OpenAL now. I assume you have already tried to update your GPU drivers? Be sure to uninstall the old drivers before installing the new ones.

Zomghai's solution might also work. Give it a try.
Cyradis314 Nov 29, 2013 @ 9:40pm 
Crazed Possum's method worked! I don't know if your issue is identical to mine, but it is worth a shot. My game is running smoothly again.

Good luck, all!
HaTeMe Nov 30, 2013 @ 5:30am 
Originally posted by Zomghai:
I had the same problem (running Windows 7).

I just downloaded the game and tried running it for the first time today. Whenever I tried to launch the game, my name would turn green for a few seconds like I was playing, but nothing would ever show up--no error message or anything. I went straight to the game directory and tried to launch directly from there, and that time I did get an error message: OpenAL32 was missing. Checked the Windows\SysWOW64 folder and found there was no OpenAL32.dll file.

If you can install OpenAL Soft and then RENAME its DLL file (in the SysWOW64 folder) to OpenAL32.dll, it should work.

In short, it's looking for an OpenAL driver in the Windows folder and not finding it. If it sees OpenAL32.dll, it should be happy and can launch.

Good luck!

It is already called OpenAL32.dll ...

And guys, like I said I already tried to update it without any luck. The original BG1+2 were running fine on the same system, I just had a few problems with the mods.

Also please don't come with stuff like "update your GPU drivers", I'm not an idiot who doesn't know what he is doing and answers like this are really not helpful at all.
HaTeMe Nov 30, 2013 @ 7:46pm 
*push*
Lpokie Nov 30, 2013 @ 11:01pm 
Same situation here, I've tried all of the above. To no avail.
Showing 1-15 of 29 comments
< >
Per page: 15 30 50
Date Posted: Nov 28, 2013 @ 12:41pm
Posts: 29