The Ultimate DOOM > 一般討論 > 主題細節
Skelosk 2012 年 12 月 31 日 @ 下午 3 時 52 分
Color screwing up after 1 minute of gameplay
After a few seconds, up to a minute, the colors screw up. I tought the games were optimised for modern systems.

Guess not. So what do I do to correct this without having to downloads mods or stuff like that?
顯示 1-15,共 15 則回應
< >
Skelosk 2012 年 12 月 31 日 @ 下午 6 時 39 分 
Nevermind, found a fix:

Navigate to your Ultimate Doom folder. (wherever you installed Steam/steamapps/common/ultimate doom/base) There should be three .conf files in there. dosbox.conf, which you don't care about, ultimatem.conf, used for the "modern" mouse controls, and ultimate.conf used for the classic controls. They're plain text files so open them in notepad, find the output=surface token, change it to output=ddraw, and save.

While you're in there, also set aspect=true to fix the aspect ratio (so the game is properly stretched to a 4:3 resolution, as it would've been on any monitor back in the day) and you'll likely need to increase the sensitivity. I use 200 on a system with mouse acceleration disabled.

You shouldn't need to do change the output for any of the other Doom games since they're already set to use ddraw. The sensitivity is set way too high for my mouse in the other games, so you might end up having to tweak that at least.
Unicorn Soldier 2013 年 01 月 1 日 @ 上午 5 時 52 分 
Thanks! You are great.
T34bagm 2013 年 01 月 5 日 @ 下午 9 時 36 分 
Thanks man! Great advice, fixed the 16bit color issue.
TrashMan 2013 年 01 月 27 日 @ 下午 12 時 02 分 
Hi guys, tried the above but it made the screen very small and in the top left hand side of the screen - I have no idea what I'm doing but willing to experiment. After changing several things I tried fullresolution=1920*1200 on both files mentioned above - now it plays full screen. guess if you change it to your max monitor resolution it'll work...

Hope this helps someone
M'ygnal the Wyrm Blessed 2013 年 03 月 25 日 @ 下午 8 時 08 分 
Tried the ddraw solution but I'm still having trouble with the graphics glitching after one minute. Does anyone have any other solutions I might be able to try?
Quick Edit: So far it seems to be happening whenever I'm in the pause menu. I'm running a Windows 7 64 bit laptop if that helps.
最後修改者:M'ygnal the Wyrm Blessed; 2013 年 03 月 25 日 @ 下午 11 時 10 分
HawkeyeWii 2013 年 04 月 4 日 @ 下午 2 時 56 分 
@hipraskey Same here! Still having the same problems :/
HawkeyeWii 2013 年 04 月 4 日 @ 下午 4 時 05 分 
I got it now! @Skelosk Thank you sooooo much!!! They should have that as a default when you download the game!
Don Johnny 2013 年 04 月 9 日 @ 下午 3 時 44 分 
Thanx you so much Man!!!
Soild Sanek 2013 年 07 月 24 日 @ 上午 7 時 21 分 
Or you could have just use a source port, such as Zandronum. Most source ports also allow for the use of mouse look and other modern features.
Zer0]{elvin 2013 年 08 月 3 日 @ 下午 2 時 13 分 
Thanks for this thread, was having the pastel color explosion thing too :/
williew7051980 2013 年 08 月 3 日 @ 下午 5 時 59 分 
Ddraw worked for me! Thank you :-)
HotIce 2013 年 08 月 3 日 @ 下午 7 時 18 分 
Hey i used the ddraw and it worked but the screen was moved up and i dont know what to do can any one help?
mkdoomfan 2013 年 08 月 3 日 @ 下午 7 時 25 分 
Thank you! this helped a lot!
Arcade Goon 2013 年 08 月 4 日 @ 上午 1 時 18 分 
I had better results with the follow settings changed, might help someone.

[sdl]
fullscreen=true
fulldouble=false
fullresolution=desktop
output=opengl

[render]
aspect=true
顯示 1-15,共 15 則回應
< >
每頁: 15 30 50