The Ultimate DOOM > Discussioni generali > Dettagli della discussione
Skelosk 31 dic 2012, ore 15:52
Color screwing up after 1 minute of gameplay
After a few seconds, up to a minute, the colors screw up. I tought the games were optimised for modern systems.

Guess not. So what do I do to correct this without having to downloads mods or stuff like that?
Visualizzazione di 1-15 commenti su 15
< >
Skelosk 31 dic 2012, ore 18:39 
Nevermind, found a fix:

Navigate to your Ultimate Doom folder. (wherever you installed Steam/steamapps/common/ultimate doom/base) There should be three .conf files in there. dosbox.conf, which you don't care about, ultimatem.conf, used for the "modern" mouse controls, and ultimate.conf used for the classic controls. They're plain text files so open them in notepad, find the output=surface token, change it to output=ddraw, and save.

While you're in there, also set aspect=true to fix the aspect ratio (so the game is properly stretched to a 4:3 resolution, as it would've been on any monitor back in the day) and you'll likely need to increase the sensitivity. I use 200 on a system with mouse acceleration disabled.

You shouldn't need to do change the output for any of the other Doom games since they're already set to use ddraw. The sensitivity is set way too high for my mouse in the other games, so you might end up having to tweak that at least.
Unicorn Soldier 1 gen 2013, ore 5:52 
Thanks! You are great.
T34bagm 5 gen 2013, ore 21:36 
Thanks man! Great advice, fixed the 16bit color issue.
TrashMan 27 gen 2013, ore 12:02 
Hi guys, tried the above but it made the screen very small and in the top left hand side of the screen - I have no idea what I'm doing but willing to experiment. After changing several things I tried fullresolution=1920*1200 on both files mentioned above - now it plays full screen. guess if you change it to your max monitor resolution it'll work...

Hope this helps someone
M'ygnal the Wyrm Blessed 25 mar 2013, ore 20:08 
Tried the ddraw solution but I'm still having trouble with the graphics glitching after one minute. Does anyone have any other solutions I might be able to try?
Quick Edit: So far it seems to be happening whenever I'm in the pause menu. I'm running a Windows 7 64 bit laptop if that helps.
Ultima modifica da M'ygnal the Wyrm Blessed; 25 mar 2013, ore 23:10
HawkeyeWii 4 apr 2013, ore 14:56 
@hipraskey Same here! Still having the same problems :/
HawkeyeWii 4 apr 2013, ore 16:05 
I got it now! @Skelosk Thank you sooooo much!!! They should have that as a default when you download the game!
Diobald 9 apr 2013, ore 15:44 
Thanx you so much Man!!!
Sanek 24 lug 2013, ore 7:21 
Or you could have just use a source port, such as Zandronum. Most source ports also allow for the use of mouse look and other modern features.
Zer0]{elvin 3 ago 2013, ore 14:13 
Thanks for this thread, was having the pastel color explosion thing too :/
williew7051980 3 ago 2013, ore 17:59 
Ddraw worked for me! Thank you :-)
HotIce 3 ago 2013, ore 19:18 
Hey i used the ddraw and it worked but the screen was moved up and i dont know what to do can any one help?
mkdoomfan 3 ago 2013, ore 19:25 
Thank you! this helped a lot!
The Black Knight 4 ago 2013, ore 1:18 
I had better results with the follow settings changed, might help someone.

[sdl]
fullscreen=true
fulldouble=false
fullresolution=desktop
output=opengl

[render]
aspect=true
Visualizzazione di 1-15 commenti su 15
< >
Per pagina: 15 30 50
Data di pubblicazione: 31 dic 2012, ore 15:52
Messaggi: 15