Skelosk Dec 31, 2012 @ 3:52pm
Color screwing up after 1 minute of gameplay
After a few seconds, up to a minute, the colors screw up. I tought the games were optimised for modern systems.

Guess not. So what do I do to correct this without having to downloads mods or stuff like that?
Showing 1-15 of 15 comments
< >
Skelosk Dec 31, 2012 @ 6:39pm 
Nevermind, found a fix:

Navigate to your Ultimate Doom folder. (wherever you installed Steam/steamapps/common/ultimate doom/base) There should be three .conf files in there. dosbox.conf, which you don't care about, ultimatem.conf, used for the "modern" mouse controls, and ultimate.conf used for the classic controls. They're plain text files so open them in notepad, find the output=surface token, change it to output=ddraw, and save.

While you're in there, also set aspect=true to fix the aspect ratio (so the game is properly stretched to a 4:3 resolution, as it would've been on any monitor back in the day) and you'll likely need to increase the sensitivity. I use 200 on a system with mouse acceleration disabled.

You shouldn't need to do change the output for any of the other Doom games since they're already set to use ddraw. The sensitivity is set way too high for my mouse in the other games, so you might end up having to tweak that at least.
Unicorn Soldier Jan 1, 2013 @ 5:52am 
Thanks! You are great.
T34bagm Jan 5, 2013 @ 9:36pm 
Thanks man! Great advice, fixed the 16bit color issue.
TrashMan Jan 27, 2013 @ 12:02pm 
Hi guys, tried the above but it made the screen very small and in the top left hand side of the screen - I have no idea what I'm doing but willing to experiment. After changing several things I tried fullresolution=1920*1200 on both files mentioned above - now it plays full screen. guess if you change it to your max monitor resolution it'll work...

Hope this helps someone
M'ygnal the Wyrm Blessed Mar 25, 2013 @ 8:08pm 
Tried the ddraw solution but I'm still having trouble with the graphics glitching after one minute. Does anyone have any other solutions I might be able to try?
Quick Edit: So far it seems to be happening whenever I'm in the pause menu. I'm running a Windows 7 64 bit laptop if that helps.
Last edited by M'ygnal the Wyrm Blessed; Mar 25, 2013 @ 11:10pm
HawkeyeWii Apr 4, 2013 @ 2:56pm 
@hipraskey Same here! Still having the same problems :/
HawkeyeWii Apr 4, 2013 @ 4:05pm 
I got it now! @Skelosk Thank you sooooo much!!! They should have that as a default when you download the game!
Don Johnny Apr 9, 2013 @ 3:44pm 
Thanx you so much Man!!!
Soild Sanek Jul 24, 2013 @ 7:21am 
Or you could have just use a source port, such as Zandronum. Most source ports also allow for the use of mouse look and other modern features.
Zer0]{elvin Aug 3, 2013 @ 2:13pm 
Thanks for this thread, was having the pastel color explosion thing too :/
williew7051980 Aug 3, 2013 @ 5:59pm 
Ddraw worked for me! Thank you :-)
HotIce Aug 3, 2013 @ 7:18pm 
Hey i used the ddraw and it worked but the screen was moved up and i dont know what to do can any one help?
mkdoomfan Aug 3, 2013 @ 7:25pm 
Thank you! this helped a lot!
Arcade Goon Aug 4, 2013 @ 1:18am 
I had better results with the follow settings changed, might help someone.

[sdl]
fullscreen=true
fulldouble=false
fullresolution=desktop
output=opengl

[render]
aspect=true
Showing 1-15 of 15 comments
< >
Per page: 15 30 50