The Ultimate DOOM > Algemene discussies > Details van topic
Skelosk 31 dec 2012 om 3:52nm
Color screwing up after 1 minute of gameplay
After a few seconds, up to a minute, the colors screw up. I tought the games were optimised for modern systems.

Guess not. So what do I do to correct this without having to downloads mods or stuff like that?
1-15 van 15 reacties weergegeven
< >
Skelosk 31 dec 2012 om 6:39nm 
Nevermind, found a fix:

Navigate to your Ultimate Doom folder. (wherever you installed Steam/steamapps/common/ultimate doom/base) There should be three .conf files in there. dosbox.conf, which you don't care about, ultimatem.conf, used for the "modern" mouse controls, and ultimate.conf used for the classic controls. They're plain text files so open them in notepad, find the output=surface token, change it to output=ddraw, and save.

While you're in there, also set aspect=true to fix the aspect ratio (so the game is properly stretched to a 4:3 resolution, as it would've been on any monitor back in the day) and you'll likely need to increase the sensitivity. I use 200 on a system with mouse acceleration disabled.

You shouldn't need to do change the output for any of the other Doom games since they're already set to use ddraw. The sensitivity is set way too high for my mouse in the other games, so you might end up having to tweak that at least.
Unicorn Soldier 1 jan 2013 om 5:52vm 
Thanks! You are great.
T34bagm 5 jan 2013 om 9:36nm 
Thanks man! Great advice, fixed the 16bit color issue.
TrashMan 27 jan 2013 om 12:02nm 
Hi guys, tried the above but it made the screen very small and in the top left hand side of the screen - I have no idea what I'm doing but willing to experiment. After changing several things I tried fullresolution=1920*1200 on both files mentioned above - now it plays full screen. guess if you change it to your max monitor resolution it'll work...

Hope this helps someone
M'ygnal the Wyrm Blessed 25 mrt 2013 om 8:08nm 
Tried the ddraw solution but I'm still having trouble with the graphics glitching after one minute. Does anyone have any other solutions I might be able to try?
Quick Edit: So far it seems to be happening whenever I'm in the pause menu. I'm running a Windows 7 64 bit laptop if that helps.
Laatst bewerkt door M'ygnal the Wyrm Blessed; 25 mrt 2013 om 11:10nm
HawkeyeWii 4 apr 2013 om 2:56nm 
@hipraskey Same here! Still having the same problems :/
HawkeyeWii 4 apr 2013 om 4:05nm 
I got it now! @Skelosk Thank you sooooo much!!! They should have that as a default when you download the game!
Donny 9 apr 2013 om 3:44nm 
Thanx you so much Man!!!
Soild Sanek 24 jul 2013 om 7:21vm 
Or you could have just use a source port, such as Zandronum. Most source ports also allow for the use of mouse look and other modern features.
Zer0]{elvin 3 aug 2013 om 2:13nm 
Thanks for this thread, was having the pastel color explosion thing too :/
williew7051980 3 aug 2013 om 5:59nm 
Ddraw worked for me! Thank you :-)
HotIce 3 aug 2013 om 7:18nm 
Hey i used the ddraw and it worked but the screen was moved up and i dont know what to do can any one help?
mkdoomfan 3 aug 2013 om 7:25nm 
Thank you! this helped a lot!
Arcade Goon 4 aug 2013 om 1:18vm 
I had better results with the follow settings changed, might help someone.

[sdl]
fullscreen=true
fulldouble=false
fullresolution=desktop
output=opengl

[render]
aspect=true
1-15 van 15 reacties weergegeven
< >
Per pagina: 15 30 50