The Ultimate DOOM > 一般討論 > 主題細節
Cogajon 2013 年 10 月 11 日 @ 下午 1 時 02 分
How to get DOOM to work on Windows 8 without downloading any sourcecodes or mods
So, getting Doom to work on Windows 8 is not a long, nor difficult task. I'd like to point out that I did actually get my help from the internet, but I did have to improvise a bit.
First, go to OS (C:) > Program Files (x86) > Steam > steamapps > common > Ultimate Doom > base
Right-click DOOM and go to 'Properties' then set compatability mode to Windows 95.
Then, go to ultimate.conf and open it with Notepad.
Change 'fullscreen=true' to 'fullscreen=false' and 'waitonerror=true' to 'waitonerror=false'.
After that, go to ultimatem.conf and do the same thing.
Then, open dosbox.conf and scroll down to where it says 'waitonerror=true' and change it to 'waitonerror=false'
Make sure you save these changes and close the files.
Go to your Steam Library and go to The Ultimate DOOM and click 'Play'
If it still doesn't work, like it did for me, go to ultimate.conf and change 'fulldouble=true' to 'fulldouble=false'
Do the same thing for ultimatem.conf.
After this, it should all work.
Hope this helped you! :)

P.S. This will work in any game that uses DOS box such as Doom, Heretic, or Hexen
顯示 1-15,共 36 則回應
< >
Cogajon 2013 年 10 月 15 日 @ 下午 3 時 49 分 
Amvo 發表:
Did you try changing the renderer (that would be the "output", I guess) instead? Maybe to opengl?
Well this works so I didn't have to...
The Gamer Show 2013 年 10 月 18 日 @ 下午 5 時 40 分 
This works good now. Follow the steps all the way to the end. Windows 8.1 X64
pendulousphallus 2013 年 10 月 29 日 @ 下午 11 時 50 分 
Awesome. Thanks. :)
shamus3k 2013 年 10 月 30 日 @ 下午 1 時 51 分 
Great find, doom on my surface pro, loving it!
shamus3k 2013 年 10 月 30 日 @ 下午 2 時 10 分 
works on ultimate doom, doom2 and final doom on my surface pro, cheers cogajon!
Cogajon 2013 年 10 月 30 日 @ 下午 4 時 07 分 
shamus3k 發表:
works on ultimate doom, doom2 and final doom on my surface pro, cheers cogajon!
Yeah, it works on any DOSbox game. I actually posted the same thing on a few different game hubs. I'm glad it worked for you, mate!
FeLex 2013 年 12 月 24 日 @ 下午 9 時 45 分 
many thanks
hjf1 04 月 9 日 @ 下午 9 時 04 分 
Cogajon last two instructions are required for Windows 8.1..

If it still doesn't work, like it did for me, go to ultimate.conf and change 'fulldouble=true' to 'fulldouble=false'
Do the same thing for ultimatem.conf.
After this, it should all work.
Hope this helped you! :)
Cogajon 04 月 9 日 @ 下午 9 時 28 分 
hjf1 發表:
Cogajon last two instructions are required for Windows 8.1..

If it still doesn't work, like it did for me, go to ultimate.conf and change 'fulldouble=true' to 'fulldouble=false'
Do the same thing for ultimatem.conf.
After this, it should all work.
Hope this helped you! :)
They worked fine when I didn't do those and I have Windows 8.1
Lopsided 04 月 12 日 @ 下午 2 時 00 分 
These did the trick for me. Win 8.1 x64

hjf1 發表:
Cogajon last two instructions are required for Windows 8.1..

If it still doesn't work, like it did for me, go to ultimate.conf and change 'fulldouble=true' to 'fulldouble=false'
Do the same thing for ultimatem.conf.
After this, it should all work.
Hope this helped you! :)
Dooki51 04 月 21 日 @ 下午 3 時 50 分 
It works, but the sound and music is messed up.
Can barely hear sound and there's just a weird glitch, help?
Cogajon 04 月 21 日 @ 下午 4 時 03 分 
dooki51 發表:
It works, but the sound and music is messed up.
Can barely hear sound and there's just a weird glitch, help?
Maybe try finding something in the same config document that controls volume. set it to a higher number.
Dooki51 04 月 21 日 @ 下午 4 時 05 分 
Cogajon 發表:
dooki51 發表:
It works, but the sound and music is messed up.
Can barely hear sound and there's just a weird glitch, help?
Maybe try finding something in the same config document that controls volume. set it to a higher number.
I tried changing the volume, still is the same, some sounds play once in a sequence, some sounds don't work at all and most sounds are at a quiet volume. I'm running windows 8.1. This problem never happened on my windows 7 laptop.
Cogajon 04 月 21 日 @ 下午 4 時 06 分 
dooki51 發表:
Cogajon 發表:
Maybe try finding something in the same config document that controls volume. set it to a higher number.
I tried changing the volume, still is the same, some sounds play once in a sequence, some sounds don't work at all and most sounds are at a quiet volume. I'm running windows 8.1. This problem never happened on my windows 7 laptop.
I have no idea. This problem is foreign to me.
Have you tried uninstalling and reinstalling the game?
Princess Goddammit 04 月 30 日 @ 下午 2 時 05 分 
I followed your steps to the letter but it still will not work.
My system:
Win. 8.1 64-bit x64 bit processor.
AMD A10-5750M APU with Radeon Graphics 2.50 GHz
8.00 GB
AMD Radeon HD 8650G
All drivers up to date.
顯示 1-15,共 36 則回應
< >
每頁: 15 30 50