Lurpsukka May 11, 2014 @ 1:16pm
The Ultimate Doom Vista/Win7/Win8 guide
Go to your \Steam\SteamApps\common\Ultimate Doom\base

Find the file ultimatem.conf (or ultimate.conf if you're playing with classic controls)

Open it with a notepad

Under [sdl] change output=source to output=ddraw. You can also try output=opengl if there's some problems with ddraw.

Remember to also set up correct aspect ratio under [render] aspect=true
Showing 1-15 of 26 comments
< >
Dii Infer May 12, 2014 @ 4:25pm 
YES!!! Thank you so much, the graphics were all kinds of messed up until I followed these directions. Much appreciated. :-D
Lurpsukka May 26, 2014 @ 8:12am 
Originally posted by Dii Infer:
YES!!! Thank you so much, the graphics were all kinds of messed up until I followed these directions. Much appreciated. :-D

Glad to be of help. These settings are defaults for other Doom games so this is the only one that needs correction.
jS May 26, 2014 @ 10:24pm 
Droppng by to say it worked for me too. Fixed everything. Thank you.
samurai.jenn Jun 7, 2014 @ 7:00pm 
I did this, but my game just doesn't go past the title screen.
Lurpsukka Jun 7, 2014 @ 11:47pm 
Originally posted by samurai.jenn:
I did this, but my game just doesn't go past the title screen.

Other option is to update Dosbox since Steam uses old version of it. Get it here:

http://www.dosbox.com/download.php?main=1

Install it on \Steam\SteamApps\common\Ultimate Doom\base and overwrite the old Dosbox files.
leperkhaan Jun 10, 2014 @ 8:41pm 
OP = god amongst mortals, thank you. Also, bump
STORMTROOPER_AIM Jun 13, 2014 @ 5:05am 
thx so much !!!!
Bombe_zwanzig Jul 18, 2014 @ 3:39pm 
excellent. hat tip to you, good sir, works like a charm.
LemonKing Jul 18, 2014 @ 6:54pm 
Thanks alot, man!
Not a Psychopath Jul 18, 2014 @ 11:20pm 
Originally posted by Lurpsukka:
Originally posted by samurai.jenn:
I did this, but my game just doesn't go past the title screen.

Other option is to update Dosbox since Steam uses old version of it. Get it here:

http://www.dosbox.com/download.php?main=1

Install it on \Steam\SteamApps\common\Ultimate Doom\base and overwrite the old Dosbox files.

I've tried this but I'm still stuck on the title screen (I'm running windows 8 parallels on a mac if that changes anything). Is there an alternate solution or a way to play the game on a Dosbox emulator on OSX?
Wrecker183 Jul 18, 2014 @ 11:48pm 
I was getting really frustrated until I saw this post -- This helped me get the game running perfectly. Lurpsukka, this information is much appreciated and thank you for sharing!
sixxwings Jul 19, 2014 @ 1:46am 
I did what you said. The game runs now, but I have no keyboard controls. I launch using the classic control option, and it does the same thing when I startup with the modern controls option. The only key on my keyboard that works is F12, and it takes a screenshot. I have to Alt + Tab to exit and close the game window.
In game my mouse will awkwardly move the skull cursor through the options to start a game. When the game starts I have to push my mouse forward over and over to move forward, and the left mouse button shoots. That is all the control I have while trying to play.
I am using Windows 8.1
Anyone know what is happening?
Lurpsukka Jul 19, 2014 @ 3:22am 
Originally posted by austinjohnray:
Originally posted by Lurpsukka:

Other option is to update Dosbox since Steam uses old version of it. Get it here:

http://www.dosbox.com/download.php?main=1

Install it on \Steam\SteamApps\common\Ultimate Doom\base and overwrite the old Dosbox files.

I've tried this but I'm still stuck on the title screen (I'm running windows 8 parallels on a mac if that changes anything). Is there an alternate solution or a way to play the game on a Dosbox emulator on OSX?

I'm not sure about OSX but have you tried changing fulldouble=true to fulldouble=false?

Some people have The Ultimate Doom launch problems on Windows 8 and that has worked for them. It disables double buffering while in full screen mode.


Originally posted by sixxwings:
I did what you said. The game runs now, but I have no keyboard controls. I launch using the classic control option, and it does the same thing when I startup with the modern controls option. The only key on my keyboard that works is F12, and it takes a screenshot. I have to Alt + Tab to exit and close the game window.
In game my mouse will awkwardly move the skull cursor through the options to start a game. When the game starts I have to push my mouse forward over and over to move forward, and the left mouse button shoots. That is all the control I have while trying to play.
I am using Windows 8.1
Anyone know what is happening?

That sounds weird, are you using ddraw mode? Because the F12 Steam screenshot key should only work in opengl mode. I have no idea about keyboard functionality but have you tried to change

keyboardlayout=none to keyboardlayout=us

It's found on the bottom of the config file under [serial]. It changes the keyboard layout to your country specification. That is the only solution I can think of right now apart from updating your DosBox to the newest version 0.74 (http://www.dosbox.com/download.php?main=1) and overwriting the old files in steamapps\common\Ultimate Doom\base
Last edited by Lurpsukka; Jul 19, 2014 @ 3:38am
sixxwings Jul 19, 2014 @ 1:32pm 
Thanks for your reply. When I used the ddraw mode, the game would freeze on the title screen. I then used the opengl mode, and I experienced what I mentioned before. I tried the keyboardlayout=us and keyboard response has not changed. I updated DosBox and still no change.
HuggyBear Jul 19, 2014 @ 2:46pm 
Originally posted by sixxwings:
Thanks for your reply. When I used the ddraw mode, the game would freeze on the title screen. I then used the opengl mode, and I experienced what I mentioned before. I tried the keyboardlayout=us and keyboard response has not changed. I updated DosBox and still no change.
I was in the same boat as you but got mine to work. Did you change [render] aspect=false to aspect=true? I did this, updated DosBox, and used [sdl] output=opengl, and now mine works perfectly.
Showing 1-15 of 26 comments
< >
Per page: 15 30 50