Retrovirus > General Discussions > Topic Details
JinkinsJinkies Jun 25, 2013 @ 3:16pm
Whats with the painfully low framerate?
I can run sleeping dogs with great smooth fps, same with crysis (on medium/low settings) and this game only gets 8 fps (16 with vsync) its flipping unplayable. I dont have the most powerful pc but I know I should be able to run this. I think its poorly optimized and I just speant $20 on a game I cant play.
I know theres no way I will get a refund but that wont stop me from complaining. Im really angry about this
Showing 1-15 of 53 comments
< >
ColdEquation  [developer] Jun 25, 2013 @ 7:14pm 
What hardware are you running specifically? We are working to optimize the engine, and have some large architectural changes to make to target more platforms. It helps to know what machines to target with future updates.
JinkinsJinkies Jun 25, 2013 @ 11:34pm 
my video card is AMD Radeon HD 6620G with 5 gigs of RAM
Its good to know that youre optimizing the engine i'll keep in touch with the website for updates. I just hope it happens somewhat soon
Neo Jun 26, 2013 @ 9:34am 
honestly, i've seen gameplay and it probably needs so much data that it lags up. the guy in the trailer probably has a supercomputer so he can play.
Last edited by Neo; Jun 26, 2013 @ 9:35am
Megabyte [RSSD] Jun 29, 2013 @ 8:56am 
I have to agree with this issue... not seeing it so badly as others, but I just got through the trains in the recollection center... 20FPS reported at times and I suspect lower during combat in the room with 2 trains. Here are my specs:

CPU: AMD Phenom II 6X 1100T. 3.3ghz
RAM: 4GB
Video card: Geforce 460GTX with 1GB VRAM

If that helps, glad to help. Loving this game so far, but if there is any one big thing that could help make it better, that is it.

(Keep in mind, this is the ONLY level Ive seen anything like this... so you might want to look at how your heat effect works since that's the only thing new... at least that I am aware of)
Last edited by Megabyte [RSSD]; Jun 29, 2013 @ 8:58am
JinkinsJinkies Jun 29, 2013 @ 9:28am 
Originally posted by Megabyte RSSD:
I have to agree with this issue... not seeing it so badly as others, but I just got through the trains in the recollection center... 20FPS reported at times and I suspect lower during combat in the room with 2 trains. Here are my specs:

CPU: AMD Phenom II 6X 1100T. 3.3ghz
RAM: 4GB
Video card: Geforce 460GTX with 1GB VRAM

If that helps, glad to help. Loving this game so far, but if there is any one big thing that could help make it better, that is it.

(Keep in mind, this is the ONLY level Ive seen anything like this... so you might want to look at how your heat effect works since that's the only thing new... at least that I am aware of)
Glad to know its not just me, but at least (for me anyways) 20 fps is playable to a degree. But 9 fps!? I cant even PLAY the game! Now im just mad because I could have bought endless space instead. Its a shame because I was really looking forward to this game
Megabyte [RSSD] Jun 29, 2013 @ 12:35pm 
well, its mainly been that level... but I really do suspect the issue is with how the engine handles effects like that. Most of the game Ive been hitting 50-60... but that level... yeah... I think the effects to say "going here will melt you" are doing a number.
Migz - DH Jul 9, 2013 @ 2:53am 
Originally posted by Megabyte RSSD:
well, its mainly been that level... but I really do suspect the issue is with how the engine handles effects like that. Most of the game Ive been hitting 50-60... but that level... yeah... I think the effects to say "going here will melt you" are doing a number.

I checked out that section with the trains. According to the FPS meter on the options screen, I was getting between 78-92 FPS the entire way.

It felt very smooth for me.

My GPU1 was running at 99% usage nearly the entire time according to EVGA's Precision X.

Graphics settings:
Sampling: 100%
VSync: Off
FXAA: On
Lighting Detail: High

System Info
OS - Windows 7 Home Premium (x64), SP1
Processor - Intel i7-2600K OC @ 4.6GHz
RAM - 4GB G-Skill @2133MHz (F3-17000CL7-2GBXHD)
Motherboard - ASUS P8P67 WS REVOLUTION Rev 1.xx
BIOS - 08.00.10, Feb 2010
GPU - NVIDIA Geforce GTX 570 (EVGA) OC @ 797 MHz Core Clock, 1950 MHz Memory Clock, 1.013V
Video Driver - 314.22 - WHQL
System Drive - Samsung 830 SSD, 256GB, F/W CXM03B1Q
Sound Card - Creative Sound Blaster X-Fi Titanium
Sound Driver - 2.17.0008, July 2010
Monitor - Samsung S27B550V @ 1920x1080
OlivierJT Jul 16, 2013 @ 10:34am 
To add it here too :
14 FPS on a GTX 690 (it's a one card SLI of 680 downcloked)
VSynch OFF, FXAA ON
1280x800
Using Oculus Rift.
Hadley Jul 20, 2013 @ 6:40pm 
Framerate issues... how unfortunate. One of the biggest red flags for a PC gamer. The only way I'd buy something with known framerate issues is after trying a demo.
Rambowjo Aug 15, 2013 @ 6:40am 
I actually bought this game, just so I could try it out in the Rift. On my old computer, I could barely run it, hitting around 5-10 FPS in the starting area and menu. I got a new PC today, with a 770 GTX, 8GB DDR3 RAM, 3.2GHz quad core, and now I'm getting a staggering... 20 FPS.

Please fix this. It is completely unacceptable, and won't be playable with the Rift in the next decade.

edit: ok, I tried downgrading my graphics driver to stable build, this helped a lot, trippling my FPS for the most part. It still drops quite often though, especially whenever shots are fired and stuff explodes, which is all the time. I think a wider graphics options menu would help a lot, like limiting particle usage and so on.
Last edited by Rambowjo; Aug 15, 2013 @ 9:44am
Hyper Mairo Aug 22, 2013 @ 10:52am 
I was thinking with those graphics ~100fps was low as source engine games with better graphics run couple thousand fps.
Last edited by Hyper Mairo; Aug 22, 2013 @ 10:52am
JinkinsJinkies Aug 22, 2013 @ 11:50am 
Seems like you have a god like machine lol
SargeSmash Aug 23, 2013 @ 1:08pm 
Mine isn't great, either. Now, I don't have the fastest thing around anymore, but it's not shabby, a M11x, with a i7 @ 1.2 GHz (but runs up to 1.8 GHz), and a Geforce 335M. I get single digits at the default, and I get mostly playable if I turn the lighting to low, FXAA and V-Sync off, and only 25% rendering, running at a resolution of 1366x768.

Any ideas?
JinkinsJinkies Aug 23, 2013 @ 1:22pm 
If I had any I would have been playing it. Its been over a month since I made this and still no optimization updates... im begining to wonder why they even released the game if it wasnt ready
Sgt.Psycho Aug 24, 2013 @ 8:23pm 
I have to admit, I was shocked. Yes, my computer's pretty crappy*, but still, 6fps in native res, default settings? In the video config screen? Not even anywhere close to playable. I can get 200+fps in TF2, so my system's not that bad.

By screwing it down to 1024 res (not even right ratio), 25% scaling, low light effects, I can scrape up 30fps, but it plays in Duplo mode which isn't much fun.

It's a great game, i just wish I could play it properly.

* 2.6GHz dual, 6Gb ram, GF9500GT, Win7.
Showing 1-15 of 53 comments
< >
Per page: 15 30 50