Dragon's Lair > Algemene discussies > Details van topic
rongilbert2 6 jan om 5:44vm
Windows Media Player solves most problems
I have Windows XP SP3 and the game refused to start at beginning, so i downloaded latest version of Windows Media Player for my OS that is WMP 11 and the game started without any problems, i shared my experience hoping to help someone, enjoy Dragon's Lair
Laatst bewerkt door rongilbert2; 6 jan om 5:51vm
1-14 van 14 reacties weergegeven
< >
MangAnimE [H ★ S] 18 jan om 7:05nm 
Didn't solve mine in WinXP nor Win7, game still broken in both OSes
Laatst bewerkt door MangAnimE [H ★ S]; 18 jan om 7:06nm
-=NAM=-Blade 12 apr om 3:07nm 
I have wmp/12 and my game won't even run.. wtf..... steam ripping people off.
NoctemLupis 9 mei om 8:56vm 
No not Steam....the company that released the game. I have tried to work with them,and sent my machines specs. Almost one year and they have not fixed the issue.
NoctemLupis 11 mei om 2:41nm 
Well got the game to load. Bad news is that i'm stuck on a black screen after it shows the company logo and the Dragon's Lair LLC.
-=NAM=-Blade 11 mei om 3:32nm 
to get this game to work are you talking about the k-lite mega codec pack for video players?
-=NAM=-Blade 11 mei om 3:42nm 
Thanks for your help.
NoctemLupis 11 mei om 5:19nm 
Using Windows 7 Ultimate 64bit. Downloaded the codec as you recommended. It will load,but no sound/black screen.
-=NAM=-Blade 11 mei om 9:54nm 
have windows 7 home premium and will not load period... from the library it will not change. to the game. Game stay's in the library. still working on it.
NoctemLupis 12 mei om 11:13nm 
Well i'm able to get menus by hitting escape,but no sound and black screen.even tried configuring the codecs.Really struggling on this.
rosarioluigi 25 mei om 4:36nm 
Origineel geplaatst door NoctemLupis:
Well i'm able to get menus by hitting escape,but no sound and black screen.even tried configuring the codecs.Really struggling on this.

A little late but did you try...

Control Panel ---> Programs and Features --> View Installed Updates --> (under header Microsoft Windows) Uninstall KB2803821

That worked for my black screen problem but your comp will redownload that update eventually so you will probably have to uninstall it before you play the game each time.
NoctemLupis 27 mei om 11:46vm 
Thanks rosarioluigi,I did find the update and deleted it. However same issue. It just stays at the Dragon's Lair LLC screen but will not load the game. I'll keep trying other things. Let me know if there is anything else. Again thank you.
rosarioluigi 27 mei om 11:56vm 
Hmmm okay, I gave you the fix for the wrong thing it seems. I thought you meant top half only was black.

Okay, did some searching around but it seems that others who had a full black screen solved it by deleting all 3rd party codecs on their PCs which seems to be what has already been discussed.

There really isn't any new info but here is the link anyway.
http://steamcommunity.com/app/227380/discussions/0/648811852445495967/#p2

Hope you eventually get it running... these old games are fun for nostalgia but sometimes the effort it takes to get them to run can be a little much.

Laatst bewerkt door rosarioluigi; 27 mei om 11:57vm
NoctemLupis 28 mei om 10:15vm 
Yeah I agree. I have already deleted the codecs and installed the other ones that was suggested. Hopefully this will get figured out. Till then researching it is the best thing. Again thanks for the help.
NoctemLupis 2 sep om 8:40vm 
Just built a new computer and tried playing Dragon's Lair. It is working now. This is probably due to a fresh install of Windows,and no codec packs. I think it has to do with the 3rd party codecs. Again it's just my opinion. Try to uninstall 3rd party codecs and see what happens.
1-14 van 14 reacties weergegeven
< >
Per pagina: 15 30 50