Dragon's Lair

Dragon's Lair

View Stats:
Ron Jan 6, 2014 @ 5:44am
Windows Media Player solves most problems
I have Windows XP SP3 and the game refused to start at beginning, so i downloaded latest version of Windows Media Player for my OS that is WMP 11 and the game started without any problems, i shared my experience hoping to help someone, enjoy Dragon's Lair
Last edited by Ron; Jan 6, 2014 @ 5:51am
< >
Showing 1-14 of 14 comments
Didn't solve mine in WinXP nor Win7, game still broken in both OSes
Last edited by MangAnimE [H ★ S]; Jan 18, 2014 @ 7:06pm
-=NAM=-Blade Apr 12, 2014 @ 3:07pm 
I have wmp/12 and my game won't even run.. wtf..... steam ripping people off.
NoctemLupis May 9, 2014 @ 8:56am 
No not Steam....the company that released the game. I have tried to work with them,and sent my machines specs. Almost one year and they have not fixed the issue.
NoctemLupis May 11, 2014 @ 2:41pm 
Well got the game to load. Bad news is that i'm stuck on a black screen after it shows the company logo and the Dragon's Lair LLC.
-=NAM=-Blade May 11, 2014 @ 3:32pm 
to get this game to work are you talking about the k-lite mega codec pack for video players?
-=NAM=-Blade May 11, 2014 @ 3:42pm 
Thanks for your help.
NoctemLupis May 11, 2014 @ 5:19pm 
Using Windows 7 Ultimate 64bit. Downloaded the codec as you recommended. It will load,but no sound/black screen.
-=NAM=-Blade May 11, 2014 @ 9:54pm 
have windows 7 home premium and will not load period... from the library it will not change. to the game. Game stay's in the library. still working on it.
NoctemLupis May 12, 2014 @ 11:13pm 
Well i'm able to get menus by hitting escape,but no sound and black screen.even tried configuring the codecs.Really struggling on this.
RosarioLuigi May 25, 2014 @ 4:36pm 
Originally posted by NoctemLupis:
Well i'm able to get menus by hitting escape,but no sound and black screen.even tried configuring the codecs.Really struggling on this.

A little late but did you try...

Control Panel ---> Programs and Features --> View Installed Updates --> (under header Microsoft Windows) Uninstall KB2803821

That worked for my black screen problem but your comp will redownload that update eventually so you will probably have to uninstall it before you play the game each time.
NoctemLupis May 27, 2014 @ 11:46am 
Thanks rosarioluigi,I did find the update and deleted it. However same issue. It just stays at the Dragon's Lair LLC screen but will not load the game. I'll keep trying other things. Let me know if there is anything else. Again thank you.
RosarioLuigi May 27, 2014 @ 11:56am 
Hmmm okay, I gave you the fix for the wrong thing it seems. I thought you meant top half only was black.

Okay, did some searching around but it seems that others who had a full black screen solved it by deleting all 3rd party codecs on their PCs which seems to be what has already been discussed.

There really isn't any new info but here is the link anyway.

Hope you eventually get it running... these old games are fun for nostalgia but sometimes the effort it takes to get them to run can be a little much.

Last edited by RosarioLuigi; May 27, 2014 @ 11:57am
NoctemLupis May 28, 2014 @ 10:15am 
Yeah I agree. I have already deleted the codecs and installed the other ones that was suggested. Hopefully this will get figured out. Till then researching it is the best thing. Again thanks for the help.
NoctemLupis Sep 2, 2014 @ 8:40am 
Just built a new computer and tried playing Dragon's Lair. It is working now. This is probably due to a fresh install of Windows,and no codec packs. I think it has to do with the 3rd party codecs. Again it's just my opinion. Try to uninstall 3rd party codecs and see what happens.
< >
Showing 1-14 of 14 comments
Per page: 15 30 50