TheBoone710 Feb 27 @ 6:18pm
Genius TwinWheel F1
I just received a Genius TwinWheel F1 as a gift. I was so excited to finally play ETS with a wheel and pedals. Everything works fine, except I cannot get the brakes to work. I went through the input wizard, and it assigned braking axis as the y axis, centered. So when I drive, when I press the gas slightly I will accelerate, but when I hit half way on the pedal, it applies the brakes.

If I click the setting to try to change it, it does not respond to me hitting the brake pedal. When I calibrate it in windows, everything works fine but again no response from the brake pedal.

Is this a faulty controller? Or am I just missing something?
Showing 1-4 of 4 comments
< >
zbobg Feb 27 @ 8:55pm 
You are missing something.

Brake and Accelerator pedals are typically either on the same axis (combined) or on a separate axis.

From what you have posted, a centered axis would indicate a combined axis. This is not the best setup. Try to setup the brake and accelerator as a separate axis. You do not want to see "centered".

There is a Windows driver for that wheel. In that driver you should be able to set the axis as separate or combined. Separate is better. In ETS2 separate or combined can be made to work properly.

Even if you don't use the official driver, the Windows Control Panel app for controllers should be able to configure the axis as separate or combined.

Regardless of all that I've written here, if you can only setup the controls as a combined axis then that will work just fine in ETS2.
fr8train28 Feb 28 @ 10:07am 
You have the accelerator and the brakes on the same axis…you will need to simply change that or do what zbobg said
rubble duck Feb 28 @ 11:28am 
listen to "zbobg" he knows whats he is talking about. trist me he been helpping me making a mod for the game
Tmillz Mar 7 @ 7:11pm 
I have been having trouble getting the force feedback to work with this specific controller. The rumbling works, but it doesn't seem to be adjustable... I have tried changing the force feedback settings in-game, but it doesn't seem to work. anyone have any ideas?
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Feb 27 @ 6:18pm
Posts: 4