zealousyouth Jun 5, 2013 @ 9:07pm
steam will not size properly to monitors
I'm very very happy with Display Fusion so far! One small bug seems to be that although most windows (chrome, windows, origin, firefox, etc etc) snap correctly to the size of the monitor's resolution of whatever screen you drag it to (whether that particular monitor is portrait or landscape, at whatever resolution etc), steam will only maximize correctly on my default display. When I try to maximize the Steam window on any of the other 3 displays I'm running it will not maximize to that screen. It seems to justify to the top left corner and display in the same resolution as the setting for my primary monitor. This will cause Steam to be partially displayed on two monitors if I try it on a portrait monitor, or in the case of a higher resolution but also landscape monitor, Steam will be in a window smaller than the screen. I hope that makes sense, for any clarification please ask!

I contacted the good folks over at display fusion to report this bug, and they commented that the bug is an issue with steam's programming, not display fusion, and they assured me that they have reported the issue to Valve. I just wanted to make sure that the good folks at Valve do indeed know of this bug/problem. Since Display Fusion is being sold on Steam, it would really be nice if Steam functioned correctly with Display Fusion! Can we put somebody on fixing this?!?!? Pretty Please!??!!

Thanks for the help!
Showing 1-3 of 3 comments
< >
.dR. Cobalt503 Jun 6, 2013 @ 5:39am 
Bump.. as I have this issue as well.. However IDK if this will get to valve, as it's a forum for display fusion..
Keith Lammers (Binary Fortress)  [developer] Jun 6, 2013 @ 8:12am 
It's definitely an issue with the Steam client, as I'm able to reproduce it here, even when DisplayFusion isn't running and I just have the Windows taskbar on the non-primary monitor :)

I had indeed reported it to Valve customer support, and received a confirmation yesterday that they're investigating the issue. If I hear any more news, I'll definitely post an update here.

Thanks guys!
[UBER] TheLordOfEvil Jun 30, 2013 @ 2:53pm 
One way I've found to make Steam go into fullscreen on the other monitor with the taskbar enabled is to:

1) Turn off the taskbar on DisplayFusion.
2) Maximize Steam on the second monitor.
3) Turn the taskbars back on on DisplayFusion.

This should resize Steam to be the correct size and maximized on the second monitor just like it would be on the primary. I'm not sure if this will handle a restart since I just stumbled across it right now but at the very least it could be used as a hotfix if you really needed to.
Showing 1-3 of 3 comments
< >
Per page: 15 30 50