Ears14U ™ Jan 31 @ 7:48am
Game "Freezes" many times while playing
From my own personal experience this game on my first install and play would freeze (like it was a coded processor problem). Only when I deleted the install, and re-downloaded and reinstalled it? It seems to have cleared it up completely. I posted this for everyone's information. You can get a bad download on any Steam game, so keep this in mind on any of your purchased games.
Showing 1-10 of 10 comments
< >
Duomtl Jan 31 @ 9:24am 
Interesting, glad the reinstall fixed the issue, kinda weird that it happened like that in the first place.
kingj0n Feb 27 @ 4:08am 
Prolly what I have to do.
I don't have music and there's no sound on the intro video. And it freezes every few seconds and it takes forever to load.
Ears14U ™ Feb 27 @ 6:27am 
Originally posted by kingj0n:
Prolly what I have to do.
I don't have music and there's no sound on the intro video. And it freezes every few seconds and it takes forever to load.
It's worth the redownload, reinstall. Most likely it will repair your problems.
Castor Mar 9 @ 7:13pm 
Originally posted by kingj0n:
Prolly what I have to do.
I don't have music and there's no sound on the intro video. And it freezes every few seconds and it takes forever to load.

I'm facing the same problem here. I have redownloaded and reinstalled the game many times. The problem is still there. I backed up the file I downloaded and installed it in another computer and it worked perfectly. So the problem is not on the downloaded file.
Ears14U ™ Mar 9 @ 7:18pm 
Originally posted by Castor:
Originally posted by kingj0n:
Prolly what I have to do.
I don't have music and there's no sound on the intro video. And it freezes every few seconds and it takes forever to load.

I'm facing the same problem here. I have redownloaded and reinstalled the game many times. The problem is still there. I backed up the file I downloaded and installed it in another computer and it worked perfectly. So the problem is not on the downloaded file.
Have you checked your "video driver updates" via STEAM in the very upper left corner of your steam browser? Whoops, sorry I didn't check your level 18 standing.
Last edited by Ears14U ™; Mar 9 @ 7:20pm
Castor Mar 10 @ 4:38pm 
I've updated the video drivers today. Didn't work. Thanks anyway!
kingj0n Mar 13 @ 12:03am 
Originally posted by Castor:
Originally posted by kingj0n:
Prolly what I have to do.
I don't have music and there's no sound on the intro video. And it freezes every few seconds and it takes forever to load.

I'm facing the same problem here. I have redownloaded and reinstalled the game many times. The problem is still there. I backed up the file I downloaded and installed it in another computer and it worked perfectly. So the problem is not on the downloaded file.

My issue was my sound card, disabling the GX mode on my Xonar card fixed all that.
Apparently, GX is the EAXlike thing like Creative have.
Duomtl Mar 13 @ 10:45am 
So then you had the BSOD no?
Castor Mar 13 @ 2:33pm 
Yeah it worked!! I have no idea how you guys discovered that... I have an Asus Xonar sound card. When I disabled "GX" everything worked fine. Thank you sooo much. Now I will enjoy the game!
kingj0n Mar 13 @ 5:47pm 
Originally posted by Castor:
Yeah it worked!! I have no idea how you guys discovered that... I have an Asus Xonar sound card. When I disabled "GX" everything worked fine. Thank you sooo much. Now I will enjoy the game!

Great, the Dev helped me with this issue. Glad I was able to help you with it too. :)
Showing 1-10 of 10 comments
< >
Per page: 15 30 50