Kinetic Void > General Discussions > Topic Details
Caducus_Ater Aug 26, 2013 @ 1:42pm
Great Shipbuilder, But A Few Things Bugging Me
http://steamcommunity.com/sharedfiles/filedetails/?id=173128493

I had a lot of fun building my first dreadnaut, shown in the above link. Not quite how I'd like it to look, but I grant this game is still in alpha. However, after messing around in space for a bit, there were a few things that bugged me:

Shipbuilding:

1. If you look at the screenshot carefully, you'll notice that the diagonal wings (both upward and downward) on the left are angled differently than those on the right. I could not get them to have the same angle while building, no matter what I did - freefrom, node align, rotations, nothing seemed to fix it. I don't know for sure what was the culprit, but I suspect it involved Hull 10V5, Hull 10 or both of them.

2. A few of the modules (This only seemed to involve Hull 10V5) had a slightly different color scheme than the majority of the other, identical type modules, i.e. having purple where there was normally teal. Which modules were non-conforming, however, changed each time I loaded my ship, but they always seemed to be modules (Hull 10V5) that were toward the rear of the ship.

Space:

1. Not sure what caused this exactly, but while fighting two carbon copies of my 42 million durability dreadnaut, I warped away to avoid fighting a long, losing battle, upon which I noticed, a few minutes later, that the WASD pitch controls had become reversed from the norm, forward thrusters no longer displayed their trails (only doing so when going in reverse), my kinetic field accelerated me considerably slower than usual, and I could not catch up with anything anymore. Granted I did take damage in the aforementioned fight (got down to 91%), but I don't think it should be causing that....

2. Somewhat related to a problem in my 1st space issue, but on occasion, it seemed like using my kinetic field caused things to move away from me; that or they were very good at running away and avoiding me, whether I was attacking them or not. This made destroying the 3 ships in the random distress quest very difficult, if not impossible. I'd manage to destroy the 1st ship that, for some reason, had started with 2% durability, but the 2nd ship I attacked, which also had 2% durability, I could only get down to 1% before it just became impossible to reach, much less hit.

This is a cool game and I'd love to see it grow into something really awesome. Hopefully some of this stuff is addressed eventually!
Last edited by Caducus_Ater; Aug 26, 2013 @ 1:46pm
Showing 1-5 of 5 comments
< >
Shagohod Rv~ Aug 26, 2013 @ 2:07pm 
Shipbuilder:
Both issues are known and reported, and will probably be adressed in the near future. It's sit and wait for now.

Space:
1. The WASD confusion is also known, at least in the forums. I haven't seen the devs answer to it, but I am pretty sure they are aware of it, as LumberingTroll (a Dev) is quite active here.

As for the slower movement: Yes, that could've been caused by the damage you took. Maybe a few shots hit your engine, disabling one or more of them, causing you to be slow. Super slow.
Imagine all of the shots hit your engines (damage is currently randomly distributed across your ship, making that pretty unlikely to happen) and you said you sustained 9% overall damage. That's more than enough to take all your engines out.

2. The 2% bug is also known (Yay, all known! :D).
The ship has probably been faster than you because you destroyed its engines, although that may sound confusing.
Let me explain: Since its engines stopped working it cannot maneuver anymore, cannot accelarate, cannont deccelarate. Your shots do have their own mass, causing the enemy ship upon hit to gain speed in the opposite direction. Test it yourself: let a friend run into you ;).
That ship is unable to counteract to this force, due to you shooting its engines. With every hit received it gains speed - in an angle that is facing away from you, as you are pushing it.

Hope that explains it!
Last edited by Shagohod Rv~; Aug 26, 2013 @ 2:09pm
LumberingTroll  [developer] Aug 26, 2013 @ 2:51pm 
I do infact read every post, even if I dont reply all the time. We have been gearing up for a largeish patch to come out some time next week. Pretty busy over here :D

The control versal thing is fixed, as is a bunch of other stuff that has been mentioned on these here forums.
Last edited by LumberingTroll; Aug 26, 2013 @ 2:52pm
Caducus_Ater Aug 26, 2013 @ 3:51pm 
That's great to hear! Hope the patch works as intended!

@Shagohod Rv~ Dang...I didn't think of that momentum transfer...that's pretty neat...even if it does make destroying ships trickier, lol. I'm not sure if it explained everything I saw happen, but it does help me think things through better. Thanks!
Shagohod Rv~ Aug 29, 2013 @ 2:11pm 
Glad I could help! :) If you got anymore question let me know, I'll try to answer them as detailed as I'm able to!

I do infact read every post, even if I dont reply all the time.

I thought so and I really appreciate your activity. That is, by far, not self-evident! Keep up the good work!
Last edited by Shagohod Rv~; Aug 29, 2013 @ 2:13pm
lordchip32 Aug 29, 2013 @ 9:36pm 
I wonder if it is even possible to use all the hulls on one ship, haven't researched this at all but if one could it would seem as big as a planet.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Aug 26, 2013 @ 1:42pm
Posts: 5