Kinetic Void > General Discussions > Topic Details
Kahuna Kevin Jul 19, 2013 @ 1:42am
Startup bug on Mac still exists after months.
Can't even play the game. I launch the game, the screen is completely black and I hear music. Other than that, I can't do anything. On one of the initial betas I was able to change the screen resolution/graphic options and ever since then it's been behaving like this. PLEASE FIX THIS OR REFUND MY KICKSTARTER MONEY. If it's because the settings aren't fully implemented then you need to implement basic code that checks and makes sure the screen res/quality is set back to DEFAULT every time it's launched. Right now I'm out $10 staring at a black screen, not happy and my posts about this issue on Kickstarter and personal messages have gone unanswered since then.
Last edited by Kahuna Kevin; Jul 19, 2013 @ 1:44am
Showing 1-15 of 15 comments
< >
kwils2 Jul 19, 2013 @ 7:01am 
have you tried re downloading it?
kwils2 Jul 19, 2013 @ 7:03am 
its also posssible that you dont have something that this game needs to work maybe your missing a program, it also could be your mac having some sort of problem on it,or maybe the mac is recongnizing it as some sort of virus and wont load it, all of these are possiblities
kwils2 Jul 19, 2013 @ 7:04am 
either way i only think re downloading it will help other than that i dont know
Dakili Jul 19, 2013 @ 1:40pm 
Try to play the game in windowed mode.
Kahuna Kevin Jul 22, 2013 @ 3:05pm 
I've downloaded, re-installed, uninstalled multiple times with each successive version. It was working until I made changes to the screen settings in the first Mac version, that's the whole problem, and that's where the devs need to look to resolve the issue. It's a simple matter of temporarily coding the next builds to force the program back to the default resolution and quality settings when starting. They stated later the screen options/quality weren't implemented, however in my early Mac build they were available (and ZERO warning about using them), and it jacked up the game and every build after.

I can't change to windowed mode because as soon as the game launches the menu is hidden and screen is pitch black, then ever-spinning beachball of death appears. I can't even force quit/reload the Desktop, the CPU is so inundated it has to be forced into a hard shut down.
Last edited by Kahuna Kevin; Jul 22, 2013 @ 3:07pm
Niernen Jul 23, 2013 @ 3:27am 
It works fine for me on my Mac. No launching issues, no performance issues that wouldn't be expect in an Alpha version.

Posting your system specs and other hardware/technical info helps a lot, instead of just ranting and demanding a fix asap or a refund. Help the devs so they can help you.
Dakili Jul 23, 2013 @ 4:15am 
Originally posted by Kahuna Kevin:
I've downloaded, re-installed, uninstalled multiple times with each successive version. It was working until I made changes to the screen settings in the first Mac version, that's the whole problem, and that's where the devs need to look to resolve the issue. It's a simple matter of temporarily coding the next builds to force the program back to the default resolution and quality settings when starting. They stated later the screen options/quality weren't implemented, however in my early Mac build they were available (and ZERO warning about using them), and it jacked up the game and every build after.

I can't change to windowed mode because as soon as the game launches the menu is hidden and screen is pitch black, then ever-spinning beachball of death appears. I can't even force quit/reload the Desktop, the CPU is so inundated it has to be forced into a hard shut down.


Here's what the old fix for that issue.

Reinstalling wont change. you have to go in the registry of the game to change it manually.

Run regedit.exe
Find
HKEY_CURRENT_USER\Software\Badland Studio LLC\Kinetic Void
set
Screenmanager Is Fullscreen mode_h3981298716
to 1
set
Windowed_h356684552
to 0
exit regedit this will run the game in full screen at 0x0 to which you can go to options in game to change it (might have to use the arrow keys to set other higher resolutions) and click apply.
Sozen the Crazy Cat Man Aug 16 @ 12:04pm 
Im having the same problem however It never worked to begin with._
CoreyTisdale Aug 16 @ 1:19pm 
I am also having the same problem. The advice about using regeit doesn't help with this issue, since the thread is specifically about the mac version.

There is a display.cfg file in the Kinetic Void install folder. Changing the resolution in this file and setting fullscreen to false makes no impact on the black screen problem, nor does it make the program launch in windowed mode.

Please give any feedback about how to make the mac version launch in windowed mode or how to solve the black screen problem!
CoreyTisdale Aug 16 @ 1:23pm 
Hmm. I just deleted the install including the display.cfg file. Then I reinstalled. Then I edited the display.cfg and set the resolution to my monitor native resolution (1440 x 900) and set anti-aliasing to 0.

Launched program, worked fine.

I suspect the antialiasing has a bug with some video cards and this is the issue.
Tribbz Aug 16 @ 4:32pm 
Originally posted by Dakili:
Originally posted by Kahuna Kevin:
I've downloaded, re-installed, uninstalled multiple times with each successive version. It was working until I made changes to the screen settings in the first Mac version, that's the whole problem, and that's where the devs need to look to resolve the issue. It's a simple matter of temporarily coding the next builds to force the program back to the default resolution and quality settings when starting. They stated later the screen options/quality weren't implemented, however in my early Mac build they were available (and ZERO warning about using them), and it jacked up the game and every build after.

I can't change to windowed mode because as soon as the game launches the menu is hidden and screen is pitch black, then ever-spinning beachball of death appears. I can't even force quit/reload the Desktop, the CPU is so inundated it has to be forced into a hard shut down.


Here's what the old fix for that issue.

Reinstalling wont change. you have to go in the registry of the game to change it manually.

Run regedit.exe
Find
HKEY_CURRENT_USER\Software\Badland Studio LLC\Kinetic Void
set
Screenmanager Is Fullscreen mode_h3981298716
to 1
set
Windowed_h356684552
to 0
exit regedit this will run the game in full screen at 0x0 to which you can go to options in game to change it (might have to use the arrow keys to set other higher resolutions) and click apply.

Are you ♥♥♥♥♥♥♥♥? Do you really think a Mac has regedit.exe?
Purple_Pyro Aug 16 @ 5:23pm 
Originally posted by CoreyTisdale:
Hmm. I just deleted the install including the display.cfg file. Then I reinstalled. Then I edited the display.cfg and set the resolution to my monitor native resolution (1440 x 900) and set anti-aliasing to 0.

Launched program, worked fine.

I suspect the antialiasing has a bug with some video cards and this is the issue.
This worked for me too...
superspygg Aug 22 @ 1:01pm 
What program did you use to open the display.cfg? I am using "The Unarchiver" and it cannot open the file.
EDIT: I opened it using textedit
Last edited by superspygg; Aug 22 @ 1:41pm
superspygg Aug 22 @ 5:46pm 
After changing the values listed, the game still did not work. Any suggestions?
CoreyTisdale Aug 23 @ 9:47am 
I don't know. I suspect maybe there is more than one display issue, and mine was related to antialiasing. I don't really know anythinga bout the game engine, so I only figured out that first fix by screwing around with things. Good luck!
Showing 1-15 of 15 comments
< >
Per page: 15 30 50