Kinetic Void > General Discussions > Topic Details
DryEagle Jul 13, 2013 @ 5:50pm
This game almost gave my PC a heart attack
Just bought the game and decided to try and build a ship.
However, even on the 'fastest' settings (and I tried all of them) this game throws my GPU load straight to 100%, and the card heated up to like... 80C. I've literally NEVER had it go that high in any other game. This is a HD6950 so it's not a slacker either.

I realise it's early alpha and whatnot.
I'm just asking that you guys really prioritise optimising the game a bit, as it is putting waaay more strain on the hardware than it should given what it is.
Showing 1-13 of 13 comments
< >
h34lz Jul 13, 2013 @ 5:58pm 
I also have a problem similar to this running with a gtx 670. I normally only hit the 77-80C mak when running 2 screens with tons of foliage effects and ambient occlusion. Here I'm hitting that mark in the ship builder. Could this be a vsync issue?

Going to try using nvcp to force some graphical restrictions and see if that helps.

It would be nice to not worry about early-access burning my pricey graphics hardware, y'know?
Last edited by h34lz; Jul 13, 2013 @ 6:04pm
Error Jul 13, 2013 @ 5:58pm 
I have an Nvidia card and I'm using 1920x1200 with "Fantastic" and it is running fine. One thing that I did do that may have helped to keep the heat down was force Vsync through the control panel since I didn't find that option within the game yet.
The Dragon Jul 13, 2013 @ 5:59pm 
Did you put a lot of pieces on your ship, as far as i know the models for the ships parts aren't all that optimised so don't just don/t put too much on (just for future reference if you did)
Dakili Jul 13, 2013 @ 6:26pm 
You know this game barely use anything from your GPU but is mostly hard on the CPU?

Each module has one physical collider. Each weapon has 2. Put too many of them, and you'll kill your computer. Restrict yourself.
LumberingTroll  [developer] Jul 13, 2013 @ 6:27pm 
Dakili this isnt much of an issue any more since 0.018.
Dakili Jul 13, 2013 @ 6:30pm 
Originally posted by LumberingTroll:
Dakili this isnt much of an issue any more since 0.018.

I know the changes you made, but I'm pretty sure having too many modules has an impact on his problem.
LumberingTroll  [developer] Jul 13, 2013 @ 6:48pm 
If it does its not because of the colliders is my point.
DryEagle Jul 13, 2013 @ 6:53pm 
I had like... a cockpit and one thing behind it at that point. It was nothing to do with number of modules on my ship. I'll try the vsync thing though.
Daedric Dave Jul 14, 2013 @ 5:23am 
How did you fix this issue? Did forcing Vsync work? When I try and force it, the game stills runs at 300FPS+ and makes my GPU hot.
DryEagle Jul 14, 2013 @ 5:46am 
Yep, enabling vsync force in graphics control panel did nothing to affect it.
Galdere Jul 14, 2013 @ 5:52am 
Please limit this, it's unnecessary and damaging.
Last edited by Galdere; Jul 14, 2013 @ 5:52am
Error Jul 14, 2013 @ 5:52am 
I should have provided more details, as I rarely use the real control panel for the graphics drivers. I'm using D3DOverrider that forces Vsync and Triple Buffering for Direct3D games, which is what I use for most games because rarely do games properly implement Vsync when running in windowed-mode correctly. D3DOverrider takes care of all that for me so it is automatic.
DryEagle Jul 14, 2013 @ 6:01am 
D3Doverrider did it, thanks a lot shatter!
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Jul 13, 2013 @ 5:50pm
Posts: 13