Chubzdoomer Aug 3, 2013 @ 1:06pm
[TIP] Perfomance Increase!
If you purchased Wolfenstein 3D and played it without making any modifications, you probably noticed that it's somewhat jittery and not butter smooth like it should be. The source of the problem lies within the game's DOSBox configuration file.

To correct this, first navigate to the following directory:
Program Files\Steam\steamapps\common\Wolfenstein 3D\base

Now, find the wolf3d.conf file and open it with Notepad.

In the [sdl] section at the top, change fulldouble from true to false. This alleviates screen flickering caused by the next tweak and makes the game's sprites less blurry and more "crisp" like they should be.

Finally, scroll down until you reach the [cpu] section. Change cycles from auto to max and save your changes before closing the file.

The next time you play Wolfenstein 3D, it should run smooth as butter. This never should have been an issue and could've been avoided had the folks behind the Steam releases at id Software actually tested their games and compared them to how they were years ago on machines that were capable of running them properly. That little rant aside, I hope that you enjoy this little tip and that it makes your Wolfenstein 3D sessions more enjoyable!
Last edited by Chubzdoomer; May 4 @ 5:37pm
Showing 1-14 of 14 comments
< >
Zipster Aug 3, 2013 @ 3:58pm 
Thank you for this and was searching everywhere as I played the original Wolf-3D game (first game that got me into PC gaming long ago) and it was never as jerky as how this was above without the fix you found. Thank you so very much! :D
macluke77 Aug 3, 2013 @ 4:42pm 
Not working for me under w8
Thr only thing i have to do it to set up at false this parameters:

fulldouble=false

after running smooth :)
Chubzdoomer Aug 3, 2013 @ 11:13pm 
Originally posted by macluke77:
Not working for me under w8
Thr only thing i have to do it to set up at false this parameters:

fulldouble=false

after running smooth :)

I just tested it out here on my Windows 7 PC and although setting fulldouble to false did nothing for the game's choppy frame rate under the default settings, it did remove some of the blurriness from the sprites and also alleviated some of the flickering and stuttering when cycles is changed to max.

In short: For me, the best combination is to have cycles set to max and fulldouble set to false. It's nearly flawless with those settings!

I've added that information to my original post.
Last edited by Chubzdoomer; Aug 3, 2013 @ 11:13pm
Zipster Aug 3, 2013 @ 11:35pm 
Originally posted by Chubzdoomer:

I just tested it out here on my Windows 7 PC and although setting fulldouble to false did nothing for the game's choppy frame rate under the default settings, it did remove some of the blurriness from the sprites and also alleviated some of the flickering and stuttering when cycles is changed to max.

In short: For me, the best combination is to have cycles set to max and fulldouble set to false. It's nearly flawless with those settings!

I've added that information to my original post.

I would have to say the above is correct, I tested this today as well and Wolf 3D ran even smoother with my Razer DeathAdder mouse than what the early Compaq Presario computer ran this game back in the day lol.
pendulousphallus Sep 9, 2013 @ 4:06pm 
I'm still having some issues after messing around with the config file the way you guys described. I have an Acer Aspire One Netbook and am running it with Windows 8. The game plays with really inconsistent speed. Is there anything else I can do to the config file to make it smoother on my underpowered system?

--EDIT--

Made a mistake and edited the wrong config file. Be sure that it is the Wolf3d config and not the DOSBox config.
Last edited by pendulousphallus; Sep 9, 2013 @ 4:19pm
MajorBeaner Dec 2, 2013 @ 10:46pm 
Thank you so much, I almost thought I had thrown my money away.
KandoYam Dec 28, 2013 @ 1:35am 
Thank you :)
Trevorzan Jan 18 @ 11:39am 
Sir, you rock!
I applied both configurations and it's working much better!
ForbiddenDong Feb 8 @ 7:58am 
Totaly works, thanks so much. Im still having trouble with the audio lagging but other than that runs great now.
Valrrock (っ˘ω˘ς) May 3 @ 7:35pm 
My Respect, Thank You (:
Sky Mantis X May 4 @ 12:26am 
Thanks for this fix, wish that ID did it them selfs....sigh. Thanks!
SiM0N May 4 @ 1:47am 
These changes made absolutely no difference for me at all. Windows 7 user.
Chubzdoomer May 4 @ 10:15am 
Originally posted by SiM0N:
These changes made absolutely no difference for me at all. Windows 7 user.

Sorry to hear about that. :-( Odd..
Crusader_bin May 4 @ 4:33pm 
Thanks for the info, on Windows 8.1 - the game works like a charm now.
Surprised it was left like that. I got suspicous in the menus. And knew it's wrong during first 10 seconds of playing.
Showing 1-14 of 14 comments
< >
Per page: 15 30 50