Stafa Jul 6, 2014 @ 4:47pm
Runs extremely slow
This game runs extremely slow on my pc, it's very unplayable. I recently upgraded to Windows 8, could that be the reason why? Anyone else with Windows 8 having issues with this game running slowly?
Showing 1-9 of 9 comments
< >
Rcj8993 Jul 6, 2014 @ 8:34pm 
im getting this too,
it ran fine on windows 7, but on 8.1 im having issues
music is laggy as hell and the screen is zoomed in.
Rcj8993 Jul 6, 2014 @ 8:36pm 
im going to try downloading the newest version of dosbox to see if it fixes this.
Rcj8993 Jul 6, 2014 @ 8:44pm 
oh wow, this game uses Dosbox 0.71
newest version is 0.74
downloading the newest version didnt help sadly
Rcj8993 Jul 6, 2014 @ 8:57pm 
this will help here http://wolfenstein.wikia.com/wiki/DOSBox

but if you use OpenGl mode, use Normal3X for the scalar.
Last edited by Rcj8993; Jul 6, 2014 @ 9:17pm
Rcj8993 Jul 6, 2014 @ 9:19pm 
but id suggest using this
http://maniacsvault.net/ecwolf/download.php

(has some issues with controllers, tested with a xbox and a logitech controller,
keeps registering buttons as AD0, so nothing will work right with a controller)

best wolfenstein port ever
Last edited by Rcj8993; Jul 6, 2014 @ 10:15pm
Stafa Jul 6, 2014 @ 11:11pm 
thanks
Vulcan Assassin Jul 7, 2014 @ 7:03am 
Windows 8 is probably why it's running slow for you. By default the Dosbox config sets the output to use DirectDraw (ddraw) and Windows 8 breaks directdraw for a lot of old games. I had the same issue.

How to fix it: You need to edit the proper dosbox config files and change the output from directdraw to something else, such as opengl, surface, or overlay.

How to do that: It's usually just finding and editing the dosbox.conf file, but that won't work, or at least it didn't for me. For some reason there are 2 other dosbox config files in the game directory, tweaking them fixed it for me.

1. Open to the game directory "/Program Files (x86)/steam/steamapps/common/Wolfenstein 3D/base/

2. Open the file "wolf3d.conf" in notepad.

3. Change "output=ddraw" to "output=opengl".

4. Change line "scaler=none" to whatever scaler you like best (someone above recommended "scaler=normal3x")

* I also did this for the dosbox.conf file in the game directory as well. I didn't mess with wolf3dc.conf, becasue editing wolf3d.conf and dosbox.conf fixed it for me.

Hope that helps!

Last edited by Vulcan Assassin; Jul 7, 2014 @ 7:21am
Stafa Jul 7, 2014 @ 9:45am 
Thanks, that fixed the issue!
jbejarano Jul 20, 2014 @ 9:24am 
if that fix doesnt work for someone, what I did was change "fulldouble=true" to "fulldouble=false" in the conf file for the game itself (i left the dosbox conf as is) and it ran fine for me. (windows 8.1 pro)
Showing 1-9 of 9 comments
< >
Per page: 15 30 50