LemonCake Mar 27 @ 5:17am
PLEASE HELP!
so i bought the game and downloaded it when it finnished i clicked play and the 1st time set up came up it said "direct X 9.0 web setup 1 of 1" it has been loading on this for A LONG TIME! it never loads for ever it just stays on this 1st time set up please help
Showing 1-3 of 3 comments
< >
The doctor is in Mar 27 @ 6:50am 
verify game cache

post details about your hardware (cpu, gpu, memory) and os (windows version n if 32/64 bits)

make sure windows, drivers, c/c++ runtime, .net runtime, directx runtime, etc are all updated

===========================
also make sure box exceeds minimum requirements
http://store.steampowered.com/app/226700/
System Requirements

Minimum:
OS:Windows Vista/Windows 7 (enhanced for 64-bit OS)
Processor:2.4 GHZ Quad Core or better
Memory:4 GB RAM
Graphics:Nvidia GTX 460/ATI Radeon HD 5850
DirectX®:9.0
Hard Drive:3 GB HD space
Sound:Windows Compatible Sound Card
Other Requirements:Broadband Internet connection

keep in mind if you have a laptop components such as cpu/gpu are 1/2 generations behind desktop equivalent

also this game needs 64-bit os with 8gb of ram and a very good 4 core cpu + gpu with 1gb video ram

===========================
look at this thread on tweaking the game and increasing performance
http://steamcommunity.com/app/226700/discussions/0/846959179199964105/

===========================
if client performance problems

run resource monitor or better msi afterburnder + hwinfo to see where bottleneck is
LemonCake Mar 27 @ 9:39am 
i have an alienware X51 so all my requirments should be good
The doctor is in Mar 27 @ 10:25am 
who knows without u posting details about your hardware (cpu, gpu, memory) and os (windows version n if 32/64 bits)
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Mar 27 @ 5:17am
Posts: 3