The Absolute Wanker Sep 23, 2013 @ 4:02am
Poorly Optimised?
I get really horrible frames on my GTX 770, AMD 8350 FX set up when PyhsX is enabled along with AA.

Is this expected?
Showing 1-9 of 9 comments
< >
Jammy Bastard Sep 23, 2013 @ 9:54am 
Physx is poorly done, just disable it.
The Absolute Wanker Sep 23, 2013 @ 10:29am 
Originally posted by NwptRaisins:
Physx is poorly done, just disable it.

But i've seen people play it without problems?
Jammy Bastard Sep 23, 2013 @ 11:30am 
Then keep it on and lower/disable the AA.
Rustea Dec 12, 2013 @ 4:08am 
Physx is an nvidia thing, it's only emulated on amd's thus poor performance.
uremytoy Dec 12, 2013 @ 10:01am 
physx works poor even on high end nvidia cards diasble it ^^
raubrey Dec 16, 2013 @ 3:01am 
I haven't had any problems with the game running it on high settings with a 460 v2 -- running an AMD FX8350. But for as long as AA was an option in games I turn it off or keep it really low. I don't use PhysX for reason described.
a.k.a. Dead Dec 21, 2013 @ 8:01am 
The op's GTX 770 should destroy just about any current game maxed-out obviously. I don't have any performance issues at all running the game maxed-out in 1080p with physx enable, which is strange because my specs are a bit less than his.

W8.1 x64
I5 3570k OC 4.4
8 gigs DDR3 1600 ram (1.5v, Cl9, 9-9-9-24, XMP OC 1650)
2 gig MSI GTX 760 Twin Frozr OC (PCI-E 3.0 slot 1, OC 1300 core)
1 gig MSI GTX 650 (PCI-E 3.0 slot 2, for physx)

Perhaps having a dedicated card for physx actually helps considerably more with performance in Sacred 2, instead of the main GPU and/or the CPU having to do all of the calculations.

I hope you get it solved op, and post back if you do. :)


Edit:

Op, double check your nVIDIA control panel settings, and make sure that your GTX 770 is being used for physx, otherwise the game may try and use your AMD CPU, and while the 8350 should be powerful enough to get the job done, in this case it may not be optimal.

:)
Last edited by a.k.a. Dead; Dec 21, 2013 @ 8:07am
Nuku Dec 21, 2013 @ 8:30am 
Originally posted by Robowski:
I get really horrible frames on my GTX 770, AMD 8350 FX set up when PyhsX is enabled along with AA.

Is this expected?
I'm not sure what is causing this for you, maybe some AMD driver issue?
I also have a GTX 770 and the game works perfectly, i got everything on max settings ingame, 4x AA, Physx on and in 2560x1440 (didn't do anything in nvidia control panel for this game)
I only notice a small dip in fps when things get hectic on screen but then even only if i have the camera at it's lowest point.

EDIT: ah yes, be sure physx is set to your videocard instead of the cpu like Joh Mahmah mentioned.
Last edited by Nuku; Dec 21, 2013 @ 8:32am
raubrey Dec 21, 2013 @ 4:27pm 
Originally posted by Joh Mahmah:
and while the 8350 should be powerful enough to get the job done, in this case it may not be optimal.


Do you even know what you're talking about?
Last edited by raubrey; Dec 21, 2013 @ 4:28pm
Showing 1-9 of 9 comments
< >
Per page: 15 30 50