Shadow Warrior Sep 6, 2013 @ 9:31am
I can't start the game
Just a few days ago Sacred 2 (Gold) worked just fine, but today for some obscure reason it completely refuse to start! No loading screen, no error message, no anything! Please, help me.
Showing 1-8 of 8 comments
< >
Jammy Bastard Sep 6, 2013 @ 9:59am 
Verify the cache
Shadow Warrior Sep 6, 2013 @ 10:05am 
Originally posted by Nwpt | Raisins:
Verify the cache
Which cache?
Jammy Bastard Sep 6, 2013 @ 10:14am 
Right click the game in Steam
Go to properties
Local Files
Verify Integrity

Wait 10 minutes or so and Steam will fix whatever file broke.
Shadow Warrior Sep 6, 2013 @ 10:21am 
Thanks!
26 files failed
Shadow Warrior Sep 6, 2013 @ 10:33am 
Downloaded.
Now 100% of files ar OK, but game still refuse to start.
Any other ideas?
Jammy Bastard Sep 6, 2013 @ 1:11pm 
Windows 7? Set the game to compatibility for XP SP2 or 3.
Jammy Bastard Sep 6, 2013 @ 1:56pm 
Go back to properties and click on 'Set Launch Options' and add these (copy/paste).

-nocpubinding -skipopenal

Shadow Warrior Sep 7, 2013 @ 2:28am 
Problem resolved.
1. Something terribly wrong happened with my videodriver. Even Crimsonland and Angry Birds refused to start. Driver online updater fixed it.
2. Also something happened with DirectX. When I attempted to start game by Sacred2.exe it give message about missing file <something>36.dll
MS DirectX Web Setup resolved it.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Sep 6, 2013 @ 9:31am
Posts: 8