Enternight Aug 7, 2013 @ 8:02am
Failed to start game (app already running)
Hello,

I just got Sacred 2 Gold and I can play it with the latest community patch without a problem. However, whenever I launch the game, it stays in some kind of "launched" state for Steam, even though I don't see it anywhere in my processes. Steam pops an error window saying "Failed to start game (app already running)" when I try to start it again.

I can't even close Steam, as it asks me to close Sacred 2 first, which isn't running. I have to kill the Steam process manually.

What can I do ? I have already tried putting the game (and its patcher) in XP compatibility mode and it didn't help...

Thanks in advance !
Last edited by Enternight; Aug 7, 2013 @ 8:02am
Showing 1-15 of 25 comments
< >
Ferns Aug 7, 2013 @ 9:11am 
1.Go to your steam library \steamapps/common/sacred gold 2/redist/physx
and install: PhysX_9.10.0513_SystemSoftware

(Even if you have a radeon card)

2. Reboot your computer

3. Run Sacred 2 gold as you would run any other game from Steam.

4. Enjoy

(This worked on my system. CPU: AMD 8320FX, GFX: MSI R7950 3GB, OS: Win 8)
Enternight Aug 7, 2013 @ 10:13am 
Thank you for your answer.

The thing is, I don't get any kind of error about PhysX, which was probably already installed by a few dozens games.

I will still give it a try. I'll let you know if it worked !

Edit : scratch that, when I try to install the PhysX driver, it says it won't, because my current version is more recent.
Last edited by Enternight; Aug 7, 2013 @ 10:14am
Ferns Aug 7, 2013 @ 10:38am 
Sorry to hear it didn't work.

I didn't get the error either - When starting the game from the Steam launchbar.
But when I launched the game from its folder it gave me the physX error. Maybe it will give you a hint about what is wrong, in your case,, if you try to launch it the same way.

I hope you'll succeed :)
Enternight Aug 7, 2013 @ 1:42pm 
Nothing seems to work ! I have tried disabling the in-game overlay, crashing the game on purpose, etc.

I'm sure someone out there knows how to fix this !
peterrandle Aug 7, 2013 @ 2:36pm 
You dont have tracks eraser do you.That caused my game to do that same thing had to launch it from the game folder.Another one was games for windows was out of date.Or read post how to fix startup errors thats got some good info
Last edited by peterrandle; Aug 7, 2013 @ 2:42pm
Enternight Aug 7, 2013 @ 4:28pm 
To clarify, launching the game from its folder still launches it via Steam. It doesn't give me any kind of error. The only problem is that I end up with the game leaving Steam in a state that makes it believe Sacred 2 is still running... indefinitely.
austinwarner21 Aug 7, 2013 @ 11:37pm 
I have this same problem :(
Nirvair Aug 8, 2013 @ 8:06pm 
CTRL+ALT+DEL > Kill Sacred 2 application.
Enternight Aug 9, 2013 @ 7:19am 
Thank you Zethell, but neither of your answers apply to the problem I am having.
Foyrexjr Aug 9, 2013 @ 9:30am 
i think it is a very big problem
Zacletus Aug 10, 2013 @ 1:24pm 
Is it trying to run the game as administrator? I know that when I was trying to get Bioshock to run in XP compatibility mode it ran into a similar issue as what you're saying.

Easy fix though, if that's the case. Just run steam as administator and then it should work.

Edit: ah, never mind. Seems that that's the first thing on the bug hunter guide.
Last edited by Zacletus; Aug 10, 2013 @ 1:30pm
StinkyCyka Aug 11, 2013 @ 11:13pm 
Took a while to download, but after it said "performing first time set-up", the box disappeared, and the game failed to start. I also have the "app already running problem", and bought it from the recent Deep Silver Humble Bundle (like most everyone else recently). It also doesn't show up in the Task Manager. Even though both me and my brother bought it, it only works on his computer, but fails on mine. Hope this gets resolved soon...
Mt. Dewid Aug 12, 2013 @ 1:15am 
I have the same problem, I wish they could fix this
ajdean Aug 13, 2013 @ 7:59pm 
Same problem here... tried everything I can come up with
Showing 1-15 of 25 comments
< >
Per page: 15 30 50