Sacred 2 Gold

Sacred 2 Gold

Game crash on graphics change.
My machine should run this game fine, considering its age.

But the game defulted to medium and tbh i want it full as i want to play the game in all its glory.

But for some strange reason the game crash's without any idication of why when ever i change any graphics setting and then try to apply it. while applying the new setting its just dies.

Has anyone else had this issue and found a fix or work around?

My specs are not amazing but like i said the games old and should run fine.

Win 7 64 bit.
2nd gen intell core i3 2.2ghz
4gb ram
1gb geforce 315m

FYI its not a my computer cannot run it on high issue its a client crash issue.

I have installed the game in ADMIN mode all my games are.

Im guessing before releasing this on steam they didnt optimise it for modern machines
and windows 7
< >
Showing 1-4 of 4 comments
CrazyNando Aug 5, 2013 @ 3:04am 
have this issue only with activated xfire overlay! Maybe its a issue with an other overlay tool like fraps if you dont use xfire. so try to deactivate this for resolution changes!
Last edited by CrazyNando; Aug 5, 2013 @ 3:09am
its not that i dont use xfire. the only overlay i would have would be my mumble overlay (mumble is a voip program like teamspeak or raidcall fyi) but i get the issue when its not up anyway.
pcguru Feb 3 @ 1:59pm 
I don't know if anybody will have this Problem after 2016, but still. As soon as I read the thing about "xfire overlay" my mind jumped directly to "steam overlay". So I went and disabled it for the game (Right-Click the Game in the Library->Properties->first thing you should see, really, uncheck the box). Before I couldn't even go windowed, but now everything worked fine.

So in conclusion: This game sucks at running with any kind of overlay enabled. At least that's how it seems.
Stealth Feb 5 @ 10:30am 
mine only ctd when i try to enable vsync
< >
Showing 1-4 of 4 comments
Per page: 15 30 50