eyezex Jul 22, 2013 @ 1:47pm
CTD Fix!! I am so happy i thought i would share this in its own thread
i just gotta say i absolutely LOVE Sacred 2 Gold!!
the only prob i had was CTD at load screen but i found this fix and its been working like a dream.

All i did was add:

-skipopenal -nocpubinding

to launch options in steam settings. Im so happy i could do cartwheels. Anyway i got the idea to try that because the fix i found said to add that to a shorcut you create on the desktop and it worked so i went ahead and tried that too.
Here's the link:

http://forums.steampowered.com/forums/showthread.php?t=1464623

And the post is at or near the bottom of the thread:
____________________________________________________________________

These 2 things fixed the crashes to me (on Win7 64bit):

-FIRST THING-
source: http://www.mokonamodoki.com/sacred-2-on-windows-7
1.Create a shortcut to the Sacred 2 executable. You’ll find it in the game directory, in another directory called ‘system’. For me, it is: D:\Games\Steam\SteamApps\Common\Sacred 2\System\Sacred2.exe
2.Put the shortcut on your desktop, or somewhere handy.
3.Right click the shortcut and select properties
4.Click the Shortcut tab
5.In the Target field, you need to add the following: -skipopenal -nocpubinding. The contents of my Target field look like this: "D:\Games\Steam\SteamApps\common\sacred 2\system\sacred2.exe" -skipopenal -nocpubinding
6.Click Apply and Click OK.
7.Double click the shortcut and play Sacred 2.

-SECOND THING-
source: http://forum.sacred2.com/showpost.ph...38&postcount=1
For those with Patch 2.43 crashes using Windows 7
If you are experiencing crashing/stuttering using the 2.43 patch on Windows 7 can you please try the following:

Right click the Sacred 2 shortcut on your desktop and click 'properties'. In the windows that opens click the 'compatability' tab and check the 'run this program in compatibility for' box, selecting Windows XP(service pack 3) from the drop down menu. Also check the 'run this program as an administrator' box. Click apply/ok and then run the game, this should stop the crashing/stuttering.

Last edited by playthegame: 12-21-2011 at 10:47 AM.
_____________________________________________________________

i hope this helps anyone who was having trouble,
this is by far way to good of a game to pass up.
Showing 1-6 of 6 comments
< >
Reventage Jul 22, 2013 @ 1:57pm 
you even made a thread for it :) anyway good fix, hope this helps if they can't do it the way i posted :)
eyezex Jul 22, 2013 @ 4:17pm 
Exactly, this actually includes your fix hehe

-SECOND THING-
source: http://forum.sacred2.com/showpost.ph...38&postcount=1
For those with Patch 2.43 crashes using Windows 7
If you are experiencing crashing/stuttering using the 2.43 patch on Windows 7 can you please try the following:

Right click the Sacred 2 shortcut on your desktop and click 'properties'. In the windows that opens click the 'compatability' tab and check the 'run this program in compatibility for' box, selecting Windows XP(service pack 3) from the drop down menu. Also check the 'run this program as an administrator' box. Click apply/ok and then run the game, this should stop the crashing/stuttering.

thanks fo the reply
[KdN]-King_Kosher Jul 23, 2013 @ 10:35am 
Nice guide,always a pleasure to read about people that fixed their problems and SHARE the solution.However,here is food for your thought:

Why do you create a shortcut and add startup parameters when you can set them directly via Steam? [1. go to your game library,rightclick the game-->2. pick properties,there pick 3. "set launch options"]
Cut down from a 7 point plan with a lot of hassle to a fast 3 point plan.

You can handle this as you like but if its already in the Steamclient,why not use it.

Have fun @ Sacred 2 guys
eyezex Jul 23, 2013 @ 12:03pm 
hehe that's what i said at the beginning of my thread:

All i did was add:

-skipopenal -nocpubinding

to launch options in steam settings.

Thank you though for spelling out the steps to get there
[KdN]-King_Kosher Jul 26, 2013 @ 9:35am 
argh,you're right.my brain didn't work until the "First steps" part where the method used is with shortcuts.mea culpa
eyezex Jul 26, 2013 @ 3:57pm 
hehe not a prob, call it a brain fart lol
Showing 1-6 of 6 comments
< >
Per page: 15 30 50