Reventage Jul 19, 2013 @ 3:53am
Sacred 2 works just fine, got a problem type it here. Got more fixes type one here as well
(*READ -most fixes are in the chat*) If the game lag/freeze every 2-5 second, game won't start you need compability mode on.
Sometimes you need to reinstall the game and have compability mode (Xp pack 2) before start
Edit09/08/13: Also the steam client beta, the most resent changes can affect the game. Thank you Torinir and .:Rafael:.
Edit: I won't type here no more. I'm done
Last edited by Reventage; Aug 26, 2013 @ 10:02am
Showing 1-15 of 27 comments
< >
Reventage Jul 19, 2013 @ 3:54am 
It it still lags restart your pc
King_Kosher Jul 19, 2013 @ 11:40am 
Any idea what to do when the Community patch installer bugs around and refuses to install because "wrong language" and "wrong version" ?
Reventage Jul 19, 2013 @ 11:52am 
It's really hard to say, you have to take that with someone who knows mods because i never had that problem but it it's the wrong V. it's eather because the patch isn't for europe and your copy of the game is an europe V. or the mod/patch isn't for your current V. (V aka version)
Reventage Jul 19, 2013 @ 11:54am 
To get around or fix that you have to take that with someone who fixed it or the guy who made it, sorry i can't help more but hopfully that gives some info
Denearys Jul 21, 2013 @ 12:31am 
i have bigger problem... my steam copy of Sacred 2 Gold is not working at all... during first run after the installation complete, ive seen the menu of the game so i start as always from changing my graphic options... when i changed default resolution for smaller and used the windowed option, it accepted my changes and i noticed that window option is not full screen-windowed, so i wanted click it back to full screen mode, and than game just hide to my task bar to never be back on screen again... i did what steam reccomended, i deleted some folder in steam loc, i restarted pc , it didnt help... so i did uninstall game totally and reinstall it again but there is no effect so far... those steam refund failure products? coz as far i know this steam version should work with windows7... please send me some tips or advise. Thanks
Reventage Jul 21, 2013 @ 7:56am 
Originally posted by Denearys:
i have bigger problem... my steam copy of Sacred 2 Gold is not working at all... during first run after the installation complete, ive seen the menu of the game so i start as always from changing my graphic options... when i changed default resolution for smaller and used the windowed option, it accepted my changes and i noticed that window option is not full screen-windowed, so i wanted click it back to full screen mode, and than game just hide to my task bar to never be back on screen again... i did what steam reccomended, i deleted some folder in steam loc, i restarted pc , it didnt help... so i did uninstall game totally and reinstall it again but there is no effect so far... those steam refund failure products? coz as far i know this steam version should work with windows7... please send me some tips or advise. Thanks

steam/steamapps/common/sacred 2/redist run them all
/direcrX/DXSETUP.exe
/PhysX/Physx_9.10......SystemSoftware
/VC/vcredist_86 (Most imoprtant)
Don't forget to set the sacred 2.exe as compability mode can be found in /sacred2/system/sacred2.exe run it as xp pack 2, if it still doesn't work remove the game and install again, all settings will still be there so just start it (dont forget to restart your pc) if this deosn't help you, you might need to change a script or set the install in xp mode
Space*elf Jul 22, 2013 @ 1:39pm 
i just gotta say i absolutely LOVE Sacred 2 Gold!!
the only prob i had was CTD at load screen but i found this fix and its been working like a dream.

All i did was add:

-skipopenal -nocpubinding

to launch options in steam settings. Im so happy i could do cartwheels. Anyway i got the idea to try that because the fix i found said to add that to a shorcut you create on the desktop and it worked so i went ahead and tried that too.
Here's the link:

http://forums.steampowered.com/forums/showthread.php?t=1464623

And the thread is at or near the bottom:

These 2 things fixed the crashes to me (on Win7 64bit):

-FIRST THING-
source: http://www.mokonamodoki.com/sacred-2-on-windows-7
1.Create a shortcut to the Sacred 2 executable. You’ll find it in the game directory, in another directory called ‘system’. For me, it is: D:\Games\Steam\SteamApps\Common\Sacred 2\System\Sacred2.exe
2.Put the shortcut on your desktop, or somewhere handy.
3.Right click the shortcut and select properties
4.Click the Shortcut tab
5.In the Target field, you need to add the following: -skipopenal -nocpubinding. The contents of my Target field look like this: "D:\Games\Steam\SteamApps\common\sacred 2\system\sacred2.exe" -skipopenal -nocpubinding
6.Click Apply and Click OK.
7.Double click the shortcut and play Sacred 2.

-SECOND THING-
source: http://forum.sacred2.com/showpost.ph...38&postcount=1
For those with Patch 2.43 crashes using Windows 7
If you are experiencing crashing/stuttering using the 2.43 patch on Windows 7 can you please try the following:

Right click the Sacred 2 shortcut on your desktop and click 'properties'. In the windows that opens click the 'compatability' tab and check the 'run this program in compatibility for' box, selecting Windows XP(service pack 3) from the drop down menu. Also check the 'run this program as an administrator' box. Click apply/ok and then run the game, this should stop the crashing/stuttering.

Last edited by playthegame: 12-21-2011 at 10:47 AM.
_____________________________________________________________

i hope this helps anyone who was having trouble,
this is by far way to good of a game to pass up.
Last edited by Space*elf; Jul 22, 2013 @ 1:42pm
Reventage Jul 22, 2013 @ 1:54pm 
Thanks for posting, myself i don't even need all that to fix the game, even on win 8. But for those that can't play the game with my fix that should help. Thanks again eyezex for posting that, maybe helps allot of players out there having trouble starting it.
Space*elf Jul 22, 2013 @ 4:20pm 
This is so awesome of a game, i had the boxed version but was unable to play it for years as i couldnt find a fix and i bought the steam version on a gamble.. thanks for all your efforts to make this game so much more enjoyable.

i am hesitant atm to install the community patch as its working so well at the time being
Reventage Jul 22, 2013 @ 4:40pm 
Never used that patch, game still runs perfect for me :) But i'll might try it, it might get even better!
cellyson Aug 8, 2013 @ 5:32am 
game is working, but i continue to get a windows error after a few mins, saying the windows game client has encountered an error and is shutting down.. any idea how to fix this?
Reventage Aug 8, 2013 @ 5:52am 
Originally posted by cellyson:
game is working, but i continue to get a windows error after a few mins, saying the windows game client has encountered an error and is shutting down.. any idea how to fix this?
when does it stop working? when you save, travel to new places, when you're fighting, randomly?
Last edited by Reventage; Aug 8, 2013 @ 6:00am
Reventage Aug 8, 2013 @ 5:59am 
Originally posted by cellyson:
game is working, but i continue to get a windows error after a few mins, saying the windows game client has encountered an error and is shutting down.. any idea how to fix this?
you could try to reinstall the game and change settings in-game, also if these programs didn't run in the first place
steam/steamapps/common/sacred 2/redist
/direcrX/DXSETUP.exe
/PhysX/Physx_9.10......SystemSoftware
/VC/vcredist_86
then run them now
Last edited by Reventage; Aug 8, 2013 @ 5:59am
Reventage Aug 8, 2013 @ 6:04am 
A new fix i found is this:
You will need to have the Windows setting on; Show all Hidden Files and Folders. To change the Hidden Files/Folder setting open any folder-->Click Alt Key-->Tools-->Folder Options-->View-->Click "Show hidden files and folders".
Go to the folder:
(64 Bit Windows)
''C:\Users\<YOUR_USER_NAME>\AppData\Local\Ascaron Entertainment\Sacred 2
or
(32 Bit Windows)
C:\Documents and Settings\<YOUR_USER_NAME>\Local Settings\Application Data\Ascaron Entertainment\Sacred 2''
Delete options.txt if it is found in the folder.
Create a new text file using Notepad called optionsCustom.txt. (Easiest way to create a new Text Document is to Right Click in the folder-->New-->Text Document.)
Add the below code into the empty optionsCustom.txt file you just created and save it:

Code:
settings.usePhysHW = 0
render.d_patchPhysics = 0
video.detail_physx = 0
Sometimes you need to delete the options.txt file in that same folder in order for the optionsCustom settings to take effect. A new options.txt file will be generated by the game the next time you play but with the optionsCustom settings accounted for. Keep in mind that deleting the options.txt file will mean you will need to re-enter your preferred settings in the game's menu of options such as graphics, sound and control options. You only need to delete the options.txt file when you make a change to your optionsCustom.txt file.
Heister Aug 8, 2013 @ 6:25pm 
I was playing yesterday, today game won't run...

This is just incredible.
Showing 1-15 of 27 comments
< >
Per page: 15 30 50
Date Posted: Jul 19, 2013 @ 3:53am
Posts: 27